Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38

Thread: shutdown sound

  1. #11
    Join Date
    Nov 2006
    Beans
    465

    Re: shutdown sound

    Ok, I added "home" to my path, & it worked!! Thankyou dcstar!! But I still hear the system beep at the same time This brings up a question, though.... Would it work if I put "aplay" instead of "bplay"?

    Quote Originally Posted by CheeseQueen452 View Post
    I tried this & it didn't work. Btw, I'm using Linux Mint which, under the hood, is basically the same as Ubuntu, so if it works in Ubuntu it should work in Mint.... Anywho, I've had no shutdown sound like many others here, I just hear a beep instead. So I attempted this procedure unsuccessfully, & I'm wondering if I entered the wrong path? I put "bplay /username/filename.wav".... should I put "home" before the username? If anyone can help me get this issue fixed, I'd greatly appreciate it!

  2. #12
    Join Date
    Nov 2006
    Beans
    465

    Re: shutdown sound

    It still works! Ok, now I just have to get rid of that beep....

    Quote Originally Posted by CheeseQueen452 View Post
    Would it work if I put "aplay" instead of "bplay"?

  3. #13
    Join Date
    Apr 2007
    Location
    Hartford City, Indiana US
    Beans
    1,299
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: shutdown sound


    Re: shutdown sound
    Quote:
    Originally Posted by send4m3 View Post
    Hi.. I managed to do your step-by-step sound. Thanks... how to make it with logout sound ? please let me know in send4m3@yahoo.com

    Thank you
    http://ubuntuforums.org/showthread.php?t=25857

    I now have a (global) logout sound in my 8.04 system by doing the following:

    1. Installing the bplay package;
    2. Add the following to /etc/gdm/PostSession/Default (just before the "exit 0"):

    Code:

    bplay /pathto-wav/logout.wav

    (or where-ever your preferred sound is)

    Hurrah!
    __________________
    Regards, David.
    I am interested in this fix, could someone explain where I might find the log off sound file? Also, a step by step instruction for doing this? I am running Mint 5 based on Hardy and now have the shutdown and restart sound thanks to the first post. Any help or details would be greatly appreciated!

  4. #14
    Join Date
    Apr 2007
    Location
    Hartford City, Indiana US
    Beans
    1,299
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: shutdown sound

    I found the sound file, is this how PostSession sould be configured because the logout sound is not working for me?

    #!/bin/sh

    PATH="/usr/bin:$PATH:/bin:/usr/bin"
    OLD_IFS=$IFS

    gdmwhich () {
    COMMAND="$1"
    OUTPUT=
    IFS=:
    for dir in $PATH
    do
    if test -x "$dir/$COMMAND" ; then
    if test "x$OUTPUT" = "x" ; then
    OUTPUT="$dir/$COMMAND"
    fi
    fi
    done
    IFS=$OLD_IFS
    echo "$OUTPUT"
    }
    bplay/usr/share/sounds/logout.wav
    exit 0

    I have bplay installed, am I missing something?

  5. #15
    Join Date
    Nov 2006
    Beans
    465

    Re: shutdown sound

    Quote Originally Posted by exploder View Post
    I found the sound file, is this how PostSession sould be configured because the logout sound is not working for me?

    #!/bin/sh

    PATH="/usr/bin:$PATH:/bin:/usr/bin"
    OLD_IFS=$IFS

    gdmwhich () {
    COMMAND="$1"
    OUTPUT=
    IFS=:
    for dir in $PATH
    do
    if test -x "$dir/$COMMAND" ; then
    if test "x$OUTPUT" = "x" ; then
    OUTPUT="$dir/$COMMAND"
    fi
    fi
    done
    IFS=$OLD_IFS
    echo "$OUTPUT"
    }
    bplay/usr/share/sounds/logout.wav
    exit 0

    I have bplay installed, am I missing something?
    Just put a space after "bplay". You can also put "aplay" instead, & it should still work.

  6. #16
    Join Date
    Apr 2007
    Location
    Hartford City, Indiana US
    Beans
    1,299
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: shutdown sound

    That kind of worked. I have the logout sound now but when I shutdown or restart, two sounds play.

  7. #17
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,509
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: shutdown sound

    Quote Originally Posted by exploder View Post
    That kind of worked. I have the logout sound now but when I shutdown or restart, two sounds play.
    Then simply remove the Logout sound in your preferences.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  8. #18
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,219

    Re: shutdown sound

    Still no logout/shutdown sound in Jaunty. It used to work just fine in Feisty years ago, but every release since has had no logoff sound. I don't understand the problem, since it's fine in other distros, so it can't be PulseAudio. It's kinda silly, but I have to say that it's a shame it hasn't been sorted. Hack workarounds, though obviously useful and empowering for the user, are not really a great solution for what is a very simple thing.

    I'm annoyed that it annoys me!
    AMD Phenom X4 945, 4Gb Crucial 800Mhz DDR2 RAM, 1Tb SATA III HDD, AMD Radeon R7 250X [Oibaf]

  9. #19
    Join Date
    Jun 2008
    Beans
    129
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: shutdown sound

    that solutin work only when you shutdown or restart in GDM login screen
    but if i shutdown with fast-user-switch-applet that solution doesn't work.
    any ideas?

  10. #20
    Join Date
    Jan 2006
    Beans
    545

    Re: shutdown sound

    i'm running
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=9.04
    DISTRIB_CODENAME=jaunty
    DISTRIB_DESCRIPTION="Ubuntu 9.04"

    and this did not work did i do something wrong or does this not work any more?

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •