Page 58 of 171 FirstFirst ... 848565758596068108158 ... LastLast
Results 571 to 580 of 1706

Thread: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support

  1. #571
    Join Date
    May 2008
    Beans
    20

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    I'm running mythbuntu 8.04 64-bit and I tried to install pulseaudio because I need a global equalizer but I don't get any program to connect to it, the sound has worked before and oss still works.

    Here was "pulseaudio -k; sleep 4; pulseaudio -vv" says
    Code:
    E: main.c: Failed to kill daemon.
    I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
    I: core-util.c: Successfully gained nice level -11.
    W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
    W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
    W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
    W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
    I: main.c: This is PulseAudio 0.9.10
    I: main.c: Page size is 4096 bytes
    I: main.c: Fresh high-resolution timers available! Bon appetit!
    I: module-alsa-sink.c: Successfully opened device equalized.
    I: module-alsa-sink.c: Successfully enabled mmap() mode.
    ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL equalized
    I: alsa-util.c: Unable to attach to mixer equalized: No such file or directory
    I: alsa-util.c: Unable to attach to mixer hw:(null): No such device
    I: sink.c: Created sink 0 "alsa_output.equalized" with sample spec "s16le 2ch 44100Hz"
    I: source.c: Created source 0 "alsa_output.equalized.monitor" with sample spec "s16le 2ch 44100Hz"
    I: module-alsa-sink.c: Using 8 fragments of size 896 bytes.
    D: module-alsa-sink.c: Thread starting up
    I: core-util.c: Successfully enabled SCHED_FIFO scheduling for thread, with priority 5.
    D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
    I: module-alsa-sink.c: Starting playback.
    I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device=equalized").
    I: main.c: Daemon startup complete.
    and "alsamixer" says
    Code:
    *** PULSEAUDIO: Unable to connect: Connection refused
    
    alsamixer: function snd_ctl_open failed for default: Connection refused
    Where is the problem?

  2. #572
    Join Date
    May 2008
    Beans
    1

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Awesome!!!

    Thanks Psyke83, you are a genius, worked perfectly for me

    BTW, took me a few minutes to figure out that I actually had to start pulseaudio. Before I did so, I was getting a "failure: connection refused" error when I opened up the pulseaudio device chooser.

  3. #573
    Join Date
    May 2008
    Beans
    20

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    So pulseaudio does not start automatically, but starting it does not fix the problem.

    Code:
    mythbox1@mythbox1-desktop:~$ pulseaudio -D -vv
    I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
    I: core-util.c: Successfully gained nice level -11.
    W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
    W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
    I: main.c: daemon startup successful.
    
    mythbox1@mythbox1-desktop:~$ alsamixer
    *** PULSEAUDIO: Unable to connect: Connection refused
    
    alsamixer: function snd_ctl_open failed for default: Connection refused
    
    mythbox1@mythbox1-desktop:~$ vlc
    VLC media player 0.8.6e Janus
    [00000344] a52 decoder: A/52 channels:2 samplerate:48000 bitrate:224000
    *** PULSEAUDIO: Unable to connect: Connection refused
    [00000289] main playlist: stopping playback
    Code:
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: main.c: This is PulseAudio 0.9.10
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: main.c: Page size is 4096 bytes
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: main.c: Fresh high-resolution timers available! Bon appetit!
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: module-alsa-sink.c: Successfully opened device equalized.
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: module-alsa-sink.c: Successfully enabled mmap() mode.
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: alsa-util.c: Unable to attach to mixer equalized: No such file or directory
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: alsa-util.c: Unable to attach to mixer hw:(null): No such device
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: sink.c: Created sink 0 "alsa_output.equalized" with sample spec "s16le 2ch 44100Hz"
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: source.c: Created source 0 "alsa_output.equalized.monitor" with sample spec "s16le 2ch 44100Hz"
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: module-alsa-sink.c: Using 8 fragments of size 896 bytes.
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: module-alsa-sink.c: Thread starting up
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: core-util.c: Successfully enabled SCHED_FIFO scheduling for thread, with priority 5.
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: module-alsa-sink.c: Starting playback.
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device=equalized").
    Aug 19 04:18:42 mythbox1-desktop pulseaudio[6910]: main.c: Daemon startup complete.

  4. #574
    Join Date
    Feb 2007
    Beans
    22

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Well, so far, I finally have sound working using your new post http://ubuntuforums.org/showpost.php...&postcount=472.

    Apparently module-hal-detect in the /etc/pulse/default.pa file was not automatically detecting my sound card. So I added these two lines to manualy detect my card in the default.pa file.

    load-module module-alsa-sink device=hw:0
    load-module module-alsa-source device=hw:0

    I also commented out the module-hal-detect line in the file. Now my default sink is alsa_output.hw_0 and my default source is alsa_input.hw_0 according to the pulseaudio manager. Before they were using RTP Multicast.

    When I give the command pulseaudio -k; sleep 4; pulseaudio -vv it stills hangs with a message and I have to Control C it. I still can't figure this out.

    Also how do you have your network settings setup in pulseaudio preferences.
    I have Enable network access to local sound devices checked. And underneath it I have Don't require notification checked (see attachment).
    Are these settings to allow other computers on a LAN access to the sound server. Any idea what the default settings are?
    Attached Images Attached Images
    Last edited by nick623; August 19th, 2008 at 04:00 AM.

  5. #575
    Join Date
    Jun 2008
    Location
    Georgetown, ON, Canada
    Beans
    56
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by psyke83 View Post
    I finally got around to setting up my PPA, and I have uploaded the newest release candidate of Flash 10, as well as ALSA & PulseAudio packages backported from Intrepid (with added tweaks and fixes from the guide included). I invite everyone to thoroughly test these packages!

    (Guide)
    So I followed the guide, no problems, except there is still some stutter -- though noticably less. I tried to open the daemon.conf file mentioned in part C of the original guide, just to tweak the numbers a bit, but it's blank now. any simple way to tweak things until perfection?

    Thanks a ton.

  6. #576
    Join Date
    May 2007
    Location
    Toronto, Canada
    Beans
    4,508
    Distro
    Ubuntu

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by psyke83 View Post
    I finally made lots of people happy!
    Thanks! Now I can have both my flash and savage 2

  7. #577
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by Vadi View Post
    Thanks! Now I can have both my flash and savage 2
    Really, that's not an accurate quote. I'm sure I also caused quite a bit of annoyance for others...

  8. #578
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by demios View Post
    So I followed the guide, no problems, except there is still some stutter -- though noticably less. I tried to open the daemon.conf file mentioned in part C of the original guide, just to tweak the numbers a bit, but it's blank now. any simple way to tweak things until perfection?

    Thanks a ton.
    The packages differ from the main guide as I appled the tweaks to the system-wide configuration in /etc/pulse. Therefore you can either edit the files in /etc/pulse/, or make a copy of the files to ~/.pulse/ , then begin editing.

  9. #579
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by nick623 View Post
    Well, so far, I finally have sound working using your new post http://ubuntuforums.org/showpost.php...&postcount=472.

    Apparently module-hal-detect in the /etc/pulse/default.pa file was not automatically detecting my sound card. So I added these two lines to manualy detect my card in the default.pa file.

    load-module module-alsa-sink device=hw:0
    load-module module-alsa-source device=hw:0

    I also commented out the module-hal-detect line in the file. Now my default sink is alsa_output.hw_0 and my default source is alsa_input.hw_0 according to the pulseaudio manager. Before they were using RTP Multicast.

    When I give the command pulseaudio -k; sleep 4; pulseaudio -vv it stills hangs with a message and I have to Control C it. I still can't figure this out.

    Also how do you have your network settings setup in pulseaudio preferences.
    I have Enable network access to local sound devices checked. And underneath it I have Don't require notification checked (see attachment).
    Are these settings to allow other computers on a LAN access to the sound server. Any idea what the default settings are?
    Perhaps your PulseAudio was already configured incorrectly before you followed this guide (the RTP settings are all disabled by default).

    I haven't set any of these options, but I made no changes in my packages that would cause different networked behaviour when compared to the official packages.

  10. #580
    Join Date
    Apr 2007
    Beans
    69

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Ok, so I followed the guide from post #472 in this topic. I was having flash problems where Firefox would either crash or the flash box (like in a Youtube video) would just be gray, sometimes with sound coming out.

    I was told that the process outlined in post 472 would fix that issue, so I followed it. Now most, if not ALL flash videos do not work. Youtube displays a message that "We're sorry, this video is no longer available" on ALL videos. MySpace video tells me that I need flash installed.

    Flash IS installed because I can see simple flash items & some sites show flash videos/flash content. I don't know what to do. There are too many posts in this thread & I'm feeling lost & overwhelmed just reading. =[

Page 58 of 171 FirstFirst ... 848565758596068108158 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •