Page 53 of 171 FirstFirst ... 343515253545563103153 ... LastLast
Results 521 to 530 of 1706

Thread: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support

  1. #521
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by fogelfink View Post
    Sorry to say that it didn't work for me.

    I was looking for a solution to pulse audio stuttering and adding random distortion - I have tried to get sound working on my Acer aspire 5720z for the last 4 months (not my idea of spending my time really).
    I tried numerous howtos, but the current Linux sound architecture seems such a buggy mess.

    After using this tutorial, pulse audio crashes on both soundcards, ALSA stopped working and I am back to square one.

    Sorry, I am actually referring to the new alternative howto found here http://ubuntuforums.org/showpost.php...&postcount=472.
    Read the disclaimer in the first post; this guide was never meant to fix ALSA issues like the ones you're experiencing.

    PulseAudio is a sound server that runs on top of ALSA. If ALSA does not work correctly, PulseAudio will not work either.

    You can revert the packages to Hardy defaults if you see my last post in this thread.

  2. #522
    Join Date
    May 2008
    Beans
    79
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by psyke83 View Post
    Ok, it's difficult to know what the problem is on your system, so I suggest you revert to defaults.

    1. Edit your sources.list and comment/remove the lines for my PPA.

    2. Update your repository lists:
    Code:
    $ sudo apt-get update
    3. Downgrade your packages to the Hardy versions:
    Code:
    sudo apt-get install alsa-utils/hardy flashplugin-nonfree/hardy libasound2/hardy libasound2-plugins/hardy libpulse0/hardy libpulse-browse0/hardy libpulsecore5/hardy libpulse-mainloop-glib0/hardy pulseaudio/hardy pulseaudio-esound-compat/hardy pulseaudio-module-gconf/hardy pulseaudio-module-hal/hardy pulseaudio-module-x11/hardy pulseaudio-module-zeroconf/hardy pulseaudio-utils/hardy
    4. Delete the asoundrc files:
    Code:
    $ rm ~/.asoundrc*
    Your system should be back to Hardy's default configuration after logging out and back in (or rebooting). If you want to get PulseAudio working via this guide, ignore the PPA packages and only follow Part A - and thoroughly check if it works before going any further.
    I was having a similar problem. The totem player was showing up but there wasn't any sound so i uninstalled everything like you stated above but still no sound in totem now... It was working previously. Also i had mentioned that realplayer locked up before but now it works at least. I just went ahead and tested rhythmbox and its not working either....

    Edit: i had to goto system/sound and set it to use pulseaudio again and it works
    Last edited by ethos_dacapo; August 15th, 2008 at 08:46 PM. Reason: fixed
    Here is the endurance of the set-apart ones, here are those guarding the commands of Elohim and the belief of Yahushua.

  3. #523
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by ethos_dacapo View Post
    I was having a similar problem. The totem player was showing up but there wasn't any sound so i uninstalled everything like you stated above but still no sound in totem now... It was working previously. Also i had mentioned that realplayer locked up before but now it works at least. I just went ahead and tested rhythmbox and its not working either....

    Edit: i had to goto system/sound and set it to use pulseaudio again and it works
    Ok. Rhythmbox and Totem both use the GStreamer framework, which is actually configured to use PulseAudio by default (unlike Flash & other ALSA applications), so it would have suggested that PulseAudio was working correctly for some reason.

    It's better not to mess with System/Preferences/Sound at all - leave the options at Autodetect.

  4. #524
    Join Date
    Oct 2007
    Beans
    13

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Is there a way to set application-specific default devices? I want to have Skype default to my bluetooth headset and have everything else continue to use the sound card, without having to manually change Skype's stream every time.

    And is ~/.pulse/default.pa the correct file to put additional modules to be loaded automatically on startup? (Specifically, my headset module.)

    Thirdly, I think one of my main problems is that the headset can't properly handle anything with a sampling rate greater than 8000Hz; as far as I know there's no way to set Skype's output rate, but is there a way to 'format' this output as it passes through PulseAudio, or any intermediate layer for that matter, before it reaches the headset? (Preferably without destroying sound quality.)

    And thanks for you hard work psyke83, those packages were a great help! (I am/was still having some crashing issues, but I attribute this to my messing with config files rather than anything wrong with the packages. It seems to be sorted out now.)

  5. #525
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by thesoffish View Post
    Is there a way to set application-specific default devices? I want to have Skype default to my bluetooth headset and have everything else continue to use the sound card, without having to manually change Skype's stream every time.

    And is ~/.pulse/default.pa the correct file to put additional modules to be loaded automatically on startup? (Specifically, my headset module.)
    Yes, it's possible - but you don't need to modify that file. Launch Skype and start a call (e.g. to test123), and open PulseAudio Volume Control (via the PulseAudio Device Chooser in Applications/Sound & Video). Go to the Playback tab and you'll see the entry for Skype - right-click on the Skype entry and select "Move Stream...", and select the desired output device.

    Hopefully that will work as long as the bluetooth headset was autodetected by PulseAudio upon connection, otherwise you may need to mess with configuration file you mentioned.

    If the stream successfully moved, Skype should always select that stream upon subsequent launches (fingers crossed).

    Thirdly, I think one of my main problems is that the headset can't properly handle anything with a sampling rate greater than 8000Hz; as far as I know there's no way to set Skype's output rate, but is there a way to 'format' this output as it passes through PulseAudio, or any intermediate layer for that matter, before it reaches the headset? (Preferably without destroying sound quality.)

    And thanks for you hard work psyke83, those packages were a great help! (I am/was still having some crashing issues, but I attribute this to my messing with config files rather than anything wrong with the packages. It seems to be sorted out now.)
    (Un?)fortunately, PulseAudio operates at a fixed rate (44100Hz without changing the default configuration). Your bluetooth device may operate at a different rate, but the PulseAudio server itself always stays at a fixed rate. I don't think it's necessary to change the sample rate via PulseAudio's configuration, as PulseAudio will most likely upsample to 44100Hz anyway - though I could be mistaken.

    PulseAudio Manager is a great tool to check the status of all the ALSA sinks (including sample rates). If you really need to change the rate, you'll need to edit ~/.pulse/default.pa. See PulseAudio's Modules wiki entry for guidance.
    Last edited by psyke83; August 15th, 2008 at 11:06 PM.

  6. #526
    Join Date
    Feb 2007
    Beans
    22

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Well I followed everything you posted to restore Hardy defaults. Then I followed section A completely. But I still have no sound.

    I had my system setup completely using section A of your How To before following your new instructions here http://ubuntuforums.org/showpost.php...&postcount=472

    And sound worked completely.

    I am really puzzled. Plus whenever I try pulseaudio -k and then try to restart it using pulseaudio -vv it still hangs with the message:
    "D: module-rtp-recv.c: Checking for dead streams ..."

    Then I'm unable to daemonize it. And I have to log in and out to restart it.


    I'm googling around for answers. So far none.

  7. #527
    Join Date
    Feb 2007
    Beans
    22

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Well I followed everything you posted to restore Hardy defaults. Then I followed section A completely. But I still have no sound.

    I had my system setup completely using section A of your How To before following your new instructions here http://ubuntuforums.org/showpost.php...&postcount=472

    And sound worked completely.

    I am really puzzled. Plus whenever I try pulseaudio -k and then try to restart it using pulseaudio -vv it still hangs with the message:
    "D: module-rtp-recv.c: Checking for dead streams ..."

    Then I'm unable to daemonize it. And I have to log in and out to restart it.


    I'm googling around for answers. So far none.

  8. #528
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by nick623 View Post
    Well I followed everything you posted to restore Hardy defaults. Then I followed section A completely. But I still have no sound.

    I had my system setup completely using section A of your How To before following your new instructions here http://ubuntuforums.org/showpost.php...&postcount=472

    And sound worked completely.

    I am really puzzled. Plus whenever I try pulseaudio -k and then try to restart it using pulseaudio -vv it still hangs with the message:
    "D: module-rtp-recv.c: Checking for dead streams ..."

    Then I'm unable to daemonize it. And I have to log in and out to restart it.


    I'm googling around for answers. So far none.
    Those errors are strange, yes. The instructions I gave to revert packages should have solved your issues (assuming your system worked ok prior to testing the new packages)... if you just want sound and don't care about PulseAudio, I recommend you delete your ~/.asoundrc* files, go to System/Preferences/Sound and set all the "Sound Playback" options to ALSA. Sorry I can't be of more help to you.

  9. #529
    Join Date
    Feb 2007
    Beans
    22

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by psyke83 View Post
    Those errors are strange, yes. The instructions I gave to revert packages should have solved your issues (assuming your system worked ok prior to testing the new packages)... if you just want sound and don't care about PulseAudio, I recommend you delete your ~/.asoundrc* files, go to System/Preferences/Sound and set all the "Sound Playback" options to ALSA. Sorry I can't be of more help to you.
    Thanks I guess for now I will remove .asouncrc and set to alsa.
    This is really strange. I just can't pinpoint the exact cause.

    If you come across any suggestions or ideas let me know.

  10. #530
    Join Date
    Apr 2006
    Location
    Mexico
    Beans
    21
    Distro
    Ubuntu 6.06

    Angry Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by psyke83 View Post
    Before you downgrade, can you help out a bit?

    1. Post the verbose log of PulseAudio:

    Code:
    $ pulseaudio -k && pulseaudio -vv
    2. Try to temporarily disable PulseAudio:
    Code:
    $ pulseaudio -k && asoundconf unset-pulseaudio
    Then, try launching an application and playing sound (you will need to restart any open applications).

    Let me know if you can get sound after following step 2.

    I run:
    $ pulseaudio -k && asoundconf unset-pulseaudio
    E: main.c: Failed to kill daemon.

    I don't have any audio

Page 53 of 171 FirstFirst ... 343515253545563103153 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •