Page 11 of 171 FirstFirst ... 9101112132161111 ... LastLast
Results 101 to 110 of 1706

Thread: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support

  1. #101
    Join Date
    Jan 2008
    Beans
    70
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Stuttering problem is gone.

    I did Part A and C on my 32 bit ubuntu hardy (mint elyssa beta). Flash was ok before.

    For my 5.1 sound i edited /etc/pulse/daemon.conf and changed
    ; default-sample-channels = 2
    to
    default-sample-channels = 6

    Now my sound system is complete!

    Thank you psyke83!

  2. #102
    Join Date
    May 2008
    Location
    Izmir - Turkey
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Now i did what Part D says but after that there i couldn't get any sound from my pc except rhythmbox. I tried to watch flash video on youtube and listen mp3 on imeem.com in firefox3b5. Even i couldn't hear the sound when i logged on. The worse thing is that when i try to play a video in movie player my pc totaly got locked. I also try to run movie player with comand
    Code:
    $ padsp totem
    Then i modified /etc/asound.conf like in Part A and changed the /etc/pulse/default.pa with the original one. Firefox and the other things except movie player got fixed.

    Now i will uninstall "swh-plugins" package with command
    Code:
    $ sudo apt-get remove swh-plugins
    then try run movie player properly.

    Does any one have any idea what is wrong with this things? I am using toshiba A105-S4094.

  3. #103
    Join Date
    May 2008
    Location
    Izmir - Turkey
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    I removed the package and now movie player works fine too. Is it possible that movie player and swh-plugins have some disconformity?

  4. #104
    Join Date
    Dec 2005
    Beans
    15

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    @psyke83
    Thanks for the help about the plugins.

    But first I have fix pulseaudio itself..
    I guess pulseaudio doesn't what it should. I have managed that in now starts it self. In stead of give a segmentation fault. PulseAudio Manager works also. But different programs didn't play sound.

    At this moment part A and B I have done. Part D was installed, but I have removed it again, but that seems not the problem.

    Rhythmbox didn't give sound.

    De output of verbose is displayed below. When pulseaudio is start. I start Rhythmbox and try to play a number, but that fail and give the last lines of the output below. When some dutch message are a problem, say it, then I will translate them.

    Do you have an advise what to do?
    Code:
    ..:~$ pkill pulseaudio
    ..:~$ pulseaudio -vv
    I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
    I: core-util.c: Successfully gained nice level -11.
    W: pid.c: Stale PID file, overwriting.
    I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Bewerking niet toegestaan
    I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Bewerking niet toegestaan
    I: main.c: This is PulseAudio 0.9.10
    I: main.c: Page size is 4096 bytes
    I: main.c: Dude, your kernel stinks! The chef's recommendation today is Linux with high-resolution timers enabled!
    D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
    I: module-hal-detect.c: Trying capability alsa
    D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
    D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
    D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_playback_2
    D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_capture_1
    D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_10de_59_sound_card_0_alsa_playback_0'
    D: alsa-util.c: Trying front:0...
    W: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
    I: module-alsa-sink.c: Successfully opened device front:0.
    I: module-alsa-sink.c: Successfully enabled mmap() mode.
    ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
    I: alsa-util.c: Unable to attach to mixer front:0: Bestand of map bestaat niet
    I: alsa-util.c: Successfully attached to mixer 'hw:0'
    I: alsa-util.c: Using mixer control "Master".
    I: sink.c: Created sink 0 "alsa_output.pci_10de_59_sound_card_0_alsa_playback_0" with sample spec "s16le 2ch 48000Hz"
    I: source.c: Created source 0 "alsa_output.pci_10de_59_sound_card_0_alsa_playback_0.monitor" with sample spec "s16le 2ch 48000Hz"
    I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.
    I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
    D: module-alsa-sink.c: Thread starting up
    D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
    I: module-alsa-sink.c: Starting playback.
    I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_10de_59_sound_card_0_alsa_playback_0").
    D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_10de_59_sound_card_0_alsa_capture_0'
    D: alsa-util.c: Trying front:0...
    W: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
    I: module-alsa-source.c: Successfully opened device front:0.
    I: module-alsa-source.c: Successfully enabled mmap() mode.
    ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
    I: alsa-util.c: Unable to attach to mixer front:0: Bestand of map bestaat niet
    I: alsa-util.c: Successfully attached to mixer 'hw:0'
    I: alsa-util.c: Using mixer control "Capture".
    I: source.c: Created source 1 "alsa_input.pci_10de_59_sound_card_0_alsa_capture_0" with sample spec "s16le 2ch 48000Hz"
    I: module-alsa-source.c: Using 4 fragments of size 4408 bytes.
    I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
    D: module-alsa-source.c: Thread starting up
    D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
    I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0 source_name=alsa_input.pci_10de_59_sound_card_0_alsa_capture_0").
    D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_control__1
    I: module-hal-detect.c: Loaded 2 modules.
    I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
    D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
    I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
    I: protocol-native.c: loading cookie from disk.
    I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
    I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
    D: module-default-device-restore.c: No previous default sink setting, ignoring.
    D: module-default-device-restore.c: Restored default source 'alsa_input.pci_10de_59_sound_card_0_alsa_capture_0'.
    I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
    I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
    D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 becomes idle.
    D: module-suspend-on-idle.c: Source alsa_output.pci_10de_59_sound_card_0_alsa_playback_0.monitor becomes idle.
    D: module-suspend-on-idle.c: Source alsa_input.pci_10de_59_sound_card_0_alsa_capture_0 becomes idle.
    I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
    D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
    I: module.c: Loaded "module-gconf" (index: #9; argument: "").
    D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
    D: module-x11-publish.c: using already loaded auth cookie.
    I: module.c: Loaded "module-x11-publish" (index: #10; argument: "").
    I: main.c: Daemon startup complete.
    D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
    I: module-suspend-on-idle.c: Source alsa_input.pci_10de_59_sound_card_0_alsa_capture_0 idle for too long, suspending ...
    I: module-alsa-source.c: Device suspended...
    I: module-suspend-on-idle.c: Source alsa_output.pci_10de_59_sound_card_0_alsa_playback_0.monitor idle for too long, suspending ...
    I: module-suspend-on-idle.c: Sink alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 idle for too long, suspending ...
    I: module-alsa-sink.c: Device suspended...
    I: client.c: Created 0 "Native client (UNIX socket client)"
    I: protocol-native.c: Got credentials: uid=1000 gid=1000 success=1
    I: protocol-native.c: Enabled SHM for new connection
    I: client.c: Client 0 changed name from "Native client (UNIX socket client)" to "Rhythmbox"
    I: client.c: Freed 0 "Rhythmbox"
    I: protocol-native.c: connection died.
    I: client.c: Created 1 "Native client (UNIX socket client)"
    I: protocol-native.c: Got credentials: uid=1000 gid=1000 success=1
    I: protocol-native.c: Enabled SHM for new connection
    I: client.c: Client 1 changed name from "Native client (UNIX socket client)" to "Rhythmbox"
    I: client.c: Freed 1 "Rhythmbox"
    I: protocol-native.c: connection died.
    I: client.c: Created 2 "Native client (UNIX socket client)"
    I: protocol-native.c: Got credentials: uid=1000 gid=1000 success=1
    I: protocol-native.c: Enabled SHM for new connection
    I: client.c: Client 2 changed name from "Native client (UNIX socket client)" to "Rhythmbox"
    I: client.c: Freed 2 "Rhythmbox"
    I: protocol-native.c: connection died.
    I: client.c: Created 3 "Native client (UNIX socket client)"
    I: protocol-native.c: Got credentials: uid=1000 gid=1000 success=1
    I: protocol-native.c: Enabled SHM for new connection
    I: client.c: Client 3 changed name from "Native client (UNIX socket client)" to "PulseAudio Manager"
    D: sound-file.c: POSIX_FADV_SEQUENTIAL succeeded.
    D: memblock.c: Memory block too large for pool: 1361924 > 16376
    D: core-scache.c: Playing sample "pulse-hotplug" on "alsa_output.pci_10de_59_sound_card_0_alsa_playback_0"
    D: core-util.c: posix_madvise() failed (or doesn't exist), trying mlock(): Ongeldige bestandsdescriptor
    D: core-util.c: mlock() worked fine!
    I: module-alsa-sink.c: Trying resume...
    I: module-alsa-sink.c: Resumed successfully...
    I: module-alsa-sink.c: Starting playback.
    D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 becomes idle.
    D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 becomes busy.
    I: resampler.c: Using resampler 'speex-float-3'
    I: resampler.c: Using float32le as working format.
    I: resampler.c: Choosing speex quality setting 3.
    I: sink-input.c: Created input 0 "sample:pulse-hotplug" on alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
    D: memblock.c: Memory block too large for pool: 17624 > 16376
    D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 becomes idle.
    D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 becomes idle.
    I: sink-input.c: Freeing output 0 "sample:pulse-hotplug"
    I: module-suspend-on-idle.c: Sink alsa_output.pci_10de_59_sound_card_0_alsa_playback_0 idle for too long, suspending ...
    I: module-alsa-sink.c: Device suspended...

  5. #105
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by klap-in View Post
    @psyke83
    Thanks for the help about the plugins.

    But first I have fix pulseaudio itself..
    I'm afraid I don't see any problems from that output, and I'm not sure what your problem is.

    I would recommend you undo all the changes from this guide (Appendix 2), then check if your PulseAudio is running normally.

    Then, apply Part A, log out and in, and see if things work. Then follow the other steps as long as things still work ok.

  6. #106
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Quote Originally Posted by beytun View Post
    I removed the package and now movie player works fine too. Is it possible that movie player and swh-plugins have some disconformity?
    No, that shouldn't happen. Try to undo all the changes from this guide and see if things work ok, perhaps.

  7. #107
    Join Date
    Feb 2007
    Location
    USA
    Beans
    141
    Distro
    Hardy Heron (Ubuntu Development)

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    The equalizer part of your guide was awesome! Thanks

  8. #108
    Join Date
    Nov 2007
    Beans
    135
    Distro
    Hardy Heron (Ubuntu Development)

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Woha thank you so much. It works without any problems!

  9. #109
    Join Date
    Oct 2007
    Beans
    4
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Thanks indeed psyke83 c|;o)

    Improved soundquality throughout - no stuttering and no tincan sound anymore.

    No difficulties whatsoever with your guide.


    Would it be possible for you to add a comment at the bottom near the downloadable files (flash and default.pa.txt) that one has to be a member of Ubuntuforums to get the attachments?

  10. #110
    Join Date
    Dec 2005
    Location
    What a weird trip.....
    Beans
    4,678
    Distro
    Ubuntu 12.04 Precise Pangolin

    Cool Re: HOWTO: PulseAudio Fixes & System-Wide Equalizer Support (Hardy Heron)

    Part C, #4 (Optional) fixed my stuttering audio.

    Thank you.

    This is the only fix I did because I already had the new kernel and it still stuttered.

    Not sure, but I think I just squashed my last bug on my laptop since installing Hardy.
    If at first you don't succeed - just buy the company and tell them to make the one you want.

Page 11 of 171 FirstFirst ... 9101112132161111 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •