Page 9 of 17 FirstFirst ... 7891011 ... LastLast
Results 81 to 90 of 161

Thread: HOWTO: Install VMware Server in Hardy (and later)

  1. #81
    Join Date
    Jun 2008
    Beans
    2

    Re: HOWTO: Install VMware Server in Hardy (and later)

    So easy to follow and whats more it worked!

  2. #82
    Join Date
    Mar 2006
    Location
    Canada
    Beans
    1,313
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Quote Originally Posted by ezramorris View Post
    Yep, that does the trick.
    Thanks.

    PS. Does it really need to upgrade everything before it installs?
    No, but you really should have the latest and greatest kernel (linux-image) because every single little upgrade breaks VMware. Its annoying, yes but they're working on fixing that for VMware Server 2.0.

    @gr4n1t3:
    You're welcome!

  3. #83
    Join Date
    Jul 2006
    Location
    Florida, USA
    Beans
    18
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: HOWTO: Install VMware Server in Hardy (and later)

    I am trying to set up a headless vmware server on 8.04 server version. I followed this thread (thanks again altonbr) with success. I can connect to the server from another Linux box that has vmware-server-console on it. Now I need to get vmware-server-console set up on the server so I can connect with a Mac. First I want to get it working from another Linux box that does not have vmware-server-console loaded. Then I will tackle the Mac.

    I downloaded and installed vmware-server-console on the new server. I installed libpng12-0 as it seemed to be needed. I installed xterm so I would have an X app to test.

    When I ssh to the server and enter:
    xterm -display 192.168.1.206:0
    where 192.168.1.206 is the Linux box without vmware-server-console, I get a terminal window for the server on that box. So I think the basics work.

    When I then enter on the server:
    vmware -display 192.168.1.206:0
    I get this:

    Locking assertion failure. Backtrace:
    #0 /usr/lib/libxcb-xlib.so.0 [0xb6fcc767]
    #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb6fcc81e]
    #2 /usr/lib/libX11.so.6 [0xb7e56518]
    #3 /usr/lib/libX11.so.6(XAddExtension+0x2c) [0xb7e39c9c]
    #4 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2(_XftDisplayInfoGet+0x77) [0xb7d3fed7]
    #5 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2 [0xb7d3e8b1]
    #6 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2 [0xb7d3ed39]
    #7 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2(XftDrawPicture+0x10) [0xb7d3eec0]
    #8 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b8b9b6]
    #9 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b8dd75]
    #10 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0xb7b5dc14]
    #11 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xb7b6a24f]
    #12 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0xb7b5dc14]
    #13 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_pixbuf_render_pixmap_and_mask_for_col ormap+0x255) [0xb7b69b34]
    #14 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a6e298]
    #15 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a6e586]
    #16 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xb7a7077e]
    #17 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0xd1) [0xb7c83459]
    #18 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 [0xb7c6b3a1]
    #19 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_closure_invoke+0x1b1) [0xb7c6b076]
    vmware: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.

    I'm at a lost looking at this and I don't know what to try. Can anyone help me out with this?

  4. #84
    Join Date
    Mar 2006
    Location
    Canada
    Beans
    1,313
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install VMware Server in Hardy (and later)

    @spoonernash
    I'm terribly sorry, but I have no experience with connecting to VMware on the command line (never have needed to). I'll see what I dig up though...

  5. #85
    Join Date
    Jan 2006
    Beans
    213
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Thanks!
    Worked great for me!

  6. #86
    Join Date
    Jul 2007
    Beans
    305
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: Install VMware Server in Hardy (and later)

    There is also a vmware-package (at least in debian testing) which builds debian packages out of various proprietary vmware products. Installing and Removing works properly.
    Maybe there are some Ubuntu-Ports of it.


    http://packages.debian.org/lenny/vmware-package
    iplist

    "Specialization is for Insects", R. Heinlein

  7. #87
    Join Date
    Jun 2008
    Beans
    7

    Re: HOWTO: Install VMware Server in Hardy (and later)

    @altonbar:

    my kernel is: 2.6.24-18-generic
    i still get the same error i posted before....this is crazy.....

  8. #88
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install VMware Server in Hardy (and later)

    just an fyi.

    i copied the script and pasted it into nano. for some reason, the paste wrapped the longer lines, and made a supreme mess of the script. i tried to clean it up but wound up just starting fresh and used gedit instead.

    never had this problem pasting into nano before. don't know why it did this time, but it did create quite a headache for me.

  9. #89
    Join Date
    Oct 2005
    Beans
    27

    Re: HOWTO: Install VMware Server in Hardy (and later)

    alton - just sending a personal thanks for this script. I ran into the rui/license key issue and this worked like a charm!

  10. #90
    Join Date
    Mar 2006
    Location
    Canada
    Beans
    1,313
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Quote Originally Posted by uljanow View Post
    There is also a vmware-package (at least in debian testing) which builds debian packages out of various proprietary vmware products. Installing and Removing works properly.
    Maybe there are some Ubuntu-Ports of it.


    http://packages.debian.org/lenny/vmware-package
    Thanks, I'll look into it!

    Quote Originally Posted by kryptonite--- View Post
    @altonbar:

    my kernel is: 2.6.24-18-generic
    i still get the same error i posted before....this is crazy.....
    Can you tell me in greater detail what you did before and after running my script? I really want to help, but I can't do much without more information.

    Quote Originally Posted by dmizer View Post
    just an fyi.

    i copied the script and pasted it into nano. for some reason, the paste wrapped the longer lines, and made a supreme mess of the script. i tried to clean it up but wound up just starting fresh and used gedit instead.

    never had this problem pasting into nano before. don't know why it did this time, but it did create quite a headache for me.
    That's really odd as I created it in gEdit so its using UTF-8 and standard Linux line breaks.

    The only possible explanation is that vbulletin has changed the output of my script and/or nano can't read Windows line breaks. I doubt it however.

    I'll try posting the script as an attachment as well, just for cases like this.

Page 9 of 17 FirstFirst ... 7891011 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •