Page 16 of 17 FirstFirst ... 614151617 LastLast
Results 151 to 160 of 161

Thread: HOWTO: Install VMware Server in Hardy (and later)

  1. #151
    Join Date
    Mar 2006
    Location
    Canada
    Beans
    1,313
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Quote Originally Posted by dmizer View Post
    While I understand this, there are two problems. First of all, your script is still using the any any update which is not needed (and breaks bridging on wireless). Second, your script requires command line work anyway.

    You have combined two commands into one line (just as I could have done with my two commands), but really it's the same amount of work in the cli.

    Though honestly, for the moment I'm stumped while trying to install VMware server 2 in 64 bit. Vmware is still looking in the wrong place for the gcc pointers and thinks my kernel was compiled against gcc version 4.2.3 instead of 4.2.4.

    Ugh, this is always a pain every time a kernel update comes down the pike.
    I do agree that this script is not fully required anymore, but for the casual user that wants VMware up and running quick, there is no other way but to use the command line. Even for VMware Server 2.0, people are having troubles getting it started. If VMware decided to release fully working .debs that didn't need to be recompiled after every kernel update, then there would be no problem. Until that happens, people can use my script for the 1.0.x series.

    If you'd like to update the script and send me your revisions, please feel free to do so.

  2. #152
    Join Date
    Dec 2007
    Beans
    14
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Has this script been broken by the latest kernel? (I am running stock i386 8.10 ubuntu) It gets as far as attempting to build the server, then borks on the compile:

    Building for VMware Server 1.0.0.
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config2/vmmon-only'
    make -C /lib/modules/2.6.27-7-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.27-7-generic'
    CC [M] /tmp/vmware-config2/vmmon-only/linux/driver.o
    In file included from /tmp/vmware-config2/vmmon-only/./include/x86.h:24,
    from /tmp/vmware-config2/vmmon-only/linux/driver.h:15,
    from /tmp/vmware-config2/vmmon-only/linux/driver.c:53:
    /tmp/vmware-config2/vmmon-only/./include/x86paging.h:61:1: warning: "PTE_PFN_MASK" redefined
    In file included from include/asm/paravirt.h:7,
    from include/asm/irqflags.h:55,
    from include/linux/irqflags.h:57,
    from include/asm/system.h:11,
    from include/asm/processor.h:17,
    from include/linux/prefetch.h:14,
    from include/linux/list.h:6,
    from include/linux/module.h:9,
    from /tmp/vmware-config2/vmmon-only/linux/driver.c:16:
    include/asm/page.h:22:1: warning: this is the location of the previous definition
    In file included from /tmp/vmware-config2/vmmon-only/linux/vmhost.h:13,
    from /tmp/vmware-config2/vmmon-only/linux/driver.c:84:
    /tmp/vmware-config2/vmmon-only/./include/compat_semaphore.h:5:27: error: asm/semaphore.h: No such file or directory
    /tmp/vmware-config2/vmmon-only/linux/driver.c:171: error: unknown field ‘nopage’ specified in initializer
    /tmp/vmware-config2/vmmon-only/linux/driver.c:172: warning: initialization from incompatible pointer type
    /tmp/vmware-config2/vmmon-only/linux/driver.c:175: error: unknown field ‘nopage’ specified in initializer
    /tmp/vmware-config2/vmmon-only/linux/driver.c:176: warning: initialization from incompatible pointer type
    /tmp/vmware-config2/vmmon-only/linux/driver.c: In function ‘__LinuxDriver_Ioctl’:
    /tmp/vmware-config2/vmmon-only/linux/driver.c:1781: error: too many arguments to function ‘smp_call_function’
    make[2]: *** [/tmp/vmware-config2/vmmon-only/linux/driver.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config2/vmmon-only] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic'
    make: *** [vmmon.ko] Error 2
    make: Leaving directory `/tmp/vmware-config2/vmmon-only'
    Unable to build the vmmon module.

    For more information on how to troubleshoot module-related problems, please
    visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
    "http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

    Execution aborted.

  3. #153
    Join Date
    Feb 2007
    Beans
    61
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Quote Originally Posted by earthforce_1 View Post
    Has this script been broken by the latest kernel? (I am running stock i386 8.10 ubuntu) It gets as far as attempting to build the server, then borks on the compile:

    ...

    make[2]: *** [/tmp/vmware-config2/vmmon-only/linux/driver.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config2/vmmon-only] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic'
    make: *** [vmmon.ko] Error 2
    make: Leaving directory `/tmp/vmware-config2/vmmon-only'
    Unable to build the vmmon module.

    For more information on how to troubleshoot module-related problems, please
    visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
    "http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

    Execution aborted.
    I've got the same problem. I'm running 8.10 Server AMD64.

  4. #154
    Join Date
    Mar 2006
    Location
    Canada
    Beans
    1,313
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install VMware Server in Hardy (and later)

    You guys are using Intrepid and the script is only for Hardy. You shouldn't need my script in Intrepid...

    Well, it doesn't need VMware-any-any, so I've heard.

    Should I be updating it for Intrepid and remove VMware-any-any?

  5. #155
    Join Date
    Nov 2008
    Location
    Sweden
    Beans
    2
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Quote Originally Posted by kextyn View Post
    I've got the same problem. I'm running 8.10 Server AMD64.
    The same message here!
    Well, I got the same problem as you guys, Running I386 Ubuntu 8.10. I thought it would actually work when I got the icons and everything. Now I dont have a glue what to do? Im actually impressed that I managed to open the tar.gz files and almost made a complete installation. Not bad for a beginner who doesnt know much about Ubuntu.

    Would be grateful to the one who can help me(us) with this!

  6. #156
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Quote Originally Posted by emulantie View Post
    Would be grateful to the one who can help me(us) with this!
    Build it without the script. It will complain about a gcc version conflict, but if you tell it to compile anyway, it will work.

  7. #157
    Join Date
    Mar 2008
    Beans
    1
    Distro
    Xubuntu Intrepid Ibex (testing)

    Exclamation Re: HOWTO: Install VMware Server in Hardy (and later)

    Hey all, someone was kind enough to post their successful install of vmware server on 8.10 Intrepid Ibex here: http://geekzine.org/2008/11/20/insta...-intrepid-810/

  8. #158
    Join Date
    Jan 2008
    Location
    Canada
    Beans
    34
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Install VMware Server in Hardy (and later)

    The any-any file cannot be found at the URL in the tutorial!

    http://uruz.org/files/vmware-any-any-update-116.tgz

    Just thought I'd point that out. Otherwise the install worked great (after downloading the any-any from another location) thanks!
    Last edited by Berethorn; December 17th, 2008 at 08:30 PM.
    I use Ubuntu 8.04 64bit on an Intel Q6600 with 4GB RAM.

  9. #159
    Join Date
    Nov 2007
    Location
    Charlotte, NC
    Beans
    733
    Distro
    Ubuntu

    Re: HOWTO: Install VMware Server in Hardy (and later)

    If I understood it correctly, I shouldn't have to download the tar file if it's already in the home directory. I did that, and the script still downloaded it.

    ....then I messed up what I was doing before the install was complete and had to run the script again and it had to RE-download the file. Takes over 30 minutes with my connection so it's time consuming...
    Dell Inspiron e1505 - 10.10/Windows 7
    HP Mini 1030NR - Jolicloud 1.2
    Follow me on Twitter!
    Ubuntu User # 19787 | Linux User #461129

  10. #160
    Join Date
    Mar 2006
    Location
    Canada
    Beans
    1,313
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install VMware Server in Hardy (and later)

    Quote Originally Posted by cartisdm View Post
    If I understood it correctly, I shouldn't have to download the tar file if it's already in the home directory. I did that, and the script still downloaded it.

    ....then I messed up what I was doing before the install was complete and had to run the script again and it had to RE-download the file. Takes over 30 minutes with my connection so it's time consuming...
    If the filename is 'VMware-server-1.0.6-91891.tar.gz' and in the directory that the script is running in, then it should not download the file again. I did this just for dial-up and DSL users.

Page 16 of 17 FirstFirst ... 614151617 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •