Page 79 of 230 FirstFirst ... 2969777879808189129179 ... LastLast
Results 781 to 790 of 2295

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #781
    Join Date
    May 2006
    Beans
    87

    Re: HOWTO: Install and use the latest FFmpeg and x264

    seelk: i'm getting the same error... will let you know if i find a fix.

    UPDATE: just re-grabbed the latest ffmpeg SVN, and noticed a few things were updated... works fine now.
    Last edited by zeus77; December 12th, 2009 at 09:07 PM.

  2. #782
    Join Date
    Jun 2006
    Location
    Rockaway, NJ
    Beans
    55
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by zeus77 View Post
    seelk: i'm getting the same error... will let you know if i find a fix.

    UPDATE: just re-grabbed the latest ffmpeg SVN, and noticed a few things were updated... works fine now.
    Good to hear! I'll give it a shot tonight...
    "smooth as seelk"

  3. #783
    Join Date
    Dec 2009
    Location
    cambridge MA
    Beans
    10

    Re: HOWTO: Install and use the latest FFmpeg and x264

    i just went through instructions for installing on 9.04(http://ubuntuforums.org/showpost.php...&postcount=636)
    and everything seemed to work fine.
    but now i can't run ffmpeg.
    Code:
    centralsqwall@PowerSpec:~/Pictures/OMPD/test-12-16$ ffmpeg
    bash: /usr/bin/ffmpeg: No such file or directory
    i have to link the ffmpeg directory to the /usr/bin directory? or move it?

    thanks,
    dan
    Last edited by danpaluska; December 17th, 2009 at 07:07 PM. Reason: clarity

  4. #784
    Join Date
    Oct 2007
    Location
    Edinburgh, UK
    Beans
    90
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Install and use the latest FFmpeg and x264

    See post #777 - a reboot should fix it

    Quote Originally Posted by FakeOutdoorsman View Post
    Update Update: The "hash -r" command works. No more rebooting needed.
    Very impressive!!, that command does not even have a man entry! (the shell had cached the original location of ffmpeg /usr/bin which is changed to /usr/local/bin when you install the compiled version, and "hash -r" clears the shell hash cache)
    Last edited by CoolDreamZ; December 19th, 2009 at 09:27 AM. Reason: Acknowledgment of better solution
    Happily running several flavours of Ubuntu

  5. #785
    Join Date
    Sep 2006
    Beans
    3,475

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by danpaluska View Post
    i just went through instructions for installing on 9.04(http://ubuntuforums.org/showpost.php...&postcount=636)
    and everything seemed to work fine.
    but now i can't run ffmpeg.
    Code:
    centralsqwall@PowerSpec:~/Pictures/OMPD/test-12-16$ ffmpeg
    bash: /usr/bin/ffmpeg: No such file or directory
    i have to link the ffmpeg directory to the /usr/bin directory? or move it?

    thanks,
    dan
    I'm trying to narrow down this issue, but I am unsure how to replicate it. Did you have FFmpeg installed before starting this guide? As CoolDreamZ mentioned, a reboot will take care of this, but I would like to find a less disruptive method. Reboot in Linux? Blasphemy!

    Update: Instead of rebooting, if you haven't already, try the "hash -r" command. Does that work?

    Update Update: The "hash -r" command works. No more rebooting needed.
    Last edited by FakeOutdoorsman; December 17th, 2009 at 09:11 PM.

  6. #786
    Join Date
    Aug 2006
    Beans
    10

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Great tut, it works, but every time i get it installed, aptitude wants to remove it!

    The following packages will be REMOVED:
    ffmpeg{u}

    How to keep my custom ffmpeg? I followed the directions step by step!

  7. #787
    Join Date
    Jun 2007
    Beans
    12,927

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Not sure how you got ffmpeg marked as automatically installed - there is a possibility or 2. Anyway just mark it as manually installed.

    Going sudo aptitude unmarkauto ffmpeg may or may not work. What should always is to open synaptic, search ffmpeg, highlight it and under the package tab, uncheck 'automatically installed'

    Now if it's not checked 'autom.... ...' then that would be, well, interesting.

  8. #788
    Join Date
    Aug 2006
    Beans
    10

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I figured it out...

    aptitude hold ffmpeg

    does it

  9. #789
    Join Date
    Sep 2006
    Beans
    3,475

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by pussfeller View Post
    Great tut, it works, but every time i get it installed, aptitude wants to remove it!

    The following packages will be REMOVED:
    ffmpeg{u}

    How to keep my custom ffmpeg? I followed the directions step by step!
    What version of Ubuntu are you using? I may have added the wrong checkinstall options during one of the revisions to this guide. There are four versions of this guide and although I try to test all updates I sometimes make occasional mistakes.

  10. #790
    Join Date
    Aug 2006
    Beans
    10

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I am using 9.10, but this has happened to me before, iirc, on earlier versions, but aptitude hold seems to take care of things.

    If it helps, before i applied hold, 'show' revealed something about not being used by other programs, and so would be removed

    Thanks!

Page 79 of 230 FirstFirst ... 2969777879808189129179 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •