Page 61 of 231 FirstFirst ... 1151596061626371111161 ... LastLast
Results 601 to 610 of 2306

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #601
    Join Date
    Jun 2007
    Beans
    13,075

    Re: HOWTO: Install and use the latest FFmpeg and x264

    If libfaad0 - 2.7.0 is installed then you can't install the 2.6.1 libfaad-dev until it's removed (synaptic and or apt-get won't downgrade off of an attempted install of a -dev

    So either remove/downgrade the 2.7.0 libfaad0 first and then install or ...

    just go ahead an install the libfaad-dev (2.7.0... ) from your ppa, ffmpeg isn't going to care whether you have the 2.6.1 or 2.7.0 version, all that matters is the lib and -dev are the same version.

    ( you don't need to re-add the ppa if you decide to go with the 2.7.0 version, just go here and direct download and install the libfaad-dev, expand the arrow for faad0.....karmic3

    https://launchpad.net/~freshmedia/+a.../ppa/+packages

  2. #602
    Join Date
    Sep 2006
    Beans
    548

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    Code:
    ffmpeg: symbol lookup error: ffmpeg: undefined symbol: avcodec_channel_layout_num_channels
    The extra packages (libavutil-extra-49 libswscale-extra-0 libpostproc-extra-51 libavformat-extra-52 libavcodec-extra-52 libavdevice-extra-52 libavfilter-extra-0) seem to cause issues in Karmic too. I'm unsure which one(s) cause errors, but I get:
    Code:
    ffmpeg: symbol lookup error: ffmpeg: undefined symbol: avcodec_decode_video2
    Those are exactly the symbol errors I was getting. Oh well, I guess I will keep doing what I'm doing when I upgrade to Karmic. Thanks.

  3. #603
    Join Date
    May 2009
    Beans
    13

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by mc4man View Post
    If libfaad0 - 2.7.0 is installed then you can't install the 2.6.1 libfaad-dev until it's removed (synaptic and or apt-get won't downgrade off of an attempted install of a -dev
    Thanks for the help. I uninstalled libfaad0 and then did an autoremove, and tried to install the prerequisites again - and the libfaad0-error is gone!

    Though, the libsdl1.2-dev remains. THe error states;
    libsdl1.2-dev: Dependent on: libglu1-mesa-dev but that will not be installed.
    Strangely enough?

    Says "E: Broken pakage" after.

    Any ideas?
    Last edited by BadSeqtor; November 5th, 2009 at 12:43 PM.

  4. #604
    Join Date
    Jun 2007
    Beans
    13,075

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Though, the libsdl1.2-dev remains. THe error states;
    libsdl1.2-dev: Dependent on: libglu1-mesa-dev but that will not be installed.
    That would be because you have a higher version of libglu1-mesa from one of your ppa's, probably the xorg-edgers.

    Can't say what your best bet is there because I don't know why you're using that ppa, if it's the one.

    Inclination would be to enable the ppa that you got libglu1-mesa from and install the libglu1-mesa-dev package from there rather than downgrade to the karmic repo version which may, at this point, have other consequences.

    In the long run, if using ppa's, you should check and be aware of what they're upgrading, or in the case of ppa's that have multiple apps, be aware of what they could upgrade by leaving them enabled after installing whatever it is that caused you in add them in the first place. (thru the update manager, ect.

    ( not saying any of your ppa's are multi-app, just a 'in general' comment

  5. #605
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I have compiled ffmpeg and x264 following your directions, however using WinFF when I try and import presets for the updated svn ffmpeg from http://winff.googlecode.com/files/presets-r15824.tar.gz I get a the preset to import does not have a label message. Any ideas whats going on?

  6. #606
    Join Date
    Sep 2006
    Beans
    3,491

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by Arup View Post
    I have compiled ffmpeg and x264 following your directions, however using WinFF when I try and import presets for the updated svn ffmpeg from http://winff.googlecode.com/files/presets-r15824.tar.gz I get a the preset to import does not have a label message. Any ideas whats going on?
    That file seems to be damaged for me at least. It will not extract:
    Code:
    $ tar xzvf presets-r15824.tar.gz 
    
    gzip: stdin: not in gzip format
    tar: Child returned status 1
    tar: Exiting with failure status due to previous errors
    A more appropriate and up-to-date preset file for your FFmpeg is probably presets-libavcodec52-v4.gz.

  7. #607
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    That file seems to be damaged for me at least. It will not extract:
    Code:
    $ tar xzvf presets-r15824.tar.gz 
    
    gzip: stdin: not in gzip format
    tar: Child returned status 1
    tar: Exiting with failure status due to previous errors
    A more appropriate and up-to-date preset file for your FFmpeg is probably presets-libavcodec52-v4.gz.
    Thanks a lot. That file is not in gzipped format, you need to remove the .gz extension for it to work. However WiFF doesn't allow me to import it somehow.

    The preset your recommended worked out fine, however I can't encode with it anymore, previously with older one, I could encode. I get a error indicating incorrect parameters being passed to encode.

    Finally figured out the issue of WinFF failing with new presets. It seems some of the codecs can't handle the multi cpu option which I had checked in WinFF, unticking that allowed me to encode the videos. Notably .flv is unable to do multi thread but x264 can.
    Last edited by Arup; November 6th, 2009 at 04:52 AM.

  8. #608
    Join Date
    Jul 2008
    Beans
    2

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thank you FakeOutdoorsman for this thread. My life is better because of it.

  9. #609
    Join Date
    Apr 2009
    Beans
    281
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hey all, Everything seemed to go very well w/ the install. When all was completed I attempted to convert my first vid. Only prob is. Im getting a bash...usr/bin/ffmpeg, no such file or dir.
    "If it ain't broken don't fix it", Just break it so you have to fix it!

    Dell Optiplex Gx270 P4 2.40 ghz 1.5 gb Nvidia GEforce 440 64 megs. (Lappy, Dell inspiron 1440 dual core 4 megs)

  10. #610
    Join Date
    Apr 2009
    Beans
    8
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi,

    I'm using Ubuntu 9.10 (Karmic)
    and I couldn't get winff to work
    then followed the "Install FFmpeg and x264 on Ubuntu Hardy Heron 8.04 LTS steps

    but winff doesn't want want to work because of "Unknown encoder 'libx264'"

    error:


    presets:


    x264:


    thanks

Page 61 of 231 FirstFirst ... 1151596061626371111161 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •