Page 52 of 231 FirstFirst ... 242505152535462102152 ... LastLast
Results 511 to 520 of 2306

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #511
    Join Date
    Sep 2006
    Beans
    3,484

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by stoppage View Post
    Code:
    WARNING: The bitrate parameter is set too low. It takes bits/s as argument, not kbits/s
    I don't know where I've gone wrong here, could somebody help me out please?
    FFmpeg is telling you that your bitrate is too low. You need to add a "k" to your bitrate so your command should look like:
    Code:
    ffmpeg -i out2.ogg -b 128k -ar 11025 -s 400x240 -pass 1 -passlogfile log-file outputx.avi
    Is there a reason you're converting to AVI? It's a somewhat dated format.

  2. #512
    Join Date
    Sep 2007
    Location
    Germany
    Beans
    229
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thank you for the speedy reply, I've been tearing the hair out here. I tried exactly the line you supplied with „k“ added, output of terminal is still exactly the same. I think this newer version of ffmpeg has some (other) problem with this format.....

    :~$ ffmpeg -i out2.ogg

    FFmpeg version SVN-r20182, Copyright (c) 2000-2009 Fabrice Bellard, et al.

    built on Oct 6 2009 20:47:37 with gcc 4.2.4 (Ubuntu 4.2.4-1ubuntu4)

    configuration: --enable-gpl --enable-nonfree --enable-pthreads --enable-libfaac --enable-libfaad --enable-libmp3lame --enable-libtheora --enable-libx264 --enable-libxvid --enable-x11grab

    libavutil 50. 3. 0 / 50. 3. 0

    libavcodec 52.36. 0 / 52.36. 0

    libavformat 52.39. 0 / 52.39. 0

    libavdevice 52. 2. 0 / 52. 2. 0

    libswscale 0. 7. 1 / 0. 7. 1

    [ogg @ 0x8b3f420]Could not find codec parameters (Video: theora, 1440x896)

    Input #0, ogg, from 'out2.ogg':

    Duration: 00:00:57.68, start: 0.000000, bitrate: 1074 kb/s

    Stream #0.0: Video: theora, 1440x896, PAR 1:1 DAR 45:28, 15 tbr, 15 tbn, 15 tbc

    Stream #0.1: Audio: vorbis, 48000 Hz, stereo, s16, 499 kb/s

    At least one output file must be specified
    ...

    and why .avi? I just want a format that I can host online, but available also to Windows users....conversion to .flv also doesn't work
    !!!!!!!!!!!!?????????

  3. #513
    Join Date
    Sep 2007
    Location
    Germany
    Beans
    229
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Sorry, my mistake in last posting...... when I specify 128k the difference in output is that the „Warning“ line no longer appears...
    „WARNING: The bitrate parameter is set too low. It takes bits/s as argument, not kbits/s

    Otherwise terminal output remains as original

  4. #514
    Join Date
    Sep 2006
    Beans
    3,484

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by stoppage View Post
    Sorry, my mistake in last posting...... when I specify 128k the difference in output is that the „Warning“ line no longer appears...
    „WARNING: The bitrate parameter is set too low. It takes bits/s as argument, not kbits/s

    Otherwise terminal output remains as original
    This may be a broken file or FFmpeg may have a bug. Can you actually play out2.ogg with anything such as MPlayer or VLC? Are you able to provide a sample of the file? If it is large you can try cutting it down to size:
    Code:
    dd if=out2.ogg of=out2-small.ogg bs=1024 count=5000
    This would create a 5 MB file. If you are unable to upload this anywhere you can PM me and I can give you my email address.

    Edit: Also, what version of recordmydesktop did you use? What was your recordmydesktop command or settings? Perhaps it is creating non-standard ogg video.
    Last edited by FakeOutdoorsman; October 7th, 2009 at 06:54 PM.

  5. #515
    Join Date
    Dec 2005
    Location
    St. Petersburg, FL
    Beans
    525
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by stoppage View Post
    and why .avi? I just want a format that I can host online, but available also to Windows users....conversion to .flv also doesn't work
    !!!!!!!!!!!!?????????
    To be able to play Theora video and Vorbis audio in the first place, Windows users will have to install additional software anyway - in the case of VLC, SMPlayer, or the CCCP, said additional software can already handle using those formats in the proper containers (Ogg or Matroska, whichever one you personally prefer). Putting it in AVI won't solve that for them. Not to mention AVI and Vorbis do not get along very well.

  6. #516
    Join Date
    Sep 2007
    Location
    Germany
    Beans
    229
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Recordmydesktop version is 0.3.6-1. File plays with vlc, mplayer, and opens in browser. WinFF wont play it since I introduced new version of ffmpeg. Its around 7MB. I hosted it here...

    http://www.fileden.com/files/2009/9/9/2569301/out2.ogg

  7. #517
    Join Date
    Oct 2009
    Beans
    6

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi i have installed ffmpeg now finally!!! However i am having a problem with the exec command from php. When i run an ffmpeg command to convert a video file to an flv through the terminal it works fine. When i run the same command through php's exec function it silentlly fails. I have checked m php.ini and safe mode is off. Do you have any idea what is wrong and how i can fix it?

  8. #518
    Join Date
    Sep 2006
    Beans
    3,484

    Re: HOWTO: Install and use the latest FFmpeg and x264

    stoppage:
    Quote Originally Posted by stoppage View Post
    Recordmydesktop version is 0.3.6-1. File plays with vlc, mplayer, and opens in browser. WinFF wont play it since I introduced new version of ffmpeg. Its around 7MB. I hosted it here...

    http://www.fileden.com/files/2009/9/9/2569301/out2.ogg
    My FFmpeg is having trouble on this too. I'll try out some tests and try to figure this out but it may take me a few days.


    supernath:
    Quote Originally Posted by supernath View Post
    Hi i have installed ffmpeg now finally!!! However i am having a problem with the exec command from php. When i run an ffmpeg command to convert a video file to an flv through the terminal it works fine. When i run the same command through php's exec function it silentlly fails. I have checked m php.ini and safe mode is off. Do you have any idea what is wrong and how i can fix it?
    Sorry, but I know next to nothing about php. You would have a better chance at getting a good answer in the Programming Talk section of these forums.

  9. #519

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks for nice tutorial but I always failed to install ffmpeg

  10. #520
    Join Date
    Sep 2006
    Beans
    3,484

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by kevinguillorytraining View Post
    Thanks for nice tutorial but I always failed to install ffmpeg
    If you provide some more information I may be able to help you. What version of Ubuntu are you using? When does installation fail? What errors do you get?

Page 52 of 231 FirstFirst ... 242505152535462102152 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •