Page 49 of 231 FirstFirst ... 3947484950515999149 ... LastLast
Results 481 to 490 of 2306

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #481
    Join Date
    Dec 2006
    Beans
    6,936

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi qyot,

    Quote Originally Posted by qyot27 View Post
    Both worked, thanks. Is there any benefit for using the sed method over the one with cut?
    I guess what you would look for is the ever-present possibility of the FFmpeg developers changing the syntax and decide on a variation that might accommodate this.

    Also, x264 always installs and gets listed fine, but apt put ffmpeg under the auto removable category. Which is somewhat annoying. Is that from a package numbering issue (which I hope can be resolved) or just an inherent thing?
    I see the problem. The Jaunty Ubuntu repository version is in fact labelled by date --> 3:0.svn20090303-1ubuntu6 not by revision number. It depends how keen you are to use revision numbers, you may have to play with the initial 3:0 numbers...

    Note: the first time I tried to install I used the cut method, but during the process everything locked up completely and I was forced to reboot, which canceled the installation. The sed method was the one that completed the install successfully, and then I noticed the auto removable thing. I don't know if that has anything to do with it, though.
    I am afraid I am not entirely sure what that is all about, both techniques produce the same end result.

    All the best,

    Andrew
    You think that's air you're breathing now?

  2. #482
    Join Date
    Dec 2006
    Beans
    6,936

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi FakeOutdoorsman,

    Quote Originally Posted by FakeOutdoorsman View Post
    Excellent! The sed command is something I need to work on. I've often needed it, but not often enough to take the time to learn it but I'm getting better.
    Works well but looks like it it will not work with your guide to trump the repository package version . I am sure a little more twiddling should get it working correctly though...

    Andrew
    You think that's air you're breathing now?

  3. #483
    Join Date
    Dec 2005
    Location
    St. Petersburg, FL
    Beans
    525
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by andrew.46 View Post
    I am afraid I am not entirely sure what that is all about, both techniques produce the same end result.
    By that part I simply meant that I was thinking the freeze-up could have made the system think something was wrong and resulted in what I saw, not that the difference in method between cut and sed did. Just that I thought the interference might have had something to do with it.

    I think what had happened was that the disc I was playing encountered an error and that made Audacious spazz out, and it in turn brought the rest of the freeze-up (I couldn't have used force quit, as the screen locked up, my music was either looping in ½-second bursts or had been replaced by endless beeping, etc. - the only way I could fix it was doing a hard reboot, and then everything was fine). I have no clue what happened, as I had to step out for just a couple of minutes and it was fine when I left, but when I came back it was in the middle of its panic attack or whatever that was. I also thought maybe it was a mini power surge, but there was no other evidence for that.

  4. #484
    Join Date
    May 2009
    Beans
    2

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Great thanks!
    It helps me to convert FullHD (AVCHD) videos from my Canon cam to MPEG.

  5. #485
    Join Date
    Sep 2006
    Beans
    3,491

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by dmitryme View Post
    Great thanks!
    It helps me to convert FullHD (AVCHD) videos from my Canon cam to MPEG.
    Good to hear that it converted AVCHD with no problems. I'm sure we'll be seeing more of this format.

  6. #486
    Join Date
    Sep 2009
    Beans
    15

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi

    I have successfully installed FFMPEG from source following your directions. Thanks for that.

    I tried writing a simple program to test how it works (attached below)

    #include <libavcodec/avcodec.h>
    #include <libavformat/avformat.h>
    #include <stdio.h>
    #include <math.h>

    int main(int argc, char *argv[]) {
    printf("Before av_register_all(); \n");
    av_register_all();
    printf("OK 1\n");
    return 0;
    }

    and compiled using

    gcc -o test-ffmpeg test-ffmpeg.c -lavformat -lavcodec -lavutil -lswscale -lz -lm

    I get a whole list of errors (attached below). Seems there are too many undefined things. Am I missing out setting some env variables etc.

    Looking forward to your help!

    tvkpz


    /usr/local/lib/libavcodec.a(libfaac.o): In function `Faac_encode_frame':
    /home/sujoy/ffmpeg/libavcodec/libfaac.c:128: undefined reference to `faacEncEncode'
    /usr/local/lib/libavcodec.a(libfaac.o): In function `Faac_encode_close':
    /home/sujoy/ffmpeg/libavcodec/libfaac.c:144: undefined reference to `faacEncClose'
    /usr/local/lib/libavcodec.a(libfaac.o): In function `Faac_encode_init':
    /home/sujoy/ffmpeg/libavcodec/libfaac.c:46: undefined reference to `faacEncOpen'
    /home/sujoy/ffmpeg/libavcodec/libfaac.c:51: undefined reference to `faacEncGetCurrentConfiguration'
    /home/sujoy/ffmpeg/libavcodec/libfaac.c:75: undefined reference to `faacEncClose'
    /home/sujoy/ffmpeg/libavcodec/libfaac.c:114: undefined reference to `faacEncSetConfiguration'
    /home/sujoy/ffmpeg/libavcodec/libfaac.c:54: undefined reference to `faacEncClose'
    /home/sujoy/ffmpeg/libavcodec/libfaac.c:102: undefined reference to `faacEncGetDecoderSpecificInfo'
    /usr/local/lib/libavcodec.a(libfaad.o): In function `faac_decode_init':
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:252: undefined reference to `NeAACDecOpen'
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:253: undefined reference to `NeAACDecClose'
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:254: undefined reference to `NeAACDecGetCurrentConfiguration'
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:255: undefined reference to `NeAACDecSetConfiguration'
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:256: undefined reference to `NeAACDecInit'
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:257: undefined reference to `NeAACDecInit2'
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:258: undefined reference to `NeAACDecDecode'
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:260: undefined reference to `NeAACDecGetErrorMessage'
    /home/sujoy/ffmpeg/libavcodec/libfaad.c:274: undefined reference to `NeAACDecOpen'
    /usr/local/lib/libavcodec.a(libmp3lame.o): In function `MP3lame_encode_frame':
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:160: undefined reference to `lame_encode_buffer'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:152: undefined reference to `lame_encode_buffer_interleaved'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:170: undefined reference to `lame_encode_flush'
    /usr/local/lib/libavcodec.a(libmp3lame.o): In function `MP3lame_encode_close':
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:212: undefined reference to `lame_close'
    /usr/local/lib/libavcodec.a(libmp3lame.o): In function `MP3lame_encode_init':
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:48: undefined reference to `lame_init'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:50: undefined reference to `lame_set_in_samplerate'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:51: undefined reference to `lame_set_out_samplerate'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:52: undefined reference to `lame_set_num_channels'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:56: undefined reference to `lame_set_quality'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:59: undefined reference to `lame_set_mode'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:60: undefined reference to `lame_set_brate'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:66: undefined reference to `lame_set_bWriteVbrTag'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:67: undefined reference to `lame_set_disable_reservoir'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:68: undefined reference to `lame_init_params'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:71: undefined reference to `lame_get_framesize'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:54: undefined reference to `lame_set_quality'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:79: undefined reference to `lame_close'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:62: undefined reference to `lame_set_brate'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:63: undefined reference to `lame_set_VBR'
    /home/sujoy/ffmpeg/libavcodec/libmp3lame.c:64: undefined reference to `lame_set_VBR_q'
    /usr/local/lib/libavcodec.a(libtheoraenc.o): In function `encode_frame':
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:203: undefined reference to `theora_encode_YUVin'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:222: undefined reference to `theora_encode_packetout'
    /usr/local/lib/libavcodec.a(libtheoraenc.o): In function `encode_close':
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:252: undefined reference to `theora_encode_packetout'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:253: undefined reference to `theora_clear'
    /usr/local/lib/libavcodec.a(libtheoraenc.o): In function `encode_init':
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:89: undefined reference to `theora_info_init'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:124: undefined reference to `theora_encode_init'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:130: undefined reference to `theora_info_clear'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:142: undefined reference to `theora_encode_header'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:148: undefined reference to `theora_comment_init'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:149: undefined reference to `theora_encode_comment'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:154: undefined reference to `theora_comment_clear'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:157: undefined reference to `ogg_packet_clear'
    /home/sujoy/ffmpeg/libavcodec/libtheoraenc.c:160: undefined reference to `theora_encode_tables'
    /usr/local/lib/libavcodec.a(libx264.o): In function `X264_frame':
    /home/sujoy/ffmpeg/libavcodec/libx264.c:105: undefined reference to `x264_encoder_encode'
    /usr/local/lib/libavcodec.a(libx264.o): In function `X264_close':
    /home/sujoy/ffmpeg/libavcodec/libx264.c:144: undefined reference to `x264_encoder_close'
    /usr/local/lib/libavcodec.a(libx264.o): In function `X264_init':
    /home/sujoy/ffmpeg/libavcodec/libx264.c:155: undefined reference to `x264_param_default'
    /home/sujoy/ffmpeg/libavcodec/libx264.c:285: undefined reference to `x264_encoder_open_76'
    /home/sujoy/ffmpeg/libavcodec/libx264.c:295: undefined reference to `x264_encoder_headers'
    /usr/local/lib/libavcodec.a(libxvidff.o): In function `ff_xvid_encode_frame':
    /home/sujoy/ffmpeg/libavcodec/libxvidff.c:431: undefined reference to `xvid_encore'
    /usr/local/lib/libavcodec.a(libxvidff.o): In function `ff_xvid_encode_close':
    /home/sujoy/ffmpeg/libavcodec/libxvidff.c:481: undefined reference to `xvid_encore'
    /usr/local/lib/libavcodec.a(libxvidff.o): In function `ff_xvid_encode_init':
    /home/sujoy/ffmpeg/libavcodec/libxvidff.c:184: undefined reference to `xvid_global'
    /home/sujoy/ffmpeg/libavcodec/libxvidff.c:271: undefined reference to `xvid_plugin_lumimasking'
    /home/sujoy/ffmpeg/libavcodec/libxvidff.c:349: undefined reference to `xvid_encore'
    /home/sujoy/ffmpeg/libavcodec/libxvidff.c:264: undefined reference to `xvid_plugin_single'
    /home/sujoy/ffmpeg/libavcodec/libxvidff.c:255: undefined reference to `xvid_plugin_2pass2'
    /usr/local/lib/libavcodec.a(libxvid_rc.o): In function `ff_xvid_rate_control_uninit':
    /home/sujoy/ffmpeg/libavcodec/libxvid_rc.c:146: undefined reference to `xvid_plugin_2pass2'
    /usr/local/lib/libavcodec.a(libxvid_rc.o): In function `ff_xvid_rate_estimate_qscale':
    /home/sujoy/ffmpeg/libavcodec/libxvid_rc.c:127: undefined reference to `xvid_plugin_2pass2'
    /home/sujoy/ffmpeg/libavcodec/libxvid_rc.c:119: undefined reference to `xvid_plugin_2pass2'
    /usr/local/lib/libavcodec.a(libxvid_rc.o): In function `ff_xvid_rate_control_init':
    /home/sujoy/ffmpeg/libavcodec/libxvid_rc.c:80: undefined reference to `xvid_plugin_2pass2'
    /usr/local/lib/libavcodec.a(pthread.o): In function `avcodec_thread_free':
    /home/sujoy/ffmpeg/libavcodec/pthread.c:95: undefined reference to `pthread_join'
    /usr/local/lib/libavcodec.a(pthread.o): In function `avcodec_thread_init':
    /home/sujoy/ffmpeg/libavcodec/pthread.c:159: undefined reference to `pthread_create'
    collect2: ld returned 1 exit status

  7. #487
    Join Date
    Apr 2009
    Beans
    42

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi FakeOutdoorsman, I followed your step and when I issue the following command I got a series of errors that are listed after the command:

    sudo apt-get purge ffmpeg x264 libx264-dev
    Code:
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by apt-get) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by apt-get) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by apt-get) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libapt-pkg-libc6.7-6.so.4.6) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libapt-pkg-libc6.7-6.so.4.6) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libapt-pkg-libc6.7-6.so.4.6) 
    apt-get: relocation error: /usr/lib/libapt-pkg-libc6.7-6.so.4.6: symbol _ZSt16__ostream_insertIcSt11char_traitsIcEERSt13basic_ostreamIT_T0_ES6_PKS3_i, version GLIBCXX_3.4.9 not defined in file libstdc++.so.6 with link time reference
    What could be the reason.

    Thank you.

    Zelalem

  8. #488
    Join Date
    Sep 2006
    Beans
    3,491

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by tvkpz View Post
    Hi

    I have successfully installed FFMPEG from source following your directions. Thanks for that.

    I tried writing a simple program to test how it works (attached below)
    I get a whole list of errors (attached below). Seems there are too many undefined things. Am I missing out setting some env variables etc.

    Looking forward to your help!

    tvkpz
    This goes beyond my experience with FFmpeg. This would be a question to ask the FFmpeg libav-user mailing list and perhaps the #ffmpeg IRC channel. I'm sorry that I can't be more helpful.

  9. #489
    Join Date
    Sep 2006
    Beans
    3,491

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by zelalem View Post
    Hi FakeOutdoorsman, I followed your step and when I issue the following command I got a series of errors that are listed after the command:

    sudo apt-get purge ffmpeg x264 libx264-dev
    Code:
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by apt-get) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by apt-get) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by apt-get) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libapt-pkg-libc6.7-6.so.4.6) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libapt-pkg-libc6.7-6.so.4.6) 
    apt-get: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libapt-pkg-libc6.7-6.so.4.6) 
    apt-get: relocation error: /usr/lib/libapt-pkg-libc6.7-6.so.4.6: symbol _ZSt16__ostream_insertIcSt11char_traitsIcEERSt13basic_ostreamIT_T0_ES6_PKS3_i, version GLIBCXX_3.4.9 not defined in file libstdc++.so.6 with link time reference
    What could be the reason.

    Thank you.

    Zelalem
    This seems more like an Ubuntu package management issue and I'm unsure what would have caused this. A possibly related bug report:

    Bug #180160 in apt (Ubuntu): cannot run apt-get after upgrading to ubuntu 8.04


    In your previous forum thread, Need help with ffmpeg installation, someone suggested that you make some changes to your .bashrc file. I am guessing, but this may have caused your error. Also, in that same thread you said, "I installed all the dependencies and ffmpeg". If you followed an FFmpeg installation guide, can you give me the link? I would like to check if the guide may have caused your errors somehow.

  10. #490
    Join Date
    Apr 2009
    Beans
    42

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi FakeOutdoorsman, you are right it relates to ubuntu package management. I remember getting this e-mail long time ago but didn't know how i solved it. I might have tweked it. Anyway, I will try to check out the link you proposed and come back here if I got any problem.

    Thank you again for the good work.

    Best regards,

    Zelalem
    Last edited by zelalem; September 26th, 2009 at 11:34 AM.

Page 49 of 231 FirstFirst ... 3947484950515999149 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •