Page 41 of 231 FirstFirst ... 3139404142435191141 ... LastLast
Results 401 to 410 of 2306

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #401
    Join Date
    Nov 2008
    Location
    Maine
    Beans
    1,125
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question Re: HOWTO: Install and use the latest FFmpeg and x264

    Indeed a great how to. When i get home i will try this.
    Currently i have Jackalope installed and ffmpeg will export to .wav files but not .MP3 files. Anyone have some advice there?
    I will try reinstalling ffmpeg soon.

  2. #402
    Join Date
    Sep 2006
    Beans
    3,490

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by conradin View Post
    Indeed a great how to. When i get home i will try this.
    Currently i have Jackalope installed and ffmpeg will export to .wav files but not .MP3 files. Anyone have some advice there?
    I will try reinstalling ffmpeg soon.
    Jackalope uses a relatively new revision of FFmpeg unlike prior Ubuntu versions. Restricted encoders are disabled by default, but it is easy to enable them:

    HOWTO: Easily enable MP3, MPEG4, AAC, and other restricted encoding in FFmpeg

  3. #403
    Join Date
    Nov 2008
    Beans
    8

    Re: HOWTO: Install and use the latest FFmpeg and x264

    excellent instructions and working command row but trying afterwards WinFF with same input says "Could not find FFPlay"
    Should I wait until next version of WinFF?

    (Ubuntu 9.04 updated)

    Dimitris

  4. #404
    Join Date
    Sep 2006
    Beans
    3,490

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by dilog View Post
    excellent instructions and working command row but trying afterwards WinFF with same input says "Could not find FFPlay"
    Should I wait until next version of WinFF?

    (Ubuntu 9.04 updated)

    Dimitris
    I'm not too familiar with WinFF. Did you install the libsdl1.2-dev package before compiling FFmpeg? It is under "Optional Dependencies" on this guide.

    I am out of town, so my replies may be sparse.

  5. #405
    Join Date
    Nov 2008
    Beans
    8

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    I'm not too familiar with WinFF. Did you install the libsdl1.2-dev package before compiling FFmpeg? It is under "Optional Dependencies" on this guide.

    I am out of town, so my replies may be sparse.
    I did but all of the same....

  6. #406
    Join Date
    Apr 2007
    Beans
    80

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by aa52828 View Post
    Where I can get information for Jaunty?
    I'm on jaunty, followed these instructions and it works perfectly.

  7. #407
    Join Date
    Nov 2008
    Beans
    8

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by dilog View Post
    I did but all of the same....
    Sorry, it works perfectly now - many thanks!
    Dimitris

  8. #408
    Join Date
    Dec 2006
    Beans
    6,935

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi Fakeoutdoorsman,

    It seems that FFmpeg has dropped support for the non-free amr libraries in favour of opencore-amr:

    Code:
    andrew@skamandros~$ svn log svn://svn.mplayerhq.hu/ffmpeg/trunk -r 19365 
    ------------------------------------------------------------------------
    r19365 | diego | 2009-07-07 10:28:16 +1000 (Tue, 07 Jul 2009) | 3 lines
    
    Remove support for nonfree libamr library for AMR-NB/WB decoding/encoding.
    libopencore can now be used as a replacement except for AMR-WB encoding.
    
    ------------------------------------------------------------------------
    which of course makes your brief guide:

    How to play AMR audio files
    http://ubuntuforums.org/showpost.php...67&postcount=9

    correct only for older revisions. I am still scrabbling around myself with the gitorious git repository to re-enable amr support . Looks like the following will be a start:

    Code:
    $ git clone --depth=1 git://opencore-amr.git.sourceforge.net/gitroot/opencore-amr 
    $ cd opencore-amr
    $ make
    $ sudo make install
    $ make clean
    and for the FFmpeg ./configure to succeed:

    Code:
      --enable-libopencore-amrnb \
      --enable-libopencore-amrwb \
      --enable-version3
    Hmmm.... maybe I have given a little more than a start . Mind you I note there is a debian directory with the usual section for creating a debian package which would probably be a better idea.

    Andrew
    Last edited by andrew.46; July 14th, 2009 at 11:16 AM. Reason: Edit: git repository changed addresses :-)
    You think that's air you're breathing now?

  9. #409
    Join Date
    Apr 2008
    Location
    CA, US
    Beans
    119
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Install and use the latest FFmpeg and x264

    i need to do a

    cd ffmpeg
    cp ffmpeg /usr/bin/

    for the build to work


    FakeOutdoorsman love your work!!


    oh and i needed one or more of these to make x11grab work, (i have a new 9.04 install)

    sudo aptitude install libice-dev libsm-dev libx11-dev libxext-dev libxi-dev libxmu-dev libxmuu-dev libxpm-dev libxrandr-dev libxt-dev libxtrap-dev libxtst-dev libxv-dev x-dev zlib1g-dev
    Last edited by bgiannes; July 10th, 2009 at 12:38 AM.

  10. #410
    Join Date
    Jul 2008
    Location
    Reading, UK
    Beans
    182
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Umm - I'm on Hardy, but now scared for when I may need to upgrade to the next LTS.

    I trust that the non-free encoders are available in the version of ffmpeg that I would be able to buy from Canonical?

    If that is the case - I'll buy the fully-supported version - if it's just an apt-get away...

Page 41 of 231 FirstFirst ... 3139404142435191141 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •