Page 39 of 230 FirstFirst ... 2937383940414989139 ... LastLast
Results 381 to 390 of 2295

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #381
    Join Date
    Sep 2008
    Beans
    20

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I try to convert an video to another format using -vcodec but got following error:
    teppy@BP:~/Videos$ ffmpeg -i "hua xin.dat" -vcodec libx264 "hua xin.mpg"
    FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
    configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr
    libavutil version: 1d.49.3.0
    libavcodec version: 1d.51.38.0
    libavformat version: 1d.51.10.0
    built on Mar 16 2009 21:16:26, gcc: 4.2.4 (Ubuntu 4.2.4-1ubuntu3)
    Input #0, mpeg, from 'hua xin.dat':
    Duration: 00:03:43.3, start: 0.253333, bitrate: 1422 kb/s
    Stream #0.0[0x1e0]: Video: mpeg1video, yuv420p, 352x240, 1152 kb/s, 29.97 fps(r)
    Stream #0.1[0x1c0]: Audio: mp2, 44100 Hz, stereo, 224 kb/s
    Unknown codec 'libx264'
    1/ How do I install libx264 codec?
    2/ what is another codec option other than libx264?

  2. #382
    Join Date
    Feb 2009
    Location
    Kyiv, Ukraine
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks for nice guide! I just got rid of "Segmentation fault" issue. Used Hardy HOW-TO on Intrepid.
    good luck to you

  3. #383
    Join Date
    Sep 2006
    Beans
    3,470

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by gaixixon View Post
    I try to convert an video to another format using -vcodec but got following error:

    1/ How do I install libx264 codec?
    2/ what is another codec option other than libx264?
    You are using FFmpeg from the Ubuntu repository. This does not include support for libx264 by default. Ubuntu Hardy users can:

    1. Uninstall the repository FFmpeg and compile FFmpeg and x264 yourself:
    HOWTO: Install and use the latest FFmpeg and x264

    or

    2. Use FFmpeg from a third-party repository:
    HOWTO: Easily enable MP3, MPEG4, AAC, and other restricted encoding in FFmpeg

  4. #384
    Join Date
    Sep 2008
    Beans
    20

    Re: HOWTO: Install and use the latest FFmpeg and x264

    hi FakeOutdoorsman, I still got error
    Unknown codec 'libx264'
    what is another video codec options that I can use?
    I am now trying to convert some .dat movie files to what ever (maybe flv, mpg to play on my mobile phone).

  5. #385
    Join Date
    Sep 2006
    Beans
    3,470

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by gaixixon View Post
    hi FakeOutdoorsman, I still got error
    what is another video codec options that I can use?
    I am now trying to convert some .dat movie files to what ever (maybe flv, mpg to play on my mobile phone).
    For mpg:
    Code:
    ffmpeg -i inputvideo.dat -b 512k output.mpg
    You will need to compile FFmpeg yourself or install FFmpeg from Medibuntu to create flv with mp3 audio.

  6. #386
    Join Date
    Aug 2007
    Beans
    4

    Re: HOWTO: Install and use the latest FFmpeg and x264

    hi, my installation stop at "install FFmpeg" because I accidentally closed the terminal. When restart the whole process I got this error

    " svn: Working copy 'ffmpeg' locked"

    soon after entered this command "svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg".

    how can I fix this problem?

  7. #387
    Join Date
    Sep 2006
    Beans
    3,470

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Rename or delete ~/ffmpeg and then run svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg again:
    Code:
    cd
    rm -rf ffmpeg
    svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg

  8. #388
    Join Date
    May 2009
    Beans
    1

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi,

    This question may have been asked already, but I couldn't find it in the thread. Do I need to uninstall the unstripped ffmpeg libraries such as libavutil-unstripped49 et al before compiling ffmpeg?

    Thank you,

    Kevin

  9. #389
    Join Date
    Sep 2006
    Beans
    3,470

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by kishigo View Post
    Hi,

    This question may have been asked already, but I couldn't find it in the thread. Do I need to uninstall the unstripped ffmpeg libraries such as libavutil-unstripped49 et al before compiling ffmpeg?

    Thank you,

    Kevin
    I doubt that you need to remove them. However, the libav*-dev packages may cause issues if my memory is correct. I usually like to test these things out before replying (instead of relying on my often faulty memory), but I'm out of town now, so I can't test it to be completely sure.

  10. #390
    Join Date
    Dec 2006
    Beans
    6,930

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi hz428,

    Quote Originally Posted by hz428 View Post
    Code:
    svn: Working copy 'ffmpeg' locked
    The Gordian Knot approach is to delete and start again as FakeOutdoorsman has already suggested. An alternative is to change to your FFmpeg source tree and run:

    Code:
    svn cleanup .
    Don't forget the '.' which of course signifies that the target of the command is the present working directory. This command recursively cleans up the working copy, removing locks, resuming unfinished operations, etc.

    All the best,

    Andrew
    You think that's air you're breathing now?

Page 39 of 230 FirstFirst ... 2937383940414989139 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •