Page 224 of 232 FirstFirst ... 124174214222223224225226 ... LastLast
Results 2,231 to 2,240 of 2311

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #2231
    Join Date
    Nov 2006
    Beans
    216

    Re: HOWTO: Install and use the latest FFmpeg and x264

    thank you FakeOutdoorsman

    i figured that out, i did my research and read everything twice though i'd be smart and make the web page a .pdf file with firefox. so print to .pdf in firefox doesn't make a perfect .pdf file, lesson learned.

  2. #2232
    Join Date
    Jan 2013
    Beans
    5

    Re: HOWTO: Compile the latest ffmpeg and x264 from source

    Quote Originally Posted by Paerez View Post
    I tried using both nasm and yasm from the repos, and x264 would compile but it would say it was building without support for yasm and nasm.

    Then, when I used it to convert a file it would say that it was using no cpu extensions, as opposed to saying "MMX SSE ...". It would also take significantly longer (like 2-5 times as long).

    But just installing the yasm from source fixed it, and it wasn't very difficult to do.
    when I try to enable yasm in ffmpeg it is giving me an error that "yasm not found" how can I solve this problem..? Any one please suggest me

  3. #2233
    Join Date
    Sep 2006
    Beans
    3,500

    Re: HOWTO: Compile the latest ffmpeg and x264 from source

    Did you install yasm first?

  4. #2234
    Join Date
    Nov 2008
    Location
    La Paz - Bolivia
    Beans
    18
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Good guide..

    Quote Originally Posted by FakeOutdoorsman View Post
    This guide has been moved to the official FFmpeg wiki:

    How to Compile FFmpeg and x264 on Ubuntu

    The guide will be kept up to date and all supported Ubuntu versions will be included.

  5. #2235
    Join Date
    Nov 2008
    Location
    UK
    Beans
    91

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Using the guide I got installation errors installing fdk-acc and ffmpeg sections; the other sections installed OK.

    fdk-acc and ffmpeg folders appear in /home directory, but are not shown as installed in Synaptic.

    I'm using 12.04 (Precise) Classic No Effects.

    Error installing fdk-acc

    richard@base-desktop:~/fdk-aac$ autoreconf -fiv
    autoreconf: Entering directory `.'
    autoreconf: configure.ac: not using Gettext
    autoreconf: running: aclocal -I m4 --output=aclocal.m4t
    Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 326.
    autoreconf: failed to run aclocal: No such file or directory
    richard@base-desktop:~/fdk-aac$ ./configure --disable-shared
    bash: ./configure: No such file or directory
    richard@base-desktop:~/fdk-aac$ make
    make: *** No targets specified and no makefile found. Stop.
    richard@base-desktop:~/fdk-aac$ sudo checkinstall --pkgname=fdk-aac --pkgversion="$(date +%Y%m%d%H%M)-git" --backup=no \
    > --deldoc=yes --fstrans=no --default

    Installation results
    make: *** No rule to make target `install'. Stop.

    **** Installation failed. Aborting package creation.
    Error installing ffmpeg

    richard@base-desktop:~/ffmpeg$ ./configure --enable-gpl --enable-libass --enable-libfaac --enable-libfdk-aac --enable-libmp3lame \
    > --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-librtmp --enable-libtheora \
    > --enable-libvorbis --enable-libvpx --enable-x11grab --enable-libx264 --enable-nonfree --enable-version3
    ERROR: libfdk_aac not found

    If you think configure made a mistake, make sure you are using the latest
    version from Git. If the latest version fails, report the problem to the
    ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
    Include the log file "config.log" produced by configure as this will help
    solving the problem.
    richard@base-desktop:~/ffmpeg$ make
    Makefile:2: config.mak: No such file or directory
    Makefile:49: /common.mak: No such file or directory
    Makefile:92: /libavutil/Makefile: No such file or directory
    Makefile:92: /library.mak: No such file or directory
    Makefile:178: /doc/Makefile: No such file or directory
    Makefile:179: /tests/Makefile: No such file or directory
    make: *** No rule to make target `/tests/Makefile'. Stop.
    richard@base-desktop:~/ffmpeg$ sudo checkinstall --pkgname=ffmpeg --pkgversion="7:$(date +%Y%m%d%H%M)-git" --backup=no \
    > --deldoc=yes --fstrans=no --default

    Installation results
    Makefile:2: config.mak: No such file or directory
    Makefile:49: /common.mak: No such file or directory
    Makefile:92: /libavutil/Makefile: No such file or directory
    Makefile:92: /library.mak: No such file or directory
    Makefile:178: /doc/Makefile: No such file or directory
    Makefile:179: /tests/Makefile: No such file or directory
    make: *** No rule to make target `/tests/Makefile'. Stop.

    **** Installation failed. Aborting package creation.
    Can you help fix this.

    As aside, it would helpful to beginners if you added instructions to the guide to show how to install source snapshot tar.bz2 files.

  6. #2236
    Join Date
    Sep 2006
    Beans
    3,500

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by heyup View Post
    Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 326.
    autoreconf: failed to run aclocal: No such file or directory
    That's strange. Installation of autoconf should have installed automake which should have installed aclocal. Are you sure autoconf and automake are installed?

    Code:
    $ dpkg -s automake | grep Status
    Status: install ok installed
    $ dpkg -s autoconf | grep Status
    Status: install ok installed
    Quote Originally Posted by heyup View Post
    As aside, it would helpful to beginners if you added instructions to the guide to show how to install source snapshot tar.bz2 files.
    I'll keep this in mind. Is git just too annoying to use? I'm planning on changing the guides so they no longer perform any system installation, so changes will be coming...eventually.
    Last edited by FakeOutdoorsman; February 12th, 2013 at 08:32 PM.

  7. #2237
    Join Date
    Nov 2008
    Location
    UK
    Beans
    91

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    That's strange. Installation of autoconf should have installed automake which should have installed aclocal. Are you sure autoconf and automake are installed?
    autoconf was installed, but automake wasn't.

    I'm using a custom build of Precise desktop; automake wasn't installed by default, and I had disabled 'consider recommended packages as dependencies' in Synaptic settings (to avoid unnecessary bloat).

    In Synaptic autoconf lists automake as a recommendeded package not a dependency of autoconf, so automake wasn't installed!

    No errors after installing automake.

    Quote Originally Posted by FakeOutdoorsman View Post
    Is git just too annoying to use? I'm planning on changing the guides so they no longer perform any system installation, so changes will be coming...eventually.
    No problem with using git. I just thought that it might useful to include instructions on how to install a snapshot.

    Great guide. Thanks for your help solving this problem.

  8. #2238
    Join Date
    Jun 2005
    Location
    Porto, Portugal
    Beans
    121
    Distro
    Ubuntu

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hey guys,

    I have installed everything successfully, but kdenlive does not detect the new codecs.

    How do I get kdenlive to work with the new codecs?

    Thank you!

  9. #2239
    Join Date
    Jun 2005
    Location
    Porto, Portugal
    Beans
    121
    Distro
    Ubuntu

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Anyone?!

  10. #2240
    Join Date
    Dec 2005
    Location
    St. Petersburg, FL
    Beans
    529
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Case 1: kdenlive uses shared libs (which is the most likely scenario).
    Solution: Build FFmpeg as shared; this guide builds it as static. May also require installing to /usr rather than /usr/local, but I'm not sure on how that's handled.

    Case 2: kdenlive uses static libs.
    Solution: Recompile kdenlive so it sees/uses the new static libs.
    Last edited by qyot27; April 9th, 2013 at 09:22 PM.

Page 224 of 232 FirstFirst ... 124174214222223224225226 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •