Page 223 of 231 FirstFirst ... 123173213221222223224225 ... LastLast
Results 2,221 to 2,230 of 2306

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #2221
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by jgcsd View Post
    Any help?
    Show full unedited output from command:-
    Code:
    ffmpeg -version
    Last edited by ron999; September 14th, 2012 at 05:30 PM.

  2. #2222
    Join Date
    Sep 2006
    Beans
    3,489

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by jgcsd View Post
    x11grab isn't working for me. I've installed ffmpeg using the tutorial on the wiki, and ffmpeg seems to work, except for x11grab

    I get this
    Code:
    ffmpeg version N-35113-g509f502 Copyright (c) 2000-2012 the FFmpeg developers
      built on Sep 14 2012 15:44:58 with gcc 4.6 (Ubuntu/Linaro 4.6.3-1ubuntu5)
      configuration:
    Any help?
    Your ffmpeg configure line is blank. Did you skip the step with the configure options? The minimum you need to enable x11grab is "--enable-gpl --enable-x11grab".

  3. #2223
    Join Date
    May 2012
    Beans
    3

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I am trying to install ffmpeg on my ubuntu 12.04 server using the Ubuntu Compilation Guide linked to from here. When I do the configure step for ffmpeg I keep getting ERROR: libaacplus not found or ERROR: fdk-aac not found or ERROR: libvpx not found, even though I installed all those like the guide said.

    I also noticed in the configure log this line "ffmpeg /usr/bin/ld: error: cannot find -laacplus", and I think my laacplus files are in /usr/local/lib/ I thought maybe if I re-installed all the components using --enable-shared it might fix the issue. Any help with this issue would be greatly appreciated. Thank you in advanced.

  4. #2224
    Join Date
    Sep 2006
    Beans
    3,489

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Did you follow the guide word-for-word, or did you modify any steps? Someone else added the libaacplus and libopus sections, and I haven't tested those instructions yet.

    You shouldn't need to add --enable-shared.

    Are you sure libaacplus, fdk-aac, and libvpx were installed successfully? You can check with dpkg:

    Code:
    $ dpkg -L libaacplus
    /.
    /usr
    /usr/local
    /usr/local/bin
    /usr/local/bin/aacplusenc
    /usr/local/lib
    /usr/local/lib/pkgconfig
    /usr/local/lib/pkgconfig/aacplus.pc
    /usr/local/lib/libaacplus.a
    /usr/local/lib/libaacplus.la
    /usr/local/lib/libaacplus.so.2.0.2
    /usr/local/include
    /usr/local/include/aacplus.h
    /usr/local/share
    /usr/local/share/man
    /usr/local/share/man/man1
    /usr/local/share/man/man1/aacplusenc.1.gz
    /usr/share
    /usr/share/doc
    /usr/share/doc/libaacplus
    /usr/share/doc/libaacplus/NEWS
    /usr/share/doc/libaacplus/COPYING
    /usr/share/doc/libaacplus/INSTALL
    /usr/share/doc/libaacplus/ChangeLog
    /usr/share/doc/libaacplus/docs
    /usr/share/doc/libaacplus/docs/aacplusenc.1
    /usr/share/doc/libaacplus/README
    /usr/share/doc/libaacplus/AUTHORS
    /usr/share/doc/libaacplus/TODO
    /usr/local/lib/libaacplus.so.2
    /usr/local/lib/libaacplus.so
    If you don't need libaacplus, fkd-aac, and libvpx you can simply omit --enable-libaacplus, --enable-libfdk-aac, and --enable-libvpx from the ffmpeg configure line. The instructions to add these external libraries are optional. If you don't plan on using them then it is recommended not to install them.

  5. #2225
    Join Date
    May 2012
    Beans
    3

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks for responding FakeOutdoorsman, I actually do plan on using the aac+ and aac codecs, and would like to try out the new vp8 codec. I compared my output from dpkg -L libaacplus to yours and it matches perfectly. I remember getting success from each of these installs when I ran the commands from the guide. I just copy and pasted directly from the guide. I also tried setting up an ubuntu 12.04 vm, followed the same steps, and everything worked. Its just not working on my Ubuntu 12.04 server for some reason.

    I pasted the error part from the configure log below. I did notice something interesting in the configure log. FFmpeg appears to be looking in '/usr/bin/ld' for some reason, then failing. I dont have this directory on my machine.

    /usr/bin/ld: error: cannot find -laacplus
    /tmp/ffconf.2DUaOkun.o:ffconf.qEzF9ZAK.c:function main: error: undefined reference to 'aacplusEncOpen'
    collect2: ld returned 1 exit status
    ERROR: libaacplus >= 2.0.0 not found

    I also tried running 'sudo ldconfig -v' and did see it listed like below.
    /usr/local/lib:
    libaacplus.so.2 -> libaacplus.so.2.0.2

    I hope this information is useful. I have no idea whats causing this. Thanks for the help.

  6. #2226
    Join Date
    Dec 2006
    Beans
    6,934

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Debate over sound quality never ends but arguable you would get better aac sound with neroAacEnc, not part of FFmpeg of course..
    You think that's air you're breathing now?

  7. #2227
    Join Date
    May 2012
    Beans
    3

    Re: HOWTO: Install and use the latest FFmpeg and x264

    So I was able to get FFmpeg to configure and install by omitting --enable-libfdk-aac and --enable-libaacplus in my configure command. I did install these libraries, but the configure wouldn't see them no mater how many times I removed and reinstalled them.

  8. #2228
    Join Date
    Nov 2006
    Beans
    216

    Re: HOWTO: Install and use the latest FFmpeg and x264

    good day

    i have been following your guide for ubuntu 10.04 https://ffmpeg.org/trac/ffmpeg/wiki/...tionGuideLucid everything goes well until i get to installing ffmpeg i do :

    ./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
    --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libvpx \
    --enable-libx264 --enable-nonfree --enable-version3 --enable-x11grab

    and it tells me :
    Unknown option "--enable-libopencore-am"
    --enable-libopencore-amrwb: command not found
    --enable-libx264: command not found

    any one have a clue what i have missed or done wrong ?

  9. #2229
    Join Date
    Nov 2006
    Beans
    216

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by klein de usa View Post
    good day

    i have been following your guide for ubuntu 10.04 https://ffmpeg.org/trac/ffmpeg/wiki/...tionGuideLucid everything goes well until i get to installing ffmpeg i do :

    ./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
    --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libvpx \
    --enable-libx264 --enable-nonfree --enable-version3 --enable-x11grab

    and it tells me :
    Unknown option "--enable-libopencore-am"
    --enable-libopencore-amrwb: command not found
    --enable-libx264: command not found

    any one have a clue what i have missed or done wrong ?

    i found my problem all is good

  10. #2230
    Join Date
    Sep 2006
    Beans
    3,489

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by koturk View Post
    So I was able to get FFmpeg to configure and install by omitting --enable-libfdk-aac and --enable-libaacplus in my configure command. I did install these libraries, but the configure wouldn't see them no mater how many times I removed and reinstalled them.
    I removed libaacplus instructions. I think it is unnecessary with fdk-aac (also capable of HE-AACv2 with the bonus of LC-AAC encoding too), I encountered some other issues compiling it on 12.04 server, and its download-and-patch functionality wasn't consistent for me causing unpatched files.

    I also have a vague recollection of libaacplus having issues when fdk-aac and/or vo-aacenc were either installed or during the ffmpeg configure, but I don't know if it is still a problem, so maybe try again and ffmpeg configure with fdk-aac might work as expected.

    Quote Originally Posted by klein de usa View Post
    and it tells me :
    Code:
    Unknown option "--enable-libopencore-am"
    --enable-libopencore-amrwb: command not found
    --enable-libx264: command not found
    any one have a clue what i have missed or done wrong ?
    Looks like a bad paste. Try again:
    Code:
    cd ~/ffmpeg
    make distclean
    ./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree --enable-version3 --enable-x11grab
    I tried it in Lucid and it worked fine for me.

Page 223 of 231 FirstFirst ... 123173213221222223224225 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •