Page 222 of 237 FirstFirst ... 122172212220221222223224232 ... LastLast
Results 2,211 to 2,220 of 2362

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #2211
    Join Date
    Sep 2006
    Beans
    3,599

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by mc4man View Post
    Edit; the alt. would be to build fdk-aac as static only, don't know enough about it to say
    (./configure --disable-shared
    It should be static like the others. I'll test and update it later today.

  2. #2212
    Join Date
    Jan 2009
    Beans
    77

    Re: HOWTO: Install and use the latest FFmpeg and x264

    mc4man, that sudo ldconfig resolved it. Thanks a ton.
    Maybe the guide needs to be updated with this

  3. #2213
    Join Date
    Sep 2006
    Beans
    3,599

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I updated the guide. It is now static so running ldconfig or monkeying with any environment variables are now not required.

  4. #2214
    Join Date
    Jan 2009
    Beans
    77

    Re: HOWTO: Install and use the latest FFmpeg and x264

    One more thing FakeOutdoorsman
    Under the FFmpeg compile section, in ./configure --enable-x11grab is missing. It only says to omit for servers but I did it for a desktop and now I got a
    "Unknown input format: 'x11grab'

  5. #2215
    Join Date
    Sep 2006
    Beans
    3,599

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by cannon_dt View Post
    One more thing FakeOutdoorsman
    Under the FFmpeg compile section, in ./configure --enable-x11grab is missing.
    Thanks for the notification. It was listed in the configure originally, but it appears someone removed it (it is a wiki) and I didn't notice when I cleaned up their mess. I'll add it again.

    Quote Originally Posted by cannon_dt View Post
    ...I did it for a desktop and now I got a
    "Unknown input format: 'x11grab'
    Can you show your ffmpeg command and the complete console output?

  6. #2216
    Join Date
    Jan 2009
    Beans
    77

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Sorry fakeoutdoorsman.
    I fixed the problem by reinstalling ffmpeg. So I dont have the complete console output
    However the command I used is

    Code:
    ffmpeg -f alsa -ac 2 -i hw:0,0 -f x11grab -r 30 \
            -s $(xwininfo -frame | grep -oEe 'geometry [0-9]+x[0-9]+' | grep -oEe '[0-9]+x[0-9]+') \
            -i :0.0+$(xwininfo -frame | grep -oEe 'Corners:\s+\+[0-9]+\+[0-9]+' \
            | grep -oEe '[0-9]+\+[0-9]+' | sed -e 's/\+/,/' ) \
            -acodec pcm_s16le -vcodec libx264 -preset ultrafast -crf 0 -threads 0 \
            -y ~/Public/screencast/aa_screencast_baking.mkv
    Last edited by cannon_dt; September 4th, 2012 at 07:53 AM. Reason: Make it look cleaner

  7. #2217
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi
    In the wiki for FFmpeg it shows:-
    Code:
    ./configure... --enable-libopencore-amrnb --enable-libopencore-amrwb ...
    I think that libopencore-amrwb is only a DEcoder, not an ENcoder.
    ffmpeg -codecs shows:-
    Code:
     DEA D    libopencore_amrnb OpenCORE AMR-NB (Adaptive Multi-Rate Narrow-Band)
     D A D    libopencore_amrwb OpenCORE AMR-WB (Adaptive Multi-Rate Wide-Band)
    Doesn't it need vo-amrwbenc to be compiled and installed to enable amr-wb encoding?

    I have compiled from here ---> http://sourceforge.net/projects/open...les/vo-aacenc/
    But it looks as though there's a git version here ---> https://github.com/mstorsjo/vo-aacenc
    (libvo-amrwbenc-dev is in the repo for Oneiric-Pangolin-Quantal)
    Last edited by ron999; September 6th, 2012 at 03:48 AM.

  8. #2218
    Join Date
    Sep 2006
    Beans
    3,599

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by ron999 View Post
    I think that libopencore-amrwb is only a DEcoder, not an ENcoder.
    Yes, I believe it is a decoder only, but I've never used it personally.

    Quote Originally Posted by ron999 View Post
    Doesn't it need vo-amrwbenc to be compiled and installed to enable amr-wb encoding?
    You can use vo-amrwbenc as an encoder in ffmpeg. Just compile it and then add "--enable-libvo-amrwbenc --enable-version3" to your ffmpeg ./configure. I haven't checked to see if it is in an Ubuntu(+1) repository yet.

    Quote Originally Posted by ron999 View Post
    I have compiled from here ---> http://sourceforge.net/projects/open...les/vo-aacenc/
    But it looks as though there's a git version here ---> https://github.com/mstorsjo/vo-aacenc
    vo-aacenc is another AAC encoder. Did you mean this: https://github.com/mstorsjo/vo-amrwbenc.

    Quote Originally Posted by ron999 View Post
    (libvo-amrwbenc-dev is in the repo for Oneiric-Pangolin-Quantal)
    Thanks for the tip. Maybe I'll add it as a dependency, but I don't know how useful it would be for the general public.

  9. #2219
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    Yes, that's the one.
    I posted the wrong links, my bad.

  10. #2220
    Join Date
    Oct 2011
    Beans
    24

    Re: HOWTO: Install and use the latest FFmpeg and x264

    x11grab isn't working for me. I've installed ffmpeg using the tutorial on the wiki, and ffmpeg seems to work, except for x11grab

    For example, if I try
    Code:
    ffmpeg -f x11grab -i hw:0 test.mkv
    I get this
    Code:
    ffmpeg version N-35113-g509f502 Copyright (c) 2000-2012 the FFmpeg developers
      built on Sep 14 2012 15:44:58 with gcc 4.6 (Ubuntu/Linaro 4.6.3-1ubuntu5)
      configuration: 
      libavutil      51. 73.100 / 51. 73.100
      libavcodec     54. 55.100 / 54. 55.100
      libavformat    54. 27.100 / 54. 27.100
      libavdevice    54.  2.100 / 54.  2.100
      libavfilter     3. 16.103 /  3. 16.103
      libswscale      2.  1.101 /  2.  1.101
      libswresample   0. 15.100 /  0. 15.100
    Unknown input format: 'x11grab'
    Any help?

Page 222 of 237 FirstFirst ... 122172212220221222223224232 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •