Page 213 of 240 FirstFirst ... 113163203211212213214215223 ... LastLast
Results 2,121 to 2,130 of 2393

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #2121
    Join Date
    Sep 2006
    Beans
    3,685

    Re: HOWTO: Install and use the latest FFmpeg and x264

    FFmpeg can support four AAC encoders: the native AAC encoder (I'll call it ffaacenc), libfaac, libvo_aacenc, and libaacplus, but this guide only supports ffaacenc and libfaac. Installing the others isn't too hard; maybe I'll add separate instructions for the others later this week.

    You should see ffmpeg -codecs instead of ffmpeg -formats to see a list of supported encoders and decoders:
    Code:
    $ ffmpeg -codecs | grep aac
    ...
     DEA D  aac             Advanced Audio Coding
     D A D  aac_latm        AAC LATM (Advanced Audio Codec LATM syntax)
      EA    libfaac         libfaac AAC (Advanced Audio Codec)
    libav-ffmpeg from the repository with libraries from Medibuntu (instructions here) should also include ffaacenc and libfaac.

    To encode with libfaac. This example will output VBR:
    Code:
    ffmpeg -i input -c:a libfaac -q:a 100 -vn output.mp4
    This example will output ABR (or maybe CBR):
    Code:
    ffmpeg -i input -c:a libfaac -b:a 128k -vn output.mp4
    To encode with ffaacenc:
    Code:
    ffmpeg -i input -strict experimental -c:a aac -b:a 128k -vn output.mp4
    You can also probably use -q:a with ffaacenc, but I'm not sure of the supported values or if it even works.

    You can also pipe from ffmpeg to any encoder that accepts piped input:
    Code:
    ffmpeg -i input -f wav - | faac -o output.mp4 -
    This is effective if you don't feel like compiling FFmpeg if your version doesn't support your desired encoder.
    Last edited by FakeOutdoorsman; March 1st, 2012 at 09:14 PM.

  2. #2122
    Join Date
    Oct 2006
    Beans
    22

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Tx FakeOutdoorsman

    I probably had aac encoding all the time:

    ffmpeg -codecs | grep aac
    ffmpeg version git-2012-02-29-a77c8ad Copyright (c) 2000-2012 the FFmpeg developers
    built on Mar 1 2012 19:52:28 with gcc 4.6.1
    configuration: --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libx264 --enable-nonfree --enable-version3 --enable-x11grab
    libavutil 51. 41.100 / 51. 41.100
    libavcodec 54. 4.100 / 54. 4.100
    libavformat 54. 1.100 / 54. 1.100
    libavdevice 53. 4.100 / 53. 4.100
    libavfilter 2. 62.101 / 2. 62.101
    libswscale 2. 1.100 / 2. 1.100
    libswresample 0. 7.100 / 0. 7.100
    libpostproc 52. 0.100 / 52. 0.100
    DEA D aac Advanced Audio Coding
    D A D aac_latm AAC LATM (Advanced Audio Codec LATM syntax)
    EA libfaac libfaac AAC (Advanced Audio Codec)

    I was following blindly other posts by polling formats.

    Tx also for the very quick feedback

  3. #2123
    Join Date
    Feb 2010
    Location
    Italy
    Beans
    177
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: HOWTO: Install and use the latest FFmpeg and x264

    main purpose:

    how to solve
    ffmpeg: relocation error: /usr/local/lib/libswresample.so.0: symbol av_opt_set_int, version LIBAVUTIL_51 not defined in file libavutil.so.51 with link time reference

    alternatively how to solve:
    segmentation fault


    Hello,

    I recently installed the last ffmpeg and x264 following this howto with the only difference that I used the following configuration

    Code:
    ./configure --enable-gpl  --enable-libgsm --enable-libxvid \
    --enable-libmp3lame --enable-libvorbis --enable-libfaac \
    --enable-shared --enable-libopencore-amrnb --enable-libvpx \
    --enable-libopencore-amrwb --enable-libtheora --enable-libx264 \
    --enable-nonfree --enable-version3 --enable-x11grab
    I'm trying to convert a h264 video file using this code
    Code:
    ffmpeg -i "input.mp4" -ar 44100 -ac 2 -ab 192k -acodec libmp3lame -s 1280x544 -vcodec libxvid -r 23.98 -b 2500k "output.avi"
    I get this error
    Code:
    ffmpeg: relocation error: /usr/local/lib/libswresample.so.0: symbol av_opt_set_int, version LIBAVUTIL_51 not defined in file libavutil.so.51 with link time reference
    However the above error is prompted for any ffmpeg command such
    Code:
    $ ffmpeg -v
    For reference I have:
    Code:
    $ ldd /usr/local/bin/ffmpeg | grep libavutil
    	libavutil.so.51 => /usr/lib/i686/cmov/libavutil.so.51 (0x00269000)
    
    $ dpkg --get-selections | grep libavutil
    libavutil-dev					install
    libavutil-extra-51				install
    libavutil51					deinstall
    
    $ uname -a
    Linux my-pc 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:50:54 UTC 2012 i686 i686 i386 GNU/Linux
    Looking at the release file note of ffmpeg I've installed the 0.9.1.git and I'm using lubuntu oneiric 32bit

    My doubt is that I don't have any libswresample at all
    Code:
    $ ls -lrt /usr/local/bin | grep libswresample
    $
    
    $ ls -lrt /usr/bin | grep libswresample
    $
    and I don't have it listed in the repository either
    Code:
    $ dpkg -l | grep libswres
    $
    I also tried to download a deb package of libswresample from here but I cannot install it as it says me
    Code:
    Error: Dependency is not satisfiable: libavutil51 (>= 5:0.10)
    I installed libavutil51 which was in conflict but it's a previous version:
    Code:
    $ dpkg -s libavutil51
    Package: libavutil51
    Status: install ok installed
    Priority: optional
    Section: libs
    Installed-Size: 352
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Architecture: i386
    Source: libav
    Version: 4:0.7.3-0ubuntu0.11.10.1
    Depends: libc6 (>= 2.4)
    Description: Libav utility library
     This is the common utility library from Libav. It contains shared code
     used by all other Libav libraries.
    Homepage: http://libav.org/
    Original-Maintainer: Debian multimedia packages maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
    So I still cannot go ahead .. must I search, compile and install a newer version of libavutil51?

    I'm afraid I'm going to have and endless list of troubles going this way ...

    Any suggestions on how to solve this?

    The reason why I'trying to install a newer version of ffmpeg and x264 is that running the code I firstly wrote, which is
    Code:
    ffmpeg -i "input.mp4" -ar 44100 -ac 2 -ab 192k -acodec libmp3lame -s 1280x544 -vcodec libxvid -r 23.98 -b 2500k "output.avi"
    on a video file I downloaded from the net I got a
    Code:
    Segmentation fault
    error so I thought I need a newer version of ffmpeg/x264 from the one I have in my repository

    Thanks in advance for any help
    Last edited by tanoloco; March 2nd, 2012 at 02:40 PM.

  4. #2124
    Join Date
    Sep 2006
    Beans
    3,685

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by tanoloco View Post
    I recently installed the last ffmpeg and x264 following this howto with the only difference that I used the following configuration

    Code:
    ./configure --enable-gpl  --enable-libgsm --enable-libxvid \
    --enable-libmp3lame --enable-libvorbis --enable-libfaac \
    --enable-shared --enable-libopencore-amrnb --enable-libvpx \
    --enable-libopencore-amrwb --enable-libtheora --enable-libx264 \
    --enable-nonfree --enable-version3 --enable-x11grab
    How else did you deviate from the guide? Why did you add --enable-shared? Are you using Ubuntu 11.10?

    Quote Originally Posted by tanoloco View Post
    on a video file I downloaded from the net I got a Segmentation fault error
    Did you get the segmentation fault with "ffmpeg" from the repository? Can you provide a sample so I can attempt to duplicate the segmentation fault? Also provide the complete console output that includes the seg fault.

  5. #2125
    Join Date
    Feb 2010
    Location
    Italy
    Beans
    177
    Distro
    Lubuntu 12.04 Precise Pangolin

    Lightbulb Re: HOWTO: Install and use the latest FFmpeg and x264

    SOLVED: see point B!

    Quote Originally Posted by FakeOutdoorsman View Post
    Are you using Ubuntu 11.10?
    Did you get the segmentation fault with "ffmpeg" from the repository? Can you provide a sample so I can attempt to duplicate the segmentation fault? Also provide the complete console output that includes the seg fault.
    Hello and thank you so much for your quick reply!
    So I divide my question into two points:

    A) Segmentation fault:
    Yes I'm using Ubuntu 11.10 ... actually lubuntu oneiric flavour
    Code:
    $ uname -a
    Linux my-pc 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:50:54 UTC 2012 i686 i686 i386 GNU/Linux
    To reproduce the segmentation fault:
    1. I started removing everything I've installed following your (very nice) guide, to install them again from the repository
    Code:
    $ sudo apt-get remove ffmpeg x264 libx264-dev
    $ sudo apt-get install ffmpeg x264 libx264-dev
    Which gave me the following versions of:
    ffmpeg
    Code:
    $ dpkg -s ffmpeg
    Package: ffmpeg
    Status: install ok installed
    Priority: optional
    Section: video
    Installed-Size: 1340
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Architecture: i386
    Source: libav
    Version: 4:0.7.3-0ubuntu0.11.10.1
    Replaces: libavcodec-extra-53 (<< 4:0.6~), libavcodec53 (<< 4:0.7.3-0ubuntu0.11.10.1)
    Depends: libavcodec53 (>= 4:0.7.3-0ubuntu0.11.10.1) | libavcodec-extra-53 (>= 4:0.7.3), libavcodec53 (<< 4:0.7.3-99) | libavcodec-extra-53 (<< 4:0.7.3.99), libavdevice53 (>= 4:0.7.3-0ubuntu0.11.10.1) | libavdevice-extra-53 (>= 4:0.7.3), libavdevice53 (<< 4:0.7.3-99) | libavdevice-extra-53 (<< 4:0.7.3.99), libavfilter2 (>= 4:0.7.3-0ubuntu0.11.10.1) | libavfilter-extra-2 (>= 4:0.7.3), libavfilter2 (<< 4:0.7.3-99) | libavfilter-extra-2 (<< 4:0.7.3.99), libavformat53 (>= 4:0.7.3-0ubuntu0.11.10.1) | libavformat-extra-53 (>= 4:0.7.3), libavformat53 (<< 4:0.7.3-99) | libavformat-extra-53 (<< 4:0.7.3.99), libavutil51 (>= 4:0.7.3-0ubuntu0.11.10.1) | libavutil-extra-51 (>= 4:0.7.3), libavutil51 (<< 4:0.7.3-99) | libavutil-extra-51 (<< 4:0.7.3.99), libc6 (>= 2.7), libpostproc52 (>= 4:0.7.3-0ubuntu0.11.10.1) | libpostproc-extra-52 (>= 4:0.7.3), libpostproc52 (<< 4:0.7.3-99) | libpostproc-extra-52 (<< 4:0.7.3.99), libsdl1.2debian (>= 1.2.10-1), libswscale2 (>= 4:0.7.3-0ubuntu0.11.10.1) | libswscale-extra-2 (>= 4:0.7.3), libswscale2 (<< 4:0.7.3-99) | libswscale-extra-2 (<< 4:0.7.3.99)
    Conflicts: ffprobe
    Conffiles:
     /etc/ffserver.conf d4d0a77d594735af0d92e12e2b74aa15
    Description: Multimedia player, server, encoder and transcoder
     This package contains the ffplay multimedia player, the ffserver streaming
     server and the ffmpeg audio and video encoder. They support most existing
     file formats (AVI, MPEG, OGG, Matroska, ASF...) and encoding formats (MPEG,
     DivX, MPEG4, AC3, DV...).
    Homepage: http://libav.org/
    Original-Maintainer: Debian multimedia packages maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
    x264
    Code:
    $ dpkg -s x264
    Package: x264
    Status: install ok installed
    Priority: optional
    Section: graphics
    Installed-Size: 656
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Architecture: i386
    Version: 2:0.116.2042+git178455c-1ubuntu1
    Replaces: x264-bin
    Depends: libavutil51 (>= 4:0.7-1) | libavutil-extra-51 (>= 4:0.7-1), libc6 (>= 2.7), libffms2-2, libswscale2 (>= 4:0.7-1) | libswscale-extra-2 (>= 4:0.7-1), libx264-116
    Conflicts: x264-bin
    Description: video encoder for the H.264/MPEG-4 AVC standard
     x264 is an advanced commandline encoder for creating H.264 (MPEG-4 AVC)
     video streams.
     .
     x264 supports the following features:
      * CABAC (context-based adaptive binary arithmetic coding) and CAVLC
        (context-based adaptive variable length coding
      * multiple reference frames
      * 16x16, 8x8 and 4x4 intra-predicted macroblocks
      * all P-frame inter-predicted macroblock types
      * B-Inter-predicted macroblock types from 16x16 down to 8x8
      * rate distortion optimization
      * multiple rate control modes (constant quantizer, constant quality, single
        or multipass ABR with the option of VBV)
      * scene cut detection
      * adaptive B-frame placement, with the option of keeping B-frames as
        references / arbitrary frame order
      * 8x8 and 4x4 adaptive spatial transform (high profile)
      * lossless mode (high 4:4:4 profile)
      * custom quantization matrices (high profile)
      * parallel encoding on multiple CPUs
      * interlaced streams
    Original-Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
    Homepage: http://www.videolan.org/developers/x264.html
    libx264-dev
    Code:
    $ dpkg -s libx264-dev
    Package: libx264-dev
    Status: install ok installed
    Priority: optional
    Section: libdevel
    Installed-Size: 1324
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Architecture: i386
    Source: x264
    Version: 2:0.116.2042+git178455c-1ubuntu1
    Depends: libx264-116 (= 2:0.116.2042+git178455c-1ubuntu1)
    Description: development files for libx264
     libx264 is an advanced encoding library for creating H.264 (MPEG-4 AVC)
     video streams.
     .
     This package contains the static library and headers used to build programs
     that use libx264.
    Original-Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
    Homepage: http://www.videolan.org/developers/x264.html
    2. You can download a sample of the video I'm trying to convert here it's a file of about 9 Mb.

    3. I'm trying to convert it using the following command
    Code:
    $ ffmpeg -i "sample.mp4" -ar 44100 -ac 2 -ab 192k -acodec libmp3lame -s 1280x544 -vcodec libxvid -r 23.98 -b 2500k "output.avi"
    I get the following error
    Code:
    ffmpeg version 0.7.3-4:0.7.3-0ubuntu0.11.10.1, Copyright (c) 2000-2011 the Libav developers
      built on Jan  4 2012 16:21:50 with gcc 4.6.1
      configuration: --extra-version='4:0.7.3-0ubuntu0.11.10.1' --arch=i386 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
      WARNING: library configuration mismatch
      avutil      configuration: --extra-version='4:0.7.3ubuntu0.11.10.1+medibuntu1' --arch=i386 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3 --enable-vaapi --enable-libopenjpeg --enable-libfaac --enable-nonfree --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdirac --enable-libmp3lame --enable-librtmp --enable-libx264 --enable-libxvid --enable-libopencore-amrnb --enable-version3 --enable-libopencore-amrwb --enable-version3 --enable-libvo-aacenc --enable-version3 --enable-libvo-amrwbenc --enable-version3 --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
      avcodec     configuration: --extra-version='4:0.7.3ubuntu0.11.10.1+medibuntu1' --arch=i386 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3 --enable-vaapi --enable-libopenjpeg --enable-libfaac --enable-nonfree --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdirac --enable-libmp3lame --enable-librtmp --enable-libx264 --enable-libxvid --enable-libopencore-amrnb --enable-version3 --enable-libopencore-amrwb --enable-version3 --enable-libvo-aacenc --enable-version3 --enable-libvo-amrwbenc --enable-version3 --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
      avformat    configuration: --extra-version='4:0.7.3-0ubuntu0.11.10.1' --arch=i386 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
      avdevice    configuration: --extra-version='4:0.7.3-0ubuntu0.11.10.1' --arch=i386 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
      avfilter    configuration: --extra-version='4:0.7.3-0ubuntu0.11.10.1' --arch=i386 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
      swscale     configuration: --extra-version='4:0.7.3-0ubuntu0.11.10.1' --arch=i386 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
      postproc    configuration: --extra-version='4:0.7.3-0ubuntu0.11.10.1' --arch=i386 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
      libavutil    51.  7. 0 / 51.  7. 0
      libavcodec   53.  6. 0 / 53.  6. 0
      libavformat  53.  3. 0 / 53.  3. 0
      libavdevice  53.  0. 0 / 53.  0. 0
      libavfilter   2.  4. 0 /  2.  4. 0
      libswscale    2.  0. 0 /  2.  0. 0
      libpostproc  52.  0. 0 / 52.  0. 0
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'sample.mp4':
      Metadata:
        major_brand     : mp42
        minor_version   : 0
        compatible_brands: mp42isomavc1
        creation_time   : 2011-04-20 03:55:11
        encoder         : HandBrake 0.9.5 2011010300
      Duration: 00:00:30.03, start: 0.000000, bitrate: 2530 kb/s
        Stream #0.0(und): Video: h264 (High), yuv420p, 1280x544, 2141 kb/s, 23.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc
        Metadata:
          creation_time   : 2011-04-20 03:55:11
        Stream #0.1(eng): Audio: aac, 48000 Hz, 5.1, s16, 383 kb/s
        Metadata:
          creation_time   : 2011-04-20 03:55:11
    [buffer @ 0x89fb020] w:1280 h:544 pixfmt:yuv420p
    Output #0, avi, to 'output.avi':
      Metadata:
        major_brand     : mp42
        minor_version   : 0
        compatible_brands: mp42isomavc1
        creation_time   : 2011-04-20 03:55:11
        ISFT            : Lavf53.3.0
        Stream #0.0(und): Video: mpeg4, yuv420p, 1280x544, q=2-31, 2500 kb/s, 23.98 tbn, 23.98 tbc
        Metadata:
          creation_time   : 2011-04-20 03:55:11
        Stream #0.1(eng): Audio: libmp3lame, 44100 Hz, 2 channels, s16, 192 kb/s
        Metadata:
          creation_time   : 2011-04-20 03:55:11
    Stream mapping:
      Stream #0.0 -> #0.0
      Stream #0.1 -> #0.1
    Press ctrl-c to stop encoding
    Segmentation Fault
    B) Following your howto:
    Why --enable-shared ? you asked ..
    The only params changing from your guide are --enable-shared --enable-libgsm --enable-libxvid .. actually the only one I really need is libxvid so I discarded the others and recompiled ffmpeg.
    So following your guide I completed point 1 (with sudo apt-get autoremove too), 2, 3, 4 and 5 (installing ffmpeg) with
    Code:
    ./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libx264     --enable-nonfree --enable-version3 --enable-x11grab --enable-libxvid --enable-libvpx
    and then everything went ok!
    So now I can convert my sample.mp4 with the same command as above! (see point A.3)

    So you were right: the problem was --enable-shared!
    Thank you very much for your support!
    Last edited by tanoloco; March 2nd, 2012 at 11:36 PM.

  6. #2126
    Join Date
    Dec 2006
    Beans
    7,299

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Exciting times for FFmpeg and MPlayer users: Windows Media Audio Lossless decoder.
    You think that's air you're breathing now?

  7. #2127
    Join Date
    Sep 2006
    Beans
    3,685

    Re: HOWTO: Install and use the latest FFmpeg and x264

    ...and another for today: bluray protocol.

  8. #2128
    Join Date
    Jun 2007
    Location
    india>maharastra>nashik
    Beans
    192
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    thanks i was searchig for a perfict screencast which ended hear. Thanks a lot for this good work of yours.

  9. #2129
    Join Date
    Sep 2011
    Beans
    2

    Re: HOWTO: Install and use the latest FFmpeg and x264

    When I try installing FFmpeg from Git as you have given and then I try to install OpenCV, I keep getting these undefined reference errors.

    I then downloaded the version 0.10 source and compiled from there and OpenCV installed without issue.

    Why is this discrepancy present?

  10. #2130
    Join Date
    Sep 2006
    Beans
    3,685

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by varagrawal View Post
    Why is this discrepancy present?
    It's hard to give a reason without seeing the errors.

Page 213 of 240 FirstFirst ... 113163203211212213214215223 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •