Page 195 of 230 FirstFirst ... 95145185193194195196197205 ... LastLast
Results 1,941 to 1,950 of 2295

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #1941
    Join Date
    Dec 2005
    Location
    St. Petersburg, FL
    Beans
    521
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Avidemux does use libavcodec to do any encoding (not sure if static, however), but that still leaves two different scenarios:

    1) The blocking is due to not cutting on I frame or GOP boundaries. In this case, the 'blocking' would probably look more like smearing, since it doesn't have all the data. To remedy this, programs might use a smart encoding process that will decode only those portions affected by a bad merge so that all the data is retained, and then re-encode that portion so that all there aren't any adverse artifacts.

    2) You're encountering a case of libavcodec's bad rate control, especially in the event of joins that incur a smart encoding method (again, I don't know if Avidemux does smart encoding). My tests of libavcodec as an MPEG-2 encoder a few years ago showed that it had pretty bad RC that was most obvious at the very beginning of a stream and then lessened as encoding progressed. I've not done tests with a current version to know whether this has been improved - FFmpeg's git log does show that there have been fairly recent commits that affected the MPEG-2 encoder, so it's possible that it has. That's no guarantee that Avidemux is using that updated code, though (especially in the case of Avidemux under Natty; the more recent MPEG-2 commits were from September).
    Last edited by qyot27; November 20th, 2011 at 10:29 PM.

  2. #1942
    Join Date
    Jun 2011
    Beans
    30

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I could see that happening, the join smearing where I've moved single frames and made a cut, and not on key frames.

    it's making all my films look so amateurish!! actual frames are being ground up in the process.

    I've just read up .. about mpeg editors and realise now that editing mpeg is not the easiest or best thing to do!

    the thing is I tend to put all my MTS files from my hd camera through Kdenlive to make mpeg files for dvds, and only after the mpegs are made I might need to cut out parts (kdenlive makes freezes happen with me) or re-edit them for m4v encoding with handbrake. It would NOT be that practical to put the MTS through kdenlive all over again (that's at least 4x movie length for encode time on my intel core duo) to make another edit.

    putting the mpeg movie into kdenlive again and rendering with cuts gives a movie with no smearing. it's just its a lot easier to edit in avidemux.

    ------
    OK, I've found that converting the movie to DV with avidemux re-encodes and hence gives no blocky transitions, the output of this DV from handbrake is good quality too. My problem was with avidemux not re-encoding but sticking the mpeg pieces together which is not a good idea.

    But oh help, DV files are huge, so I might have to do all the work in kdenlive and render to a good mpeg2 setting.
    Last edited by ppqq; November 21st, 2011 at 05:42 PM.

  3. #1943
    Join Date
    Jul 2010
    Beans
    26

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I fixed the compile error on OpenCV "relocation R_X86_64_32S against `a local symbol' can not be used when making a shared object; recompile with -fPIC" on my Ubuntu 11.10 64 bit system.

    The cure was to add " --enable-pic --enable-shared" in addition to "--enable static" while configuring x264. Also I had to add " --enable-pic --enable-shared" while configuring ffmpeg.

    Thanks to:
    http://thebitbangtheory.wordpress.co...rt/#comment-71

  4. #1944
    Join Date
    Dec 2008
    Beans
    340
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Install and use the latest FFmpeg and x264

    HELP

    I'm unable to install this from step 4 onwards. I get connection error message

    Code:
    ****@******:~$ cd
    ****@******:~$ git clone git://git.videolan.org/x264
    Initialized empty Git repository in /home/****/x264/.git/
    git.videolan.org[0: 88.191.250.118]: errno=Connection refused
    fatal: unable to connect a socket (Connection refused)
    ****@******:~$ cd x264
    bash: cd: x264: No such file or directory
    ****@******:~$ ./configure --enable-static
    bash: ./configure: No such file or directory
    ****@******:~$ make
    make: *** No targets specified and no makefile found.  Stop.
    ****@******:~$ sudo checkinstall --pkgname=x264 --default --pkgversion="3:$(./version.sh | \
    >     awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes

  5. #1945
    Join Date
    Sep 2006
    Beans
    3,470

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Some users may not be able to use Git. For example, the Git server may refuse the connection or a firewall on the users end might be interfering. Here are two alternative methods to get the x264, libvpx, and FFmpeg project files:

    Using Git over http
    The guide uses the git protocol for the git clone command. The files can also be retrieved over http instead and will probably not be blocked by firewalls. This method is slower, but will still give the user the same files. Note that the command may sit for a long time with little user feedback. To retrieve the files via http instead, use:
    Code:
    git clone http://git.videolan.org/git/x264.git
    Using Snapshots
    You can also skip Git completely and use snapshots instead. A snapshot is a routinely updated collection of all project source files continently compressed into a single file.

    x264
    Code:
    cd
    wget ftp://ftp.videolan.org/pub/x264/snapshots/last_x264.tar.bz2
    tar xvjf last_x264.tar.bz2
    cd x264-snapshot-*
    Then continue with the ./configure line in the Install x264 section. Now for libvpx if you decide to use it too:

    libvpx
    Code:
    cd
    wget "http://git.chromium.org/gitweb/?p=webm/libvpx.git;a=snapshot;h=HEAD;sf=tgz" -O libvpx-snapshot.tar.gz
    tar xzvf libvpx-snapshot.tar.gz
    cd libvpx-HEAD-*
    Then continue with the ./configure line in the Install libvpx section. The FFmpeg snapshot is similar:

    FFmpeg
    Code:
    cd
    wget "http://git.videolan.org/?p=ffmpeg.git;a=snapshot;h=HEAD;sf=tgz" -O ffmpeg-snapshot.tar.gz
    tar xzvf ffmpeg-snapshot.tar.gz
    cd ffmpeg-HEAD-*
    Now, as with the others, continue with the ./configure line in the Install FFmpeg section. Follow the rest of the guide normally.
    Last edited by FakeOutdoorsman; November 23rd, 2011 at 09:55 PM.

  6. #1946
    Join Date
    Jun 2007
    Beans
    12,909

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    . Note that the command may sit for a long time with little user feedback.
    Just to mention because I've seen this confuse a few users who thought their terminal/command had 'frozen'

    In gnome/nautilus 3 it's been decided to timeout the cursor blink at 10 secs
    I find it annoying & reset much higher

    Can be seen with this
    ~$ gsettings get org.gnome.desktop.interface cursor-blink-timeout
    10
    And altered with this, value as desired

    Code:
    gsettings set org.gnome.desktop.interface cursor-blink-timeout 200

  7. #1947
    Join Date
    Dec 2008
    Beans
    340
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks for the heads up, FakeOutdoorsman. It is indeed a sort firewall issue (git protocol apparently had no permission to pass through) basically the problem is caused as a result of the fact that I didn't recognize that git protocol before (I'm no Linux pro so it didn't even catch my eye that there was a different protocol... I was thinking it was the IP or some other thing that was the problem. So now rather than follow up on your alternative suggestions I'll go back to the original instruction step and see how that goes first...

  8. #1948
    Join Date
    Nov 2009
    Beans
    611

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Excellent work folks.

    Is there a simple set of instructions to install the latest stable version of FFMPEG for Ubuntu 10.04?

    I really need help with this stuff.

    Thanks.

  9. #1949
    Join Date
    Sep 2006
    Beans
    3,470

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I consider FFmpeg from Git to be stable (for my purposes) on most occasions, but others have disagreed with me. Of couse a project with such active development will encounter issues, but most of the time they are fixed in a timely manner. Once again, others have disagreed with me on this point.

    If you don't feel comfortable using the bleeding-edge, then you can try a recent release version. For a typical user a release version probably won't have any advantages over FFmpeg from Git other than they are called a "release" to ease any anxiety from stability concerns.

    Compiling and installing a release version is fairly similar to using FFmpeg from Git as shown in the guide. Just download your desired release version from the FFmpeg download page, extract the archive file, and then continue with the guide starting with the appropriate ./configure line.

    As for x264, there is a stable branch. x264 updates are usually pushed in one big dump every month or two. This includes fixes and other non-fix updates. The stable branch will include the most recent fixes, but the other non-fix updates won't be included in stable until the next set of updates. This allows the developers to catch any unforseen bugs that can be fixed before the next push to stable, and therefore hopefully decreasing the number of bugs encountered by the user. That's the idea at least, as I understand it, but I don't know how many bugs have actually been avoided in stable. To switch to the stable branch for x264, enter the following command before the x264 ./configure command:
    Code:
    git checkout stable
    Last edited by FakeOutdoorsman; November 24th, 2011 at 09:34 AM.

  10. #1950
    Join Date
    Nov 2009
    Beans
    611

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks for helping me but I got an error message when I tried to get the mp3 from a video file.

    Below is the entire results from the command line input to the end;


    Code:
    echo@echo-laptop:~/Downloads$ ffmpeg -i rrr.mp4 dkdik.mp3
    ffmpeg version git-2011-11-24-957867a, Copyright (c) 2000-2011 the FFmpeg developers
      built on Nov 24 2011 07:50:58 with gcc 4.4.3
      configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-libfaac --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libx264 --enable-x11grab
      libavutil    51. 27. 0 / 51. 27. 0
      libavcodec   53. 37. 0 / 53. 37. 0
      libavformat  53. 21. 0 / 53. 21. 0
      libavdevice  53.  4. 0 / 53.  4. 0
      libavfilter   2. 49. 0 /  2. 49. 0
      libswscale    2.  1. 0 /  2.  1. 0
      libpostproc  51.  2. 0 / 51.  2. 0
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'rrr.mp4':
      Metadata:
        major_brand     : mp42
        minor_version   : 0
        compatible_brands: isommp42
        creation_time   : 2011-09-11 20:34:31
      Duration: 00:09:58.73, start: 0.000000, bitrate: 610 kb/s
        Stream #0:0(und): Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuv420p, 640x360, 508 kb/s, 29.97 fps, 29.97 tbr, 1k tbn, 59.94 tbc
        Metadata:
          creation_time   : 1970-01-01 00:00:00
          handler_name    : VideoHandler
        Stream #0:1(und): Audio: aac (mp4a / 0x6134706D), 44100 Hz, stereo, s16, 95 kb/s
        Metadata:
          creation_time   : 2011-09-11 20:34:32
          handler_name    : 
    Output #0, mp3, to 'dkdik.mp3':
      Metadata:
        major_brand     : mp42
        minor_version   : 0
        compatible_brands: isommp42
        creation_time   : 2011-09-11 20:34:31
        Stream #0:0(und): Audio: none, 44100 Hz, stereo, s16, 128 kb/s
        Metadata:
          creation_time   : 2011-09-11 20:34:32
          handler_name    : 
    Stream mapping:
      Stream #0:1 -> #0:0 (aac -> ?)
    Encoder (codec none) not found for output stream #0:0
    Any idea how to fix it?

    Thank you

Page 195 of 230 FirstFirst ... 95145185193194195196197205 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •