Page 129 of 236 FirstFirst ... 2979119127128129130131139179229 ... LastLast
Results 1,281 to 1,290 of 2357

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #1281
    Join Date
    May 2010
    Beans
    6

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    Are you using Ubuntu? If yes, what version are you using? I would expect to see bash, not sh. qt-faststart should be executable from any directory if it installed correctly.
    Code:
    $ whereis qt-faststart
    qt-faststart: /usr/local/bin/qt-faststart

    Yes, Ubuntu 10.04.

    I did the whereis command and only received the following

    Code:
    $ whereis qt-faststart
    qt-faststart:
    So I guess it is not installed.

    By the way, when I was using your terrific guide at the top of this thread for Lucid, I would get an error saying something like "y is not a valid something something for deldoc" (sorry, I can't remember the exact error and it was several hours ago). I didn't use "--deldoc=y" I used "--deldoc=yes" as you have it, so I don't understand that error.

    I tried to install ffmpeg and qt-faststart without the --deldoc=yes switch. ffmpeg works for me, it's just qt-faststart that doesn't.

    Edit to add: figured it out -- I cut off the end of the checkinstall line when I pasted it, thinking the "> >" printed needed to be deleted. Same issue with what I did with the qt-faststart below.
    Last edited by spacechampion; September 18th, 2010 at 05:46 AM. Reason: solved

  2. #1282
    Join Date
    May 2010
    Beans
    6

    Re: HOWTO: Install and use the latest FFmpeg and x264

    edited this post to remove my install log since below I figured out what happened.
    Last edited by spacechampion; September 18th, 2010 at 05:37 AM. Reason: realised what the error was

  3. #1283
    Join Date
    May 2010
    Beans
    6

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Arg. Now I see what happened. Apparently the file was misnamed somehow -- once just now, and again earlier today.

    In /usr/local/bin
    Code:
    -rwxr-xr-x 1 root      root        10472 2010-09-18 00:27 qt-fasts
    -rwxr-xr-x 1 root      root        20310 2010-09-17 15:51 qt-faststa

    Dumb mistake, I cut off the end of the line when pasting.
    Last edited by spacechampion; September 18th, 2010 at 05:47 AM.

  4. #1284
    Join Date
    Dec 2006
    Beans
    7,111

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi FakeOutdoorsman,

    Congratulations on your work again appearing in the FFmpeg source:

    Code:
    andrew@skamandros~$ svn log -r 25142 svn://svn.mplayerhq.hu/ffmpeg/trunk
    ------------------------------------------------------------------------
    r25142 | darkshikari | 2010-09-18 06:14:24 +1000 (Sat, 18 Sep 2010) | 7 lines
    
    Remove legacy x264 presets
    
    Since we now have the official x264 presets in ffmpeg, there's no reason to
    keep around the old ones.
    
    Patch by Lou Logan <lou AT fakeoutdoorsman DOT com>.
    
    ------------------------------------------------------------------------
    All the best,

    Andrew
    You think that's air you're breathing now?

  5. #1285
    Join Date
    Sep 2006
    Beans
    3,532

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks, but my patches are incredibly simple. This one deleted some files. You can always find something interesting when trawling the logs.

  6. #1286
    Join Date
    Oct 2009
    Location
    /Germany/home
    Beans
    28
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install and use the latest FFmpeg and x264

    FFmpeg version SVN-r25146 needs > lame-3.98.2

    deinstall - libmp3lame0-dev_3.98.2+debian-0ubuntu3_i386.deb

    Download Lame (lame-3.98.4.tar.gz)

    Unpack lame-3.98.4.tar.gz
    edit /lame-3.98.4/debian/changlog

    first line
    lame (3.98.4+debian-0ubuntu3) unstable; urgency=low
    save changelog

    Open Terminal
    cd /lame-3.98.4
    dpkg-buildpackage -b


    After compiling the three packages are to be installed.

    libmp3lame0_3.98.4+debian-0ubuntu3_i386.deb
    lame_3.98.4+debian-0ubuntu3_i386.deb
    libmp3lame0-dev_3.98.4+debian-0ubuntu3_i386.deb


    Install with sudo dpkg -i *.deb
    Greetings
    Henrikx

    Ego sum, qui sum

  7. #1287
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi Hendrikx
    I followed your instructions.

    When I tried to compile there was an error:-
    Code:
    ron@ubuntu:~$ cd /home/ron/Downloads/lame-3.98.4
    ron@ubuntu:~/Downloads/lame-3.98.4$ dpkg-buildpackage -b 
    dpkg-buildpackage: set CFLAGS to default value: -g -O2
    dpkg-buildpackage: set CPPFLAGS to default value: 
    dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
    dpkg-buildpackage: set FFLAGS to default value: -g -O2
    dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
    dpkg-buildpackage: source package lame
    dpkg-buildpackage: source version 3.98.4+debian-0ubuntu3
    dpkg-buildpackage: source changed by Rogério Brito <rbrito@users.sf.net>
    dpkg-buildpackage: host architecture i386
    dpkg-checkbuilddeps: Unmet build dependencies: libsndfile1-dev
    dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
    So I went into Synaptic and installed libsndfile1-dev.

    After that, everything went OK.

    Thanks

  8. #1288
    Join Date
    Mar 2010
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Is this guide applicable to maverick?

  9. #1289
    Join Date
    Sep 2006
    Beans
    3,532

    Install FFmpeg and x264 on Ubuntu Lucid Lynx 10.04

    This guide has moved to the official FFmpeg wiki:

    How to Compile FFmpeg and x264 on Ubuntu Lucid Lynx 10.04
    Last edited by FakeOutdoorsman; May 16th, 2012 at 12:36 AM.

  10. #1290
    Join Date
    Sep 2006
    Beans
    3,532

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by karmila View Post
    Is this guide applicable to maverick?
    Yes. Fortunately Maverick is easier and has fewer steps than Lucid because it has newer packages in the repository. The first page of this thread has been changed to Maverick and Lucid has been "archived".

    I suppose I'll continue to create a page for each Ubuntu release, but I can't guarantee support for all of them...but the rolling release model is still tempting (just like the distros).

Page 129 of 236 FirstFirst ... 2979119127128129130131139179229 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •