Page 111 of 232 FirstFirst ... 1161101109110111112113121161211 ... LastLast
Results 1,101 to 1,110 of 2311

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #1101
    Join Date
    Sep 2006
    Beans
    3,500

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by braddjwinter View Post
    is there a reason why the "Install libvpx (optional)" instructions aren't in the Karmic Koala guide?
    Not a good reason. I meant to add it to Karmic after adding it to Lucid, but it's almost been a month already. I'll test it on Karmic now and add it shortly.

    Update: libvpx added to Karmic. Installed successfully on a 32-bit VM.
    Last edited by FakeOutdoorsman; July 2nd, 2010 at 11:26 PM.

  2. #1102
    Join Date
    Apr 2007
    Location
    Alt Maresme
    Beans
    2,997

    Re: HOWTO: Install and use the latest FFmpeg and x264

    What an awesome tutorial, thanks a lot!
    Tingueu presents les normes d'or dels fòrums d'Ubuntu: poseu un títol entenedor i apropiat als vostres fils; digueu quina versió i variant d'Ubuntu feu servir i a quina màquina; i què heu provat abans de demanar ajut.

  3. #1103
    Join Date
    Feb 2008
    Location
    The Hague,Netherlands
    Beans
    252
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Code:
    sudo aptitude ffmpeg ffmpeg-dbg
    Always doing it.
    Registered Linux user,number 507113.02-01-2013: ASUS M4A785TD-V EVO 785G |Athlon 2 X4 640|4 GiB DDR|1 TiB SATA2|Radeon HD 6570(HDMI)|Realtek 7.1 HDMI audio|Gigabit Lan|Kubuntu 12.10 Quanzal AMD64

  4. #1104
    Join Date
    Apr 2005
    Location
    New York, NY
    Beans
    152
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I'm getting the following error when compiling ffmpeg:

    Code:
    /home/ravenel/source/ffmpeg/libavformat/libavformat.a(id3v2.o): In function `read_ttag':
    /home/ravenel/source/ffmpeg/libavformat/id3v2.c:142: undefined reference to `ff_id3v1_genre_str'
    collect2: ld returned 1 exit status
    make: *** [ffmpeg_g] Error 1
    Any ideas?

    FYI, here are the configuration options I passed:

    Code:
    ./configure --enable-pthreads --enable-gpl --enable-postproc --enable-memalign-hack --enable-runtime-cpudetect --disable-devices --disable-filters --disable-encoders --disable-muxers --disable-network --disable-outdevs --disable-decoder=aac,ac3,adpcm_*,alac,als,ape,atrac?,cook,dca,dsicinaudio,dxa,eac3,flac,interplay_dpcm,mlp,mp1,mp2,mp3,mp3*,mpc?,pcm_*,qcelp,ra_*,sipr,truehd,truespeech,tta,vorbis,wavpack,wma*,twinvq --disable-demuxer=aac,ac3,pcm_*,ape,amr,***,au,avs,dts,eac3,flac,mp3,mpc,mpc8,truehd,tta,w64,wav,wv --disable-parser=aac,ac3,dca,mlp,mpegaudio

  5. #1105
    Join Date
    Apr 2005
    Location
    New York, NY
    Beans
    152
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Apparently this is due to a bug in ffmpeg. I retried using source from 6/1 (just a date I picked), and it worked fine.

  6. #1106
    Join Date
    Sep 2006
    Beans
    3,500

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by sailor420 View Post
    FYI, here are the configuration options I passed:

    Code:
    ./configure --enable-pthreads --enable-gpl --enable-postproc --enable-memalign-hack --enable-runtime-cpudetect --disable-devices --disable-filters --disable-encoders --disable-muxers --disable-network --disable-outdevs --disable-decoder=aac,ac3,adpcm_*,alac,als,ape,atrac?,cook,dca,dsicinaudio,dxa,eac3,flac,interplay_dpcm,mlp,mp1,mp2,mp3,mp3*,mpc?,pcm_*,qcelp,ra_*,sipr,truehd,truespeech,tta,vorbis,wavpack,wma*,twinvq --disable-demuxer=aac,ac3,pcm_*,ape,amr,***,au,avs,dts,eac3,flac,mp3,mpc,mpc8,truehd,tta,w64,wav,wv --disable-parser=aac,ac3,dca,mlp,mpegaudio
    I'm curious as to why you are disabling so many options. Have you tried the --disable-everything option? You can use that and then follow it with whatever --enable-foo that you want. Might make your ./configure a little smaller and easier to read.

    Quote Originally Posted by sailor420 View Post
    Apparently this is due to a bug in ffmpeg. I retried using source from 6/1 (just a date I picked), and it worked fine.
    r24030 using both the ./configure from the guide and your ./configure compiled fine for me on x86_64 Lucid.

    This happens once in a while when compiling FFmpeg SVN. Occasionally a revision will break something, but it is rare when a fix doesn't come quickly. Last time I let the developers in the #ffmpeg-devel IRC channel know that the most recent revision failed to make it was fixed very quickly.

    Update: You probably don't need --enable-memalign-hack unless you're cross-compiling for Windows.
    Last edited by FakeOutdoorsman; July 3rd, 2010 at 09:55 PM.

  7. #1107
    Join Date
    Apr 2005
    Location
    New York, NY
    Beans
    152
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks! I was following a guide from MakeMKV which suggested those options: http://www.makemkv.com/forum2/viewto...t=1313&start=0

    I talked with the author of that guide, and he found a way to get it running--notably by doing just as you suggested and running --disable-all and then just enabling the things we needed.

    Thanks for the informative response, much appreciated. Great guide!

  8. #1108
    Join Date
    Apr 2005
    Location
    New York, NY
    Beans
    152
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    Updating FFmpeg and x264
    Development of FFmpeg and x264 is active and an occasional update can give you new features and bug fixes. To update FFmpeg and x264 you will need to remove the packages, make distclean, update the source, recompile, and install. To update x264:
    Code:
    sudo apt-get remove ffmpeg x264 libx264-dev
    cd ~/x264
    make distclean
    git pull
    Now compile x264 as shown earlier in the guide starting with the x264 ./configure line. Now FFmpeg:
    Code:
    cd ~/ffmpeg
    make distclean
    svn update
    Now continue with the installation starting with the FFmpeg ./configure line.


    Reverting Changes Made by This Guide
    To remove FFmpeg/x264 and other packages added for this guide:
    Code:
    sudo apt-get remove x264 ffmpeg qt-faststart build-essential subversion git-core checkinstall yasm texi2html libfaac-dev libmp3lame-dev libsdl1.2-dev libtheora-dev libvorbis-dev libx11-dev libxfixes-dev libxvidcore-dev zlib1g-dev
    Lastly, delete the ffmpeg and x264 directories in your home folder.
    Many thanks for including this bit. So many guide neglect upgrade and removal instructions, so it's great to see it included. Great guide!

  9. #1109
    Join Date
    Jul 2010
    Beans
    4

    Re: HOWTO: Install and use the latest FFmpeg and x264

    It's better to add zero step:
    Code:
    LC_LANG="en_US.utf8"
    because output of svn info is locale sensitive.

  10. #1110
    Join Date
    Aug 2007
    Location
    Nine Towers
    Beans
    336
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Just did a test run converting a .ogv (recordMyDesktop file) to a mp4 using ffmpeg (built using this threads tutorial).
    Code:
    $ ffmpeg -i all-in-one-seo-img-2.ogv -acodec libfaac -ab 128k -ac 2 -vcodec libx264 -vpre slow -crf 22 -threads 0 output.mp4
    I must say it went very well and quality seems to be good. Any tips or remarks on the way I converted this file?
    Last edited by Stoneface; July 5th, 2010 at 02:03 PM.
    process `skype' is using obsolete setsockopt SO_BSDCOMPAT

Page 111 of 232 FirstFirst ... 1161101109110111112113121161211 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •