Page 218 of 236 FirstFirst ... 118168208216217218219220228 ... LastLast
Results 2,171 to 2,180 of 2357

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #2171
    Join Date
    May 2011
    Beans
    15

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by Jose Catre-Vandis View Post
    Install the Flash Aid extension in Firefox, then run it to update/change your flash plugin. This fixed it for me.
    Thanks! This fixed my issue.
    edit: I also noticed there was a update to flash plugin so it might have fixed the issue but I installed both nonetheless. Also I am using Nouveau, instead of NVIDIA driver.
    Last edited by Redwol; May 5th, 2012 at 03:33 PM.

  2. #2172
    Join Date
    Sep 2006
    Beans
    3,527

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by Jose Catre-Vandis View Post
    Just carried out installation on headless server. Required reboot to enable functionality (e.g. didn't recognise "c:v libx264" option). After reboot all worked as expected
    Good timing. I recently modified the guide a few days ago to support headless servers by excluding some needless dependencies. I also wikified the Lucid and Hardy versions but haven't linked to them yet.

    A reboot? Inconceivable! I don't understand why it wouldn't recognize "c:v libx264" without a reboot. Do you remember the particular message you got when you did try?

    Quote Originally Posted by Redwol View Post
    Thanks! This fixed my issue.
    Good, because I had no idea.

  3. #2173
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: HOWTO: Install and use the latest FFmpeg and x264

    A reboot? Inconceivable! I don't understand why it wouldn't recognize "c:v libx264" without a reboot. Do you remember the particular message you got when you did try?
    Just that IIRC. Same report you get when you put an incorrect parameter in the chain ....

    Didn't have to reboot when I installed to desktop 12.04 though....

    (Must confess I didn't spot your headless server section (to quote a song from Beauty and the Beast: "there was something there that wasn't there before ) until I had run the desktop install, so maybe this didn't help?
    No longer participating......

  4. #2174
    Join Date
    Aug 2009
    Beans
    1

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hello all, I'm trying to build FFmpeg with h254 support on my headless Ubuntu 12.04 server, as per https://ffmpeg.org/trac/ffmpeg/wiki/...mpilationGuide

    h264 builds fine, but when i try to build FFmpeg it fails every time at the "CC libavcodec/h254" step.

    Code:
    $ make
    CC      libavdevice/alldevices.o
    CC      libavdevice/alsa-audio-common.o
    CC      libavdevice/alsa-audio-dec.o
    CC      libavdevice/alsa-audio-enc.o
    [...SNIP...]
    CC      libavcodec/h263.o
    CC      libavcodec/h263_parser.o
    CC      libavcodec/h263dec.o
    CC      libavcodec/h264.o
    gcc: internal compiler error: Killed (program cc1)
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <file:///usr/share/doc/gcc-4.6/README.Bugs> for instructions.
    make: *** [libavcodec/h264.o] Error 4
    $
    I followed the instructions to the letter, with the exception that I apt-get installed FFmpeg and libx264-dev beforehand and then apt-get removed them when they didn't work.

    Does anyone have any idea why the build might be failing? Apologies if this has been asked before, there's a lot of posts to read through in this thread!

    - Liam

  5. #2175
    Join Date
    Dec 2006
    Beans
    7,079

    Re: HOWTO: Install and use the latest FFmpeg and x264

    This could be a ram access problem rather than an FFmpeg issue. Have you had a look at available ram / swap file?
    You think that's air you're breathing now?

  6. #2176
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi FakeOutdoorsman
    I've used the guide with Pangolin.


    No problems...

    ...but afterwards when I compiled MEncoder, config couldn't find x264.


    So I've had to re-compile x264 with "--enable-shared".

    With Natty, MEncoder found x264 OK with "--enable-static".
    Maybe something has changed since then.
    (Or maybe I was compiling against some other x264 or libx264-dev that it found somewhere).

  7. #2177
    Join Date
    Sep 2006
    Beans
    3,527

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by ron999 View Post
    ...but afterwards when I compiled MEncoder, config couldn't find x264.
    I haven't compiled MEncoder in years. Maybe Andrew will have an idea?

  8. #2178
    Join Date
    Jun 2007
    Beans
    13,442

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by ron999 View Post
    Hi FakeOutdoorsman
    I've used the guide with Pangolin.


    No problems...

    ...but afterwards when I compiled MEncoder, config couldn't find x264.


    So I've had to re-compile x264 with "--enable-shared".

    With Natty, MEncoder found x264 OK with "--enable-static".
    Maybe something has changed since then.
    (Or maybe I was compiling against some other x264 or libx264-dev that it found somewhere).
    This is likely caused by gcc > 4.4 which uses "as-needed". So if you were to check your configure log the x264 section would probably have quite a number of 'undefined references'

    How you could change this in a mplayer build not sure, possibly ask in the compiling subforum

    Otherwise you could just as well build x264 as both static & shared, won't matter much, the libx264 version # is going to be higher than the ubuntu repo's one so they can co-exist
    Otherwise you could install gcc-4.4 & configure mplayer with --cc=gcc-4.4

  9. #2179
    Join Date
    Dec 2006
    Beans
    7,079

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    I haven't compiled MEncoder in years. Maybe Andrew will have an idea?
    I too have not looked at MEncoder for a long while. But config.log should give a meaningful error message?
    You think that's air you're breathing now?

  10. #2180
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi mc4man

    I've done some experiments.
    It seems that now with Pangolin...

    Code:
    IF x264 is not installed
        THEN MEncoder is happy to build with libx264-dev
            ELSE
                IF x264 is installed
                    THEN MEncoder won't build with libx264-dev
    Maybe it's possible to force the compiler to ignore a static x264 and allow MEncoder to build with libx264-dev.
    In the meantime, I've compiled x264 'shared' and removed libx264-dev.

Page 218 of 236 FirstFirst ... 118168208216217218219220228 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •