Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Update Manager dead and strange 20-second delay launching apps

  1. #11
    Join Date
    Jun 2006
    Location
    Switzerland
    Beans
    Hidden!
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: Update Manager dead and strange 20-second delay launching apps

    what did now cause the application startup delay?

    Btw, interesting homepage

  2. #12
    Join Date
    Mar 2008
    Location
    Melbourne, Australia
    Beans
    11
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Update Manager dead and strange 20-second delay launching apps

    >what did now cause the application startup delay?

    Well, when I fixed the /etc/hosts file, the offline delay went away too.

    I imagine that every time I launch terminal, vim, etc, it must look up something on the host 'john' (my machine). With the 127.0.1.1 entry in hosts changed to john.<domain>, it must have thought it needed to do a dns lookup somewhere else, because it could no longer find plain 'john' in /etc/hosts. Online it fails to find 'john' in the network dns server (hence the complaint); offline it times out after 20 seconds, I presume looking for a dns server. (gvim must look up two different things)

    That's my best guess; I don't really know too much about networking. In any case, it's fixed.

    I've figured out that the /etc/hosts change was my stupid fault, when looking in System / Administration / Network / General / Host Settings. Being formerly addicted to Windows, I had a momentary regression to brain meltdown mode and put the Windows "domain" of my home network in there. I didn't realise that putting in a domain would wreck the machine (on Windoze, it never hurts, and sometimes helps).

    The ironic thing is that Ubuntu connects to my home Windows network more reliably than the machine did when it was actually running Windows! (Hence my obsession with always trying to "help" the machine recognise the Windows network ...)


    >Btw, interesting homepage

    Thanks mate.

  3. #13
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,884
    Distro
    Ubuntu Development Release

    Re: Update Manager dead and strange 20-second delay launching apps

    Quote Originally Posted by John Costella View Post
    Yes! That was it exactly. Many thanks.

    (I don't know how to change the header of this thread to "solved"; have tried before but failed ...)

    John
    Another new feature.

    If you edit your first post, go advanced you can pop solved at the beginning of the title. I hope they get this feature back.

  4. #14
    Join Date
    Mar 2008
    Location
    Melbourne, Australia
    Beans
    11
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Update Manager dead and strange 20-second delay launching apps

    OK, I did that, and it changed the title of the first post, but not the title of the thread as shown in the forum itself.

    Maybe I can't do that ...

    Thanks
    John

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •