Page 18 of 19 FirstFirst ... 816171819 LastLast
Results 171 to 180 of 187

Thread: HowTo: Automount NTFS Drives

  1. #171
    Join Date
    Jan 2011
    Location
    London
    Beans
    16
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HowTo: Automount NTFS Drives

    Quote Originally Posted by Joeb454 View Post
    I've found that if the directory already exists, ntfs-config doesn't play nice, for example I manually mounted my windows partition to /media/Vista, THEN installed ntfs-config.

    Turns out I had to remove the /media/Vista directory before it could continue.

    Naturally, the directory name will be different for everybody I would assume
    Ah that might explain why when I run ntfs-config and enter the password, it just closes instantly. I already have a NTFS drive that mounts at /media/Storage (though not automatically!).

    I'm a noob though and don't know how to "remove the directory" without breaking something. Any advice?

    Thanks

  2. #172
    Join Date
    Aug 2007
    Location
    Manchester, UK
    Beans
    10,279
    Distro
    Ubuntu

    Re: HowTo: Automount NTFS Drives

    It depends how you manually mounted it. If you haven't edited /etc/fstab then you should just be able to run
    Code:
    sudo rmdir /media/Storage
    while the drive isn't mounted.

  3. #173
    Join Date
    Jan 2011
    Beans
    6

    Re: HowTo: Automount NTFS Drives

    i'll try it first.. thanks

  4. #174
    Join Date
    Dec 2010
    Beans
    10

    Angry Re: HowTo: Automount NTFS Drives

    Hello Joeb454,

    I have 64bit Ubuntu 10.10
    I followed your advice however the NTFS-Config "enable write support for internal device" is greyed out and not enabled.

    sudo fdisk -l

    returns the following:


    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x000b77a2

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 498 3998720 82 Linux swap / Solaris
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 499 2988 19998721 5 Extended
    /dev/sda3 2988 60802 464387072 b W95 FAT32
    /dev/sda5 499 2988 19998720 83 Linux


    It is /dev/sda3 is the device I wish to automount.

    Your help is appreciated,

    Regards.

  5. #175
    Join Date
    Dec 2009
    Beans
    5,370

    Re: HowTo: Automount NTFS Drives

    I followed your advice however the NTFS-Config "enable write support for internal device" is greyed out and not enabled.
    That's the thing I find most spooky about ntfs-config. It asks you if you want to enable write support for ntfs. Ntfs has had write support by default for about 3 years now so I'm not sure what its doing if you select "yes".

    Anyway in your particular case you have no ntfs partitions so it doesn't matter if it's grayed out.

    The following procedure is just an example:

    Make a permanent home for your partition:
    Code:
    sudo mkdir /media/Data
    Edit fstab as root:
    Code:
    gksu gedit /etc/fstab
    Add the following line at the end of fstab:
    Code:
    /dev/sda3 /media/Data vfat utf8,umask=007,uid=1000,gid=46 0 1
    Save fstab and back in the terminal run the following command to test for errors and mount the new partition:
    Code:
    sudo mount -a
    Last edited by Morbius1; January 29th, 2011 at 02:09 PM.

  6. #176
    Join Date
    Dec 2009
    Beans
    5,370

    Re: HowTo: Automount NTFS Drives

    Joeb454, a thousand apologies. It's early here ( that's my excuse anyway ) and I had no idea I was posting in a HowTo. I consider that quite rude and I wouldn't have done it if I wasn't so feeble minded. Feel free to remove it.

  7. #177
    Join Date
    Aug 2007
    Location
    Manchester, UK
    Beans
    10,279
    Distro
    Ubuntu

    Re: HowTo: Automount NTFS Drives

    No apologies needed - it was a helpful post, and I have nothing against people helping out if they know the answer

  8. #178
    Join Date
    May 2009
    Location
    Alabama
    Beans
    25
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HowTo: Automount NTFS Drives

    thank you very much for this HowTo....exactly what I was looking for.

    Edit: this still does exactly what I wanted but it has one slight bug with network shared folders after mounting.

    The bug is fairly easy to solve though so not to worry.

    I originally manually mounted these drives and then shared some folders through Samba. This worked just fine and even after unmounting and remounting the shared folders continue to work just fine over the network. However, once I installed ntfs-config the folders were no longer seen over the network as permissions/ownership had been altered. So here is what I did to fix that.

    1. Press Alt+F2 (run dialog) or open a terminal
    2. Run the following:
    Code:
    gksu gedit /etc/samba/smb.conf
    3. Enter your root password. gedit will need root access to edit this file.
    4. Add the below line to the [global] section of Global Settings.
    Code:
    usershare owner only = false
    3. Save and exit.



    Hope this helps anyone else who runs into this issue.
    Last edited by RottNKorpse; February 1st, 2011 at 08:15 AM.
    Twitter | Facebook | Myspace
    Visuex.com - my web-development company

  9. #179
    Join Date
    Jan 2011
    Location
    British Columbia
    Beans
    Hidden!
    Distro
    Ubuntu Gnome 13.10 Saucy Salamander

    Re: HowTo: Automount NTFS Drives

    Quote Originally Posted by RottNKorpse View Post
    thank you very much for this HowTo....exactly what I was looking for.

    Edit: this still does exactly what I wanted but it has one slight bug with network shared folders after mounting.

    The bug is fairly easy to solve though so not to worry.

    I originally manually mounted these drives and then shared some folders through Samba. This worked just fine and even after unmounting and remounting the shared folders continue to work just fine over the network. However, once I installed ntfs-config the folders were no longer seen over the network as permissions/ownership had been altered. So here is what I did to fix that.

    1. Press Alt+F2 (run dialog) or open a terminal
    2. Run the following:
    Code:
    gksu gedit /etc/samba/smb.conf
    3. Enter your root password. gedit will need root access to edit this file.
    4. Add the below line to the [global] section of Global Settings.
    Code:
    usershare owner only = false
    3. Save and exit.



    Hope this helps anyone else who runs into this issue.
    Sweet Fix. But how do you enable read/write & remove passwords.
    Ubuntu 12.04 precise pangolin (64bit)
    Gnome-Shell 3.4.2 Linux Kernel 3.12.3
    Core i7 c/w itx Board / Z87 Chipset
    50gb SSD /root OS, 2TB XFS /home & 2TB ext4 (shares)

  10. #180
    Join Date
    May 2009
    Location
    Alabama
    Beans
    25
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HowTo: Automount NTFS Drives

    Quote Originally Posted by XBMC old School View Post
    Sweet Fix. But how do you enable read/write & remove passwords.
    I am not exactly sure what issues you are having as I would need much more detail but what I think your issue is that you need to make your SambaShare saved the login password when you connect to it. Be sure to click "Remember forever":



    As for the write permissions...you will need to add write permissions in NTFS-Config:




    You also need to make sure that Write access is activated for the SambaShare from the original sharing computer:



    Hope this helps...
    Twitter | Facebook | Myspace
    Visuex.com - my web-development company

Page 18 of 19 FirstFirst ... 816171819 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •