I can't switch keyboard layout using shortcut after upgrading to HH. I must uncheck the option for shortcut in settings then check it again. After that it works again, but it must be done after every boot.