Results 1 to 10 of 13

Thread: Installing ATI and get X Server: Unable to Detect

Hybrid View

  1. #1
    Join Date
    Jan 2007
    Beans
    29

    Installing ATI and get X Server: Unable to Detect

    Im trying to install the latest ATI drivers that support my card (8.28.8 ) but when i try to install i get....

    Creating directory fglrx-install
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.28.8............................................ .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .........................
    -e ==================================================
    -e ATI Technologies Linux Driver Installer/Packager
    -e ==================================================
    Detected configuration:
    Architecture: i686 (32-bit)
    X Server: unable to detect
    Removing temporary directory: fglrx-install

    thanks in advance

  2. #2
    Join Date
    Jan 2007
    Beans
    29

    Re: Installing ATI and get X Server: Unable to Detect

    please if you have any idea what may be wrong please help, i would really like to get my video card correctly installed

  3. #3
    Join Date
    Dec 2007
    Location
    mauritius
    Beans
    4
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Installing ATI and get X Server: Unable to Detect

    Hi there! i got the same probleme!!

    Am also on an ATI Radeon 9200 (64mb) on my laptop HP nx7010!
    Os:Ubuntu 8.04
    __________________________________________________ ____
    deadpunk@localhost:~$ sudo bash /ati/ati-driver-installer-8.28.8.run
    Creating directory fglrx-install
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.28.8............................................ .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .........................
    -e ==================================================
    -e ATI Technologies Linux Driver Installer/Packager
    -e ==================================================
    Detected configuration:
    Architecture: i686 (32-bit)
    X Server: unable to detect
    Removing temporary directory: fglrx-install
    deadpunk@localhost:~$
    __________________________________________________ __________
    deadpunk@localhost:~$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: Tungsten Graphics, Inc.
    OpenGL renderer string: Mesa DRI R200 20060602 AGP 4x x86/MMX/SSE2 TCL
    OpenGL version string: 1.3 Mesa 7.0.3-rc2

    deadpunk@localhost:~$ lspci | grep VGA
    01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 01)
    deadpunk@localhost:~$ lspci -n | grep 0300
    01:00.0 0300: 1002:4c66 (rev 01)
    __________________________________________________ __________________

    The problems is when i enable compiz ! everything is stuck and i think that there are no 3D acceleration!
    Or its just because my 64mb is not capable of the compiz 3D effect?
    I install the driver " ATI fglrx " from the repos ,but the 3D didnt work !
    Then i try to install the ATi proprietary " ati-driver-installer-8.28.8.run " from ATI!

    Thanx !!

  4. #4
    Join Date
    Sep 2008
    Location
    Johannesburg, South Afric
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installing ATI and get X Server: Unable to Detect

    Same problem...

    sh ./ati-driver-installer-8.28.8.run
    Creating directory fglrx-install
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.28.8
    -e ==================================================
    -e ATI Technologies Linux Driver Installer/Packager
    -e ==================================================
    Detected configuration:
    Architecture: i686 (32-bit)
    X Server: unable to detect
    Removing temporary directory: fglrx-install

    01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
    01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)
    03:0c.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)

  5. #5
    Join Date
    Jun 2006
    Location
    Israel
    Beans
    292

    Re: Installing ATI and get X Server: Unable to Detect

    I have a Radeon 9200, for me it's not even detected.
    Code:
    No protocol specified
    Error: unable to open display (null)
    That is the output of fglrxinfo.

  6. #6
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Installing ATI and get X Server: Unable to Detect

    You should not be using such and old driver with 8.04. The x server has been updated and I doubt if they will work. You should be using the open source radeon driver which fully supports those old cards.

    Getting compiz to work with a 64mb video card is most likely impossible.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •