Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Pimp my xorg.conf ---> ati x1650 and 3d games

  1. #1
    Join Date
    Jan 2007
    Location
    Location: Location:
    Beans
    1,241
    Distro
    Ubuntu 12.04 Precise Pangolin

    Pimp my xorg.conf ---> ati x1650 and 3d games

    hi there, when i run the game nexuiz, it looks like this

    http://i295.photobucket.com/albums/m...xuiz000000.jpg

    the output

    Code:
    Nexuiz Linux 15:50:35 Apr  8 2008
    Trying to load library... "libz.so.1" - loaded.
    Added packfile /usr/share/games/nexuiz/data/data20080229.pk3 (3982 files)
    Trying to load library... "libcurl.so.4" - loaded.
    Failed to init SDL joystick subsystem: 
    Trying to load library... "libvorbis.so.0" - loaded.
    Trying to load library... "libvorbisfile.so.3" - loaded.
    Trying to load library... "libmodplug.so.0" - loaded.
    Trying to load library... "libOffscreenGecko.so" "/usr/lib/games/nexuiz/libOffscreenGecko.so" - failed.
    execing quake.rc
    execing default.cfg
    execing physicsQBR.cfg
    execing newhook.cfg
    execing weapons.cfg
    execing normal.cfg
    execing config.cfg
    couldn't exec data/campaign.cfg
    couldn't exec autoexec.cfg
    Initializing Video Mode: fullscreen 1024x768x32x60hz
    Linked against SDL version 1.2.11
    Using SDL library version 1.2.11
    0 SDL joystick(s) found:
    Trying to load library... "libjpeg.so.62" - loaded.
    Trying to load library... "libpng12.so.0" - loaded.
    Draw_CachePic: failed to load gfx/complete
    Draw_CachePic: failed to load gfx/inter
    Shader 'textures/Reaptxt/sun' already defined
    and then goes on to try to autodetect sound etc.

    The game runs but hideously!

    here is my xorg.conf beginning with the device section

    Code:
    Section "Device"
    	Identifier	"ATI Technologies Inc ATI Default Card"
    	Driver		"fglrx"
    	Busid		"PCI:2:0:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"Novatek 563"
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc ATI Default Card"
    	Monitor		"Novatek 563"
    	Defaultdepth	24
    	SubSection "Display"
    		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"	"640x350"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen "Default Screen"
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    Section "Module"
    	Load		"glx"
            Load		"dri"
    EndSection
    Section "Extensions"
    	Option		"Composite"	"1"
    EndSection
    Section "DRI"
        Group       0
        Mode        0666
    EndSection
    any ideas? thx in advance.
    clear && echo paste url and press enter; read paste; (youtube-dl $paste) | zenity --progress --title="" --text "Downloading, please wait" --auto-close --pulsate && ans=$(zenity --file-selection); gnome-terminal -x mplayer "$ans"

  2. #2
    Join Date
    Jan 2007
    Location
    Location: Location:
    Beans
    1,241
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    anyone?


    now my xorg.conf looks like this
    Code:
    Section "Device"
    	Identifier	"ATI Technologies Inc ATI Default Card"
    	Driver		"fglrx"
    	Busid		"PCI:2:0:0"
    	Option		"XaaNoOffscreenPixmaps"	"true"
    	Option		"AddARGBGLXVisuals"	"true"
    	Option		"AllowGLXWithComposite"	"true"
    	Option		"EnablePageFlip"	"true"
    	Option		"AccelMethod"	"EXA"
    	Option		"MigrationHeuristic"	"greedy"
    	Option		"DRI"	"true"
    	Option		"TexturedVideo"	"on"
    	Option		"UseFastTLS"	"0"
    	Option		"BlockSignalsOnLock"	"on"
    	Option		"KernelModuleParm"	"locked-userpages=0"
    	Option		"ForceGenericCPU"	"off"
    	Option		"VideoOverlay"	"on"
    	Option		"OpenGLOverlay"	"off"
    EndSection
    
    Section "Monitor"
    	Identifier	"Novatek 563"
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc ATI Default Card"
    	Monitor		"Novatek 563"
    	Defaultdepth	24
    	SubSection "Display"
    		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"	"640x350"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen "Default Screen"
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"dri"
    EndSection
    Section "Extensions"
    	Option		"Composite"	"Enable"
    EndSection
    
    Section "ServerFlags"
    	Option		"AIGLX"	"false" #<---- i dont want to resort to it 
    EndSection
    
    Section "DRI"
    	Group	0
    	Mode	0666
    EndSection
    textures are showing up correctly in nexuiz but the gameplay is so ridiculously slow that its not worth playing at all.

    oh and now glxgears crashes x completely! lol

    funny thing is compiz has never run better.

    I installed the latest ati drivers but fglrx-info says this

    Code:
    display: :1.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (2.1 Mesa 7.0.1)
    wth mesa? I thought i was using the new ati stuff?

    I am thouroughly demused. Pls help!
    Last edited by |{urse; May 5th, 2008 at 02:30 AM.
    clear && echo paste url and press enter; read paste; (youtube-dl $paste) | zenity --progress --title="" --text "Downloading, please wait" --auto-close --pulsate && ans=$(zenity --file-selection); gnome-terminal -x mplayer "$ans"

  3. #3
    Join Date
    Aug 2006
    Beans
    731
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    Quote Originally Posted by |{urse View Post
    anyone?


    now my xorg.conf looks like this
    Code:
    Section "Device"
    	Identifier	"ATI Technologies Inc ATI Default Card"
    	Driver		"fglrx"
    	Busid		"PCI:2:0:0"
    	Option		"XaaNoOffscreenPixmaps"	"true"
    	Option		"AddARGBGLXVisuals"	"true"
    	Option		"AllowGLXWithComposite"	"true"
    	Option		"EnablePageFlip"	"true"
    	Option		"AccelMethod"	"EXA"
    	Option		"MigrationHeuristic"	"greedy"
    	Option		"DRI"	"true"
    	Option		"TexturedVideo"	"on"
    	Option		"UseFastTLS"	"0"
    	Option		"BlockSignalsOnLock"	"on"
    	Option		"KernelModuleParm"	"locked-userpages=0"
    	Option		"ForceGenericCPU"	"off"
    	Option		"VideoOverlay"	"on"
    	Option		"OpenGLOverlay"	"off"
    EndSection
    
    Section "Monitor"
    	Identifier	"Novatek 563"
    	Option		"DPMS"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc ATI Default Card"
    	Monitor		"Novatek 563"
    	Defaultdepth	24
    	SubSection "Display"
    		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"	"640x350"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen "Default Screen"
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"dri"
    EndSection
    Section "Extensions"
    	Option		"Composite"	"Enable"
    EndSection
    
    Section "ServerFlags"
    	Option		"AIGLX"	"false" #<---- i dont want to resort to it 
    EndSection
    
    Section "DRI"
    	Group	0
    	Mode	0666
    EndSection
    textures are showing up correctly in nexuiz but the gameplay is so ridiculously slow that its not worth playing at all.

    oh and now glxgears crashes x completely! lol

    funny thing is compiz has never run better.

    I installed the latest ati drivers but fglrx-info says this

    Code:
    display: :1.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (2.1 Mesa 7.0.1)
    wth mesa? I thought i was using the new ati stuff?

    I am thouroughly demused. Pls help!
    Just wondering. What method of installing the ATI drivers did you use? Did you get them from the repos or did you download it from the ATI website?
    Join me in my "No Thread Left Behind Act", the quest to leave no thread unanswered
    http://www.facebook.com/patrick.gunsolley
    Kubuntu 10.04 - Primary OS, Fedora 13 Rawhide Tester

  4. #4
    Join Date
    Aug 2006
    Beans
    731
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    This is a shot in the dark. Try moving your "module" section up so that its the first section in the xorg.conf file. Honestly I don't know how xorg.conf is read, but if it's read like any normal shell script, then it may be important to have it laid out in a certain format or order. After moving the module section, do a ctrl-alt backspace to start x.
    Last edited by WalmartSniperLX; May 5th, 2008 at 03:25 AM.
    Join me in my "No Thread Left Behind Act", the quest to leave no thread unanswered
    http://www.facebook.com/patrick.gunsolley
    Kubuntu 10.04 - Primary OS, Fedora 13 Rawhide Tester

  5. #5
    Join Date
    Jan 2007
    Location
    Location: Location:
    Beans
    1,241
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    just tried the method described above and x failed to start. *shrugs* thx for the idea though. have everything back to the way it was before again.

    GOD this is frustrating lol. sauerbraten, nexuiz, tremulous etc are horridly slow.

    oh and i downloaded the latest catalyst from ati's site, then i blocked the preinstalled fglrx from starting up with

    sudo gedit /etc/default/linux-restricted-modules-common

    and manually edited xorg.conf.

    I know this is in the topic but just a reminder, this is an x1950 256mb (liquid-cooled ffs) theres nothing wrong with the card, verified this @ work on a fc8 machine.
    Last edited by |{urse; May 5th, 2008 at 03:40 AM.
    clear && echo paste url and press enter; read paste; (youtube-dl $paste) | zenity --progress --title="" --text "Downloading, please wait" --auto-close --pulsate && ans=$(zenity --file-selection); gnome-terminal -x mplayer "$ans"

  6. #6
    Join Date
    Aug 2006
    Beans
    731
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    Quote Originally Posted by |{urse View Post
    just tried the method described above and x failed to start. *shrugs* thx for the idea though. have everything back to the way it was before again.

    GOD this is frustrating lol. sauerbraten, nexuiz, tremulous etc are horridly slow.

    oh and i downloaded the latest catalyst from ati's site, then i blocked the preinstalled fglrx from starting up with

    sudo gedit /etc/default/linux-restricted-modules-common

    and manually edited xorg.conf.

    I know this is in the topic but just a reminder, this is an x1950 256mb (liquid-cooled ffs) theres nothing wrong with the card, verified this @ work on a fc8 machine.
    That's strange. I just recently downloaded drivers from ati and installed them and my hd2600pro works fine. You did build the .deb packages instead of the automatic installer right?

    I also just migrated back from F8 and I had more stable graphics performance in general in F8.
    Join me in my "No Thread Left Behind Act", the quest to leave no thread unanswered
    http://www.facebook.com/patrick.gunsolley
    Kubuntu 10.04 - Primary OS, Fedora 13 Rawhide Tester

  7. #7
    Join Date
    Jan 2007
    Location
    Location: Location:
    Beans
    1,241
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    yeah i sure did, followed the wiki as well. And direct rendering..

    kurse@kurse-desktop:~$ DISPLAY=:0 glxinfo | grep render
    direct rendering: Yes
    OpenGL renderer string: Radeon X1650 Series
    clear && echo paste url and press enter; read paste; (youtube-dl $paste) | zenity --progress --title="" --text "Downloading, please wait" --auto-close --pulsate && ans=$(zenity --file-selection); gnome-terminal -x mplayer "$ans"

  8. #8
    Join Date
    May 2008
    Beans
    5

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    If you have xorg 7.3 you may not need an xorg.conf try moving it to a new directory and restarting X. I have the same card and just installed the drivers and started X

    Running hardy

  9. #9
    Join Date
    Apr 2008
    Beans
    120
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    Install: http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    This guide tell you about the Mesa. If you have that showing up the drivers are loaded wrong if you are trying to use ATI proprietary drivers.

    fglrxinfo
    Run this command and you should not see mesa...

  10. #10
    Join Date
    Jan 2007
    Location
    Location: Location:
    Beans
    1,241
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Pimp my xorg.conf ---> ati x1650 and 3d games

    yeah thats the exact guide i followed, 3 times to the letter. I have even done a wipe and reload. fglrxinfo is still telling me it's mesa.
    clear && echo paste url and press enter; read paste; (youtube-dl $paste) | zenity --progress --title="" --text "Downloading, please wait" --auto-close --pulsate && ans=$(zenity --file-selection); gnome-terminal -x mplayer "$ans"

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •