Results 1 to 8 of 8

Thread: ATI X1400 flickers my screen in sauerbraten

  1. #1
    Join Date
    Jan 2008
    Beans
    73

    Question ATI X1400 flickers my screen in sauerbraten

    Hi there, I'm have a Dell Inspiron 6400 with a fresh install of Hardy and an ATI X1400, everything runs ok with compiz and the desktops effects, but when I run Sauerbraten the screen start to flicker, I can play the game for a while and then everything freeze. What can I do to solve this problem?

    Thanks in advance for your help.

  2. #2
    Join Date
    Oct 2007
    Beans
    26

    Re: ATI X1400 flickers my screen in sauerbraten

    I had this problem using the open source driver on my old x850xt. You might want to switch to the proprietary ati driver. Also, try to disable compiz before playing, as it doesn't seem to play well with other 3d programs.

  3. #3
    Join Date
    Jan 2008
    Beans
    73

    Re: ATI X1400 flickers my screen in sauerbraten

    I'm using the restricted driver for ATI, so I think is the correct one for my hardware, I will try disabling compiz before playing, do I just kill the compiz process?


    ****UPDATE****

    Ok I kill all the compiz processes in System monitor and the game works perfect!!!!, so the question is, there's anyway I can disable/enable compiz easily? or can I change something in compiz manager in order to play without problems?
    Last edited by alejobar; May 2nd, 2008 at 08:55 PM. Reason: update

  4. #4
    Join Date
    Nov 2007
    Beans
    111

    Re: ATI X1400 flickers my screen in sauerbraten

    Yes there is a way to quickly enable/disable Compiz. Some ppl would give you a command line but not me. Here goes, since you are on Hardy Heron, you can search for an application called "icon fusion", this lets you to quickly enable/disable Compiz and/or Emerald.

    Cygoku

  5. #5
    Join Date
    Apr 2007
    Beans
    Hidden!

    Re: ATI X1400 flickers my screen in sauerbraten

    There's also a menu item for appearance that let's you select desktop effects. It's a few mouse clicks to get to it, but it can do it.

  6. #6
    Join Date
    May 2007
    Beans
    100
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: ATI X1400 flickers my screen in sauerbraten

    I am using The Heron version and if you want that Icon to enable or disable Compiz Fusion, it is in the synaptics download manager as a download listed as fusion-icon which is

    "tray icon to launch and manage Compiz Fusion" I tried to do a search on my system first, and it was not there.

  7. #7
    Join Date
    Jan 2008
    Beans
    73

    Re: ATI X1400 flickers my screen in sauerbraten

    Quote Originally Posted by Paul S View Post
    There's also a menu item for appearance that let's you select desktop effects. It's a few mouse clicks to get to it, but it can do it.
    Yes does what I'm doing, I go to preferences, appereance and change to no desktop effects and then I can play

    But when I activate the effects again I have to go to compiz manager to enable my custom effects and its kind of annoying

    If someone know how to do it easily please help us!

  8. #8
    Join Date
    Jan 2007
    Location
    Location: Location:
    Beans
    1,246
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ATI X1400 flickers my screen in sauerbraten

    also i bet your video flickers when watching movies etc.

    you can fix this with

    gstreamer-properties
    click the video tab and select "X window system (no XV)" from the plugin: dropdown menu

    NOTE: This isn't going to fix your sauerbraten from flickering, just uses the correct video overlay for gstreamer.
    Last edited by |{urse; May 12th, 2008 at 02:54 AM.
    clear && echo paste url and press enter; read paste; (youtube-dl $paste) | zenity --progress --title="" --text "Downloading, please wait" --auto-close --pulsate && ans=$(zenity --file-selection); gnome-terminal -x mplayer "$ans"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •