Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Rezound Playback

  1. #1
    Join Date
    Dec 2006
    Location
    London, England
    Beans
    104
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Rezound Playback

    Hi,

    After despairing at the lack of compatibility between Audacity and Heron, I've decided to give Rezound a try.

    It records OK, but the playback is "juddery". The latency in JACK is set to "default". Could the problem be something other than latency?

    I see that Rezound has a mailing list, but is there a forum too?

    TIA,
    Tim

  2. #2
    Join Date
    Jun 2006
    Location
    Colorado
    Beans
    435

    Re: Rezound Playback

    Do you have the real time kernel enabled? Are you getting any xruns? Also, what is your sample rate set at in Jack?


  3. #3
    Join Date
    Dec 2006
    Location
    London, England
    Beans
    104
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Rezound Playback

    Quote Originally Posted by warbread View Post
    Do you have the real time kernel enabled? Are you getting any xruns? Also, what is your sample rate set at in Jack?
    Sample rate= 44100

    Not sure about the real time kernal or xruns.

    TIA (and for your prompt response - I'm back in 2 hrs or so)

    Tim

  4. #4
    Join Date
    Jun 2006
    Location
    Colorado
    Beans
    435

    Re: Rezound Playback

    Post the output of the following command:

    Code:
    :-$ uname -r
    This will tell us what kernel you're using. Also, check the 'Messages' box on Jackqtl while recording to see if you're getting xruns. These are buffer over OR under runs, meaning that the buffer is either too full or too empty for the program to do anything with. This will produce a pop, click or chirp sound in your recording. If this is a buffer problem, it'll be a simple matter of enabling real time access and rebooting, then clicking another box in the Jack settings window.


  5. #5
    Join Date
    Dec 2006
    Location
    London, England
    Beans
    104
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Rezound Playback

    Hi,

    the kernel is 2.6.24-16-generic

    I am getting xruns. Here's a small sample - but I think the highest was around 0.100 msec.

    **** alsa_pcm: xrun of at least 0.020 msecs
    **** alsa_pcm: xrun of at least 0.023 msecs
    **** alsa_pcm: xrun of at least 0.023 msecs
    **** alsa_pcm: xrun of at least 0.033 msecs
    **** alsa_pcm: xrun of at least 0.022 msecs
    **** alsa_pcm: xrun of at least 0.025 msecs
    **** alsa_pcm: xrun of at least 0.021 msecs
    12:58:54.315 XRUN callback (23 skipped).

    Cheers,
    Tim

  6. #6
    Join Date
    Jun 2006
    Location
    Colorado
    Beans
    435

    Re: Rezound Playback

    Ah, yeah. You'll want to download and run the real time kernel (synaptic search), and then put the following into terminal:

    (From https://help.ubuntu.com/community/Ub...dioPreparation)
    Code:
    :-$ sudo su -c 'echo @audio - rtprio 99 >> /etc/security/limits.conf'
    :-$ sudo su -c 'echo @audio - memlock 250000 >> /etc/security/limits.conf'
    :-$ sudo su -c 'echo @audio - nice -10 >> /etc/security/limits.conf'
    Then reboot the computer. You'll also need to install the real time kernel restricted modules package (again, synaptic search) if you use the nVidia or ATI graphics card drivers. Once you have that done, start up qjackctl again, but before hitting that green arrow, go into settings and enable real time mode. If your DSP can handle it, crank the sampe rate, too. That will lower latency.

    I believe that should solve your problems.


  7. #7
    Join Date
    Dec 2006
    Location
    London, England
    Beans
    104
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Rezound Playback

    Hi,

    I followed your instructions. This time Rezound froze during recording.

    I've posted the results to the Pastebin:

    http://paste.ubuntu.com/9184/

    Thanks,
    Tim

  8. #8
    Join Date
    Jun 2006
    Location
    Colorado
    Beans
    435

    Re: Rezound Playback

    That's quite a bit of xruns for a low latency set up. What sound card are you using?


  9. #9
    Join Date
    Dec 2006
    Location
    London, England
    Beans
    104
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Rezound Playback

    Quote Originally Posted by warbread View Post
    That's quite a bit of xruns for a low latency set up. What sound card are you using?
    Just onboard sound (Intel HDA?) which I would imagine is not great for low latency work. I got away with using Audacity until Hardy was released - but there are compatibility issues.

    Tim

  10. #10
    Join Date
    Jun 2006
    Location
    Colorado
    Beans
    435

    Re: Rezound Playback

    That's true, it's not very good for it at all. You could try upping the sample rate, which should lower latency, but I don't know anything about rezound's stability. Your problems in Hardy could be related to Pulseaudio, Jack or Rezound itself. What I did was buy a $20 Turtlebeach USB soundcard which works very well in Ubuntu. I can understand why you wouldn't want to buy new hardware just to get one program to work in Hardy, but unfortunately I'm out of ideas at this point. You could run Rezound from terminal and see what output it gives you when it crashes, but that might not reveal anything useful.


Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •