Results 1 to 5 of 5

Thread: ATI RADEON 9600 pro problems

  1. #1
    Join Date
    Feb 2007
    Location
    trepassey/newfoundland
    Beans
    32
    Distro
    Edubuntu 7.10 Gutsy Gibbon

    Exclamation ATI RADEON 9600 pro problems

    ok i need help! stuck on 800*600 after tryin to install Drivers from following:
    http://ubuntuforums.org/archive/index.php/t-285125.html

    it was working fine till i meteled with it. I even had Compiz fusion workin before i even had the drivers.
    I have a ATI Radion 9600 pro i have also tried the restriced drivers and they refuse to stay enabled. im startin to wounder if my card is really even supported because of the trouble i've had with it not wanting to stay enabled i have tried everything i can think on and need help!
    PHP Code:
    sudo apt-get coffie Reading package lists... Done
    Building dependency tree Reading state information
    ... 
    Registered Linux user number: 457964.
    Registered Ubuntu user number: 18966

  2. #2
    Join Date
    Nov 2005
    Location
    Uppsala, Sweden
    Beans
    2,181
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: ATI RADEON 9600 pro problems

    That link does not describe any driver installation, it just tells you how to manually configure nvidia drivers to fix some old resolution issue.
    As you said, you have an ati card, so those instructions will never help you (but they will mess things up).
    Or maybe you pasted the wrong link?

    To get things working properly, try this:

    First make sure you have a clean xorg.conf:
    Code:
    sudo dpkg-reconfigure xserver-xorg
    Then use the restricted-manager (System --> Administration --> Hardware Drivers (or whatever its name is, I just translated from swedish)) to install and enable the drivers.

    Reboot. Now it should work. I have a Radeon 9600 Pro, which works just fine that way.
    Last edited by jocko; May 1st, 2008 at 10:04 PM.

  3. #3
    Join Date
    Feb 2007
    Location
    trepassey/newfoundland
    Beans
    32
    Distro
    Edubuntu 7.10 Gutsy Gibbon

    Re: ATI RADEON 9600 pro problems

    ok this works, thanks very very much however it shot my refresh rate up for my monitor couldn't handle how do ya fix that? do i need to edit Xorg?
    PHP Code:
    sudo apt-get coffie Reading package lists... Done
    Building dependency tree Reading state information
    ... 
    Registered Linux user number: 457964.
    Registered Ubuntu user number: 18966

  4. #4
    Join Date
    Nov 2005
    Location
    Uppsala, Sweden
    Beans
    2,181
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: ATI RADEON 9600 pro problems

    Quote Originally Posted by ricky_cullen View Post
    ok this works, thanks very very much however it shot my refresh rate up for my monitor couldn't handle how do ya fix that? do i need to edit Xorg?
    If you know which refresh rates your monitor can handle, you can add the refresh rate ranges to xorg.conf. You can probably find these in your monitor manual (which you may find on the manufacturers home page).

    Code:
    sudo gedit /etc/X11/xorg.conf
    Find 'Section "Monitor"' and add your ranges like this:
    Code:
    HorizSync       30-110
    VertRefresh     50-150

  5. #5
    Join Date
    Feb 2007
    Location
    trepassey/newfoundland
    Beans
    32
    Distro
    Edubuntu 7.10 Gutsy Gibbon

    Talking Re: ATI RADEON 9600 pro problems

    Thank you very much that worked perfectly
    PHP Code:
    sudo apt-get coffie Reading package lists... Done
    Building dependency tree Reading state information
    ... 
    Registered Linux user number: 457964.
    Registered Ubuntu user number: 18966

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •