Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 37

Thread: SPDIF in Hardy

  1. #21
    Join Date
    Jul 2006
    Location
    Calgary, Alberta
    Beans
    1,112
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: SPDIF in Hardy

    Quote Originally Posted by dryphi View Post
    Has anyone tried the above posted solution with Intrepid?

    I have been trying to get digital sound to work for some time now. I can get it to work for music by selecting iec958 for everything under Preferences -> Sound; but even after that I get no sound through Firefox or Flash apps. Furthermore I have actually never heard the startup sound!


    Edit: I am referring to the first mentioned solution, although I am curious if any other solution would work as well. Please just be specific in a response so I know which of the above solutions work, if any.
    I just set up SPDIF in 8.1 yesterday.
    1. install 8.1
    2. install Pulse Audio
    3. double click volume icon (speaker) in panel
    4. change drop down menu to your SPDIF device (mine is "ALSA PCM on front:0 (NVIDIA CK804) via DMA (PulseAudio)" when I use SPDIF out on my NVidia motherboard)
    5. set volume slider to 0
    6. open Pulse Audio Volume Control
    7. make sure the only item listed under the Playback tab is the program you're trying to play music from. If some other program is using Pulse Audio, it's not going to be able to send sound to anything else. If you see some other application there, right click and terminate the stream, then restart the application which you want to use sound with.
    8. If you do see your application listed under this tab, right click it and make sure the stream is on the right channel. If not, choose to move it to the right channel (front:0 NVIDIA CK804 for me)
    9. under Output Devices, right click your device (front:0 NVIDIA CK804 for me) and make sure it's set as default.
    10. System - Preferences - Sound - set 4 playback to Pulse Audio. Then set 5th drop down to your device (front:0 NVIDIA CK804 for me)

    You're done. If you're using Audacious, go into the options and make sure it's using the Pulse Audio output, then close it and open it again. It should play sound, I'm listening to it right now....
    Last edited by Maheriano; May 9th, 2009 at 04:00 AM.

  2. #22
    Join Date
    Jan 2009
    Location
    Phil<th>adelphia, PA
    Beans
    52
    Distro
    Ubuntu 11.04 Natty Narwhal

    Exclamation Re: SPDIF in Hardy

    Okay, this was somewhat helpful.

    I am able to "see" the IEC958 device in PulseAudio Volume Control only after I add the line "load-module module-alsa-sink device=hw:0,2" into default.pa
    Also I can get music to play if I set the default device and/or move the stream to this device.

    However, the next time I boot-up, it is no longer set as default, and I have to set the IEC958 as default all over again to hear sound.

    Can I just set this device as default, and have it STAY as default? I would like all sound, henceforth, to play via the IEC958 device.

    Thank you!

  3. #23
    Join Date
    Jan 2009
    Location
    Phil<th>adelphia, PA
    Beans
    52
    Distro
    Ubuntu 11.04 Natty Narwhal

    Talking Re: SPDIF in Hardy

    I got it working! For the most part...

    Quote Originally Posted by devguy View Post
    5) add a line at the very bottom like this:
    Code:
     load-module module-alsa-sink device=hw:0,1
    where the part "hw:0,1" is hardware card 0, device 1 (use the ones you got from step 3).
    6) save and exit this file
    I wanted to point out that the "load-module module-alsa-sink device..." code should NOT be placed at the very bottom of default.pa. It should be placed under the "### Load audio drivers statically..." subheader, towards the top of default.pa.

    When I did this my IEC958 device was properly recognized and set as the default device for playback. I could hear music and even flash videos.


    I say "for the most part" above because I'm still not hearing any sounds at startup. I can live with that I just wanted music and movies to playback correctly.

    To get proper surround-sound, I also changed the default channels from 2 to 6 per this post:
    http://ubuntuforums.org/showthread.php?t=795525

  4. #24
    Join Date
    Jun 2007
    Beans
    16

    Re: SPDIF in Hardy

    I am having trouble with a USB DAC (recognised but plays no sound through DAC - only through PC speakers).

    When I click on the speaker icon to get the Panel Volume control, I cannot see PCM listed in the Preferences (only Master).

    I also get an error message:

    An error occurred while loading or saving configuration information GNOME ALSA Mixer. Some of the config settings may not work properly.

    Bad key in directory name 11/apps/gnome/alsamixer/slider_display_names/Sigmatel_STAG 9721,23-Master",; is an Invalid character in key..........

    Can anybody tell me what to do now please?

  5. #25
    Join Date
    Mar 2007
    Location
    PA
    Beans
    174
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: SPDIF in Hardy

    Quote Originally Posted by dryphi View Post
    I got it working! For the most part...



    I wanted to point out that the "load-module module-alsa-sink device..." code should NOT be placed at the very bottom of default.pa. It should be placed under the "### Load audio drivers statically..." subheader, towards the top of default.pa.

    When I did this my IEC958 device was properly recognized and set as the default device for playback. I could hear music and even flash videos.


    I say "for the most part" above because I'm still not hearing any sounds at startup. I can live with that I just wanted music and movies to playback correctly.

    To get proper surround-sound, I also changed the default channels from 2 to 6 per this post:
    http://ubuntuforums.org/showthread.php?t=795525
    Thanks dryphi, I finally got my Turtle Beach Audio Advantage USB card working thanks to this. Now my Logitech Z-5500 are putting out beautiful DD and DTS sound again. Now I can finally crack open and watch The Ultimate Matrix Collection I bought a few months ago now that I finally got an apartment big enough(and without paper thin walls) that I can set up my Z-5500s . Audio bliss has finally come back now that I can put my old tinny stereo speakers into storage.

  6. #26
    Join Date
    Mar 2006
    Location
    Denver, CO
    Beans
    392
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: SPDIF in Hardy

    I just lost everything after it was all working fine. Now all I have is digital output via spdif. Sound from any source other than digital is completely silent. My Z5500s display "No Digital Data" where they used to display "Movie" or "Music"

    I am running 9.04. Not sure what I did to cause everything to fail so completely.

  7. #27
    Join Date
    Mar 2007
    Location
    PA
    Beans
    174
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: SPDIF in Hardy

    Look HERE I had more or less the same problem so I ended up just modifying each media player by hand and now everything but M-Player uses AC3.

  8. #28
    Join Date
    Aug 2006
    Beans
    16

    Re: SPDIF in Hardy

    Hi!

    I have an msi ex600 notebook, specs say with spdif jack output.

    I followed the instructions for setting spdif up, only result i got out of it was that i see sound-meter in pulse volume control going nicely up und down for the dig out, when playing something in mplayer - but i dont hear anything.

    (I dont know whats with amarok, it still plays normally analog.)

    Could my dig. cable be wrong? I made one myself, but i heard something about higher impedance for dig. cables, so maybe thats my problem?

  9. #29
    Join Date
    Mar 2007
    Location
    PA
    Beans
    174
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: SPDIF in Hardy

    Are you getting any sound through your digital out such as stereo? If not than it might be your cable. Use a tester and make sure that you didn't shatter your cable when you were polishing it(Fiber cables are very easy to shatter and i know this from first hand as i have made several of them) or make sure that you polish it enough. It could be as you said and your impedance is too low. You would probably be better off just buying one(I recommend MonoPrice as they offer great cables at an exceptional price and their shipping is cheap) as a machine can polish a cable to perfect impedance and can polish a cable better than a human can do it.

  10. #30
    Join Date
    Aug 2006
    Beans
    16

    Re: SPDIF in Hardy

    With fiber You mean optical cable, right?
    I have coaxial input on my DAC and a normal headphone jack on the laptop..as far as i know i have to use a mono-jack to rca cable, so thats what i made.
    I get nothing out of windows either, by the way.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •