Results 1 to 9 of 9

Thread: Help with mounting a partition please

  1. #1
    Join Date
    May 2007
    Beans
    13

    Help with mounting a partition please

    Hello to all,

    Anyways I am a little good with Linux but as how to the what I am going to ask for I am a total newb.

    Anyways I recently made a dual boot set-up running Xubuntu (Hardy) and Windows XP, Both of these partitions are fine except that I have another third Partition that's formatted as FAT32, I made this as a storage partition so that I can have store music and movies in there so that both OS's can acess them. My problem is how do I mount this third partition?

    Here's the output of fdisk -l

    Code:
    Disk /dev/sda: 61.4 GB, 61492838400 bytes
    255 heads, 63 sectors/track, 7476 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x3ab66cfc
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        1275    10241406    7  HPFS/NTFS
    /dev/sda2            1276        2127     6843690   83  Linux
    /dev/sda3            2551        7476    39568095    b  W95 FAT32
    /dev/sda4            2128        2550     3397747+  82  Linux swap / Solaris
    
    Partition table entries are not in disk order
    SDA3 is the one I am trying to mount.

    Please help me solve this, and If you can please make any instructions as newby friendly as possible since I suck at this sort of thing.

  2. #2
    Join Date
    Jul 2007
    Location
    Virginia, US
    Beans
    Hidden!

    Re: Help with mounting a partition please

    You need to edit your fstab file so that it will mount.

    Code:
    sudo cp /etc/fstab ~/.fstab
    create a backup just in case, it will be located in your home folder.

    Code:
    sudo mkdir /mnt/media
    Make a mount point for the drive, media can be replace with whatever you want to name the drive

    Code:
    sudo gedit /etc/fstab
    open your fstab file for editing

    Code:
    dev/sda3 /mnt/media FAT32 0 0
    add this line to the bottom of fstab, making sure that the '/mnt/media' is typed exactly as you did in step two.

    Code:
    sudo mount -a
    Remount your drives.

    Just copy and paste and you should be fine
    Registered Linux User: 453202 Registered Ubuntu User:17339
    WARNING: Don't take code or candy from strangers.

  3. #3
    Join Date
    May 2007
    Beans
    13

    Re: Help with mounting a partition please

    Ok so I tried everything you told me yet I am getting a bit of an error.

    this is the output of when I try to mount it.

    Code:
    carlos@carlos-desktop:~$ sudo mount -a /mnt/media
    mount: unknown filesystem type 'FAT32'

    It seems that everything would work if I can figure this part out,Whats the name that ubuntu uses for FAT 32 partitions?


    I also tried changing FAT32 for "vfat" and it triggered this error when I tried to mount it.
    Code:
    sudo mount -a /mnt/media
    mount: wrong fs type, bad option, bad superblock on /dev/sda3,
           missing codepage or helper program, or other error
           In some cases useful info is found in syslog - try
           dmesg | tail  or so
    So I am guessing vfat is not it.
    Last edited by ComeGetSome; May 1st, 2008 at 03:28 AM.

  4. #4
    Join Date
    Dec 2007
    Beans
    Hidden!

    Re: Help with mounting a partition please

    I don't have any vfat partitions at the moment but I think something like this did it for me in the past.
    Code:
    dev/sda3 /mnt/media vfat auto,iocharset=utf8,rw,noexec,umask=000  0 0

  5. #5
    Join Date
    Apr 2006
    Location
    Green Bay, WI, USA
    Beans
    399
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: Help with mounting a partition please

    First try to manually mount it from a terminal window. Here's the correct syntax:
    Code:
    sudo mount -t vfat /dev/sda3 /mnt/media
    santaslittlehelper's fstab line looks like it should work too.
    Last edited by qpieus; May 1st, 2008 at 04:46 AM.
    A computer without Microsoft is like a chocolate cake without mustard.

  6. #6
    Join Date
    Jul 2007
    Location
    Virginia, US
    Beans
    Hidden!

    Re: Help with mounting a partition please

    That was the part I wasn't sure about, I figure someone would correct me if I was wrong.
    Registered Linux User: 453202 Registered Ubuntu User:17339
    WARNING: Don't take code or candy from strangers.

  7. #7
    Join Date
    Jun 2007
    Location
    WorldWideWeb
    Beans
    87
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Help with mounting a partition please

    About 10 mins ago I learned about this app PySDM. You don't have to worry about any fstab anymore . Use this app to configure the partition of your interest only. Works great on my machine.
    I also would advise you to use NTFS instead of FAT32 for sharing partition. Though there are some small flaws with deleting files from NTFS under Ubuntu, it has less errors during work. I had some FAT32 partition on my old HD on desktop computer, and it gave me plenty of head ache. Everytime there were this harddisk checks on startup. Nevertheless, if you still like FAT32 there was some way to disable this checks...

  8. #8
    Join Date
    May 2007
    Beans
    13

    Re: Help with mounting a partition please

    Thank you all for your help, with all your help I was able to get it to mount,But it only has read access not write. Anyone know how to fix this? If not I might switch the partition to ex2 and get the ex2 read and write drivers for windows XP which supposedly work, Anyone have an idea as to what I should do?
    Last edited by ComeGetSome; May 1st, 2008 at 11:31 PM.

  9. #9
    Join Date
    Dec 2007
    Beans
    Hidden!

    Re: Help with mounting a partition please

    I got Hardy Heon installed on a old computer with a second harddrive that is unallocated so I created a small vfat partition.

    Then I double clicked the vfat partition, a pop-up came with policy changes and I was asked for password.

    The vfat partition now mounts to /media/disk at every boot and I got full rw access, I am guessing it's a hal and gnome-mount thing.

    It's now added to - Administration > Authorizations > hal/storage > Mount internal drives.

    No entry was made to fstab.

    So my suggestion is to comment out the vfat entry you made in fstab.
    Then umount the vfat drive and see if the above works for you.

    I was however able to mount /sdb1 to /mnt with full rw -
    Code:
    /dev/sdb1 /mnt/vfat vfat auto,utf8=true,umask=0000  0 0
    http://gentoo-wiki.com/HOWTO_Mount_W...FAT%2C_NTFS%29)

    The drive didn't show under Computer but is was there, I really think your suppose the mount in /media.

    Finally fat32 is not that great for many reasons so going with something else might be the thing to do anyway.

    Just to add,
    you would probably only need a fstab entry if you wanted to bypass the defaults.

    Code:
    /dev/sdb1 /media/vfat vfat users,noauto,uid=1000,gid=1000,utf8=true,umask=000  0 0
    to not auto mount but be able to mount as user.

    opps! Come to think of it you are running xubuntu so you might be missing out on some gnome features.
    If that's the case,
    Code:
    /dev/sda3 /mnt/disk vfat users,auto,utf8=true,umask=000  0 0
    should work.
    Last edited by santaslittlehelper; May 2nd, 2008 at 06:51 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •