Well I finally got Hardy installed. The trick for me with the Live CD was hitting F6 then adding the line all_generic_ide floppy = off irqpoll. Then it proceeded to install fine with no (ininitramfs)_ prompt. This solution that others here tried worked for me. Thanks!! to everyone. Hopefully now this boot parameter will be put into an updated iso by default from Canonical. Then allot of people shouldn't experience this problem when booting. I hope this update will come soon before the Shipit cds are sent. So others who are not so Linux savy won't be pulling their hair out.