Page 14 of 15 FirstFirst ... 412131415 LastLast
Results 131 to 140 of 148

Thread: Vim R plugin installation issue

  1. #131
    Join Date
    Aug 2007
    Beans
    65

    Re: Vim R plugin installation issue

    No worries, thank you for your quick reply. It was working before I made these changes, so clearly it is something I did. I don't think it's vundle, after all I was using pathogen before that and that was fine, so maybe an issue with another plugin perhaps (e.g. powerline or latex-box). Thanks again.

  2. #132
    Join Date
    Oct 2012
    Beans
    13

    Re: Vim R plugin installation issue

    I have followed all the instructions in the following site:

    http://www.lepem.ufc.br/jaa/r-plugin...n-installation


    I am trying to install this on an ubuntu chroot running in an android phone. In terminal emulator when I type vim test.R it says
    Tmux 1.5 or greater required. But my version is 1.6. Then I manually opened tmux, then vim test.R. But none of the \rf or other commands work.

    Then in vim, I typed "ScreenShell R". It opened R console right below in a split screen. Then I typed "ScreenSend" and it sent and executed R code in the console. I borrowed this command from another blog with only a vague idea about them.

    Any idea what's going on here?

  3. #133
    Join Date
    Sep 2007
    Location
    Brazil
    Beans
    77

    Re: Vim R plugin installation issue

    Quote Originally Posted by bigmonty View Post
    Tmux 1.5 or greater required. But my version is 1.6. Then I manually opened tmux, then vim test.R. But none of the \rf or other commands work.
    What is the output of
    Code:
    tmux -V
    It should be "tmux 1.6".

    Quote Originally Posted by bigmonty View Post
    Then in vim, I typed "ScreenShell R". It opened R console right below in a split screen. Then I typed "ScreenSend" and it sent and executed R code in the console. I borrowed this command from another blog with only a vague idea about them.

    Any idea what's going on here?
    ScreenSend is a command to send string to a application running in a Tmux pane started by ScreenShell. The Vim-R-plugin uses it send commands to R.

  4. #134
    Join Date
    Oct 2012
    Beans
    13

    Re: Vim R plugin installation issue

    Thanks a lot for your quick response. I really appreciated that.

    It is indeed tmux 1.6. Let me elaborate a bit on the error code when I type "vim test.R" in ubuntu console.

    Sorry, since it is in a mobile device, I can not copy and paste the whole error output: I am typing the whole thing, sorry if there is any typo.

    Cannot execute shell /system/bin/sh
    Error detected while processing /root/.vim/r-plugin/common_global.vim:line 2865

    E484: Can't open file /tmp/vYco6Ye/0

    Vim-R-plugin requires tmux>=1.5

    But if I first open tmux and then type "vim test.R" in the console, the error message does not come. But none of the plugin command works.

    Any possible solution?

  5. #135
    Join Date
    Oct 2012
    Beans
    13

    Re: Vim R plugin installation issue

    I am so much banking on you jalvesaq. Please help me out with this.

  6. #136
    Join Date
    Sep 2007
    Location
    Brazil
    Beans
    77

    Re: Vim R plugin installation issue

    Quote Originally Posted by bigmonty View Post
    Cannot execute shell /system/bin/sh
    Error detected while processing /root/.vim/r-plugin/common_global.vim:line 2865

    E484: Can't open file /tmp/vYco6Ye/0

    Vim-R-plugin requires tmux>=1.5
    You may edit ~/.vim/r-plugin/common_global.vim and DELETE the 11 lines of code that test Tmux version:

    Code:
    let s:tmuxversion = system("tmux -V")
    let s:tmuxversion = substitute(s:tmuxversion, '.*tmux \([0-9]\.[0-9]\).*', '\1', '')
    if strlen(s:tmuxversion) != 3
        let s:tmuxversion = "1.0"
    endif
    if g:vimrplugin_tmux && s:tmuxversion < "1.5"
        call RWarningMsgInp("Vim-R-plugin requires Tmux >= 1.5")
        let g:rplugin_failed = 1
        finish
    endif
    unlet s:tmuxversion

  7. #137
    Join Date
    Oct 2012
    Beans
    13

    Re: Vim R plugin installation issue

    Thanks a lot, I will try to do that and let you know.

  8. #138
    Join Date
    Oct 2012
    Beans
    13

    Re: Vim R plugin installation issue

    It spits out an error message very fast and goes to open test.R file after "vim test.R" command. Since it goes away very fast I can just see its the same kind of error message without 'tmux version warning.

  9. #139
    Join Date
    Sep 2007
    Location
    Brazil
    Beans
    77

    Re: Vim R plugin installation issue

    Quote Originally Posted by bigmonty View Post
    It spits out an error message very fast and goes to open test.R file after "vim test.R" command. Since it goes away very fast I can just see its the same kind of error message without 'tmux version warning.
    In Vim, do the following in Normal mode to see past messages:

    Code:
    :messages
    Note: it's better to start tmux first and, then, vim:

    Code:
    tmux
    vim test.R
    then you do \rf to start R.

  10. #140
    Join Date
    Oct 2012
    Beans
    13

    Re: Vim R plugin installation issue

    Thanks again. I have been doing exactly that. First, tmux, then "vim test.R". Still it does not work. It seems the plugin was not activated. \rf does not work.

Page 14 of 15 FirstFirst ... 412131415 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •