Results 1 to 7 of 7

Thread: How to disable CTRL ALT F1

  1. #1
    Join Date
    May 2007
    Beans
    71

    How to disable CTRL ALT F1

    I want to prevent the terminal from opening with CRTL ALT F1 because it interferes with some (brane-ded) software that uses the same keys to enable and disable the software GUI.

    It would normally be done by commenting out a line in inittab

    I have no inittab ... what do I have to do to the files in /etc/event.d to prevent a terminal from opening when I press CTRL ALT F1

    Step by step please.

  2. #2
    Join Date
    May 2007
    Beans
    71

    Re: How to disable CTRL ALT F1

    Uh ... no answers?

  3. #3
    Join Date
    Jan 2008
    Beans
    2

    Re: How to disable CTRL ALT F1

    Hi,

    This may be strange, answering to a very old topic, but you have to add this to the xorg.conf file:

    Code:
    Section "ServerFlags"
    Option "DontVTSwitch" "true"
    EndSection

  4. #4
    Join Date
    Jul 2008
    Beans
    2
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How to disable CTRL ALT F1

    That's exactly what it was, the:

    Option "DontVTSwitch" "true"

    in the xorg.conf disabled this option. Thanks!

  5. #5
    Join Date
    Sep 2008
    Beans
    49
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How to disable CTRL ALT F1

    just what I was looking for. I might note that in Karmic the xorg.conf file doesn't exist (if you haven't created it yet) so you'll have to create a blank file in the proper directory and and the previously mentioned lines.
    Dell Studio Core 2 Duo T6400, 4 GB RAM, Ubuntu Karmic 9.10

    Inspiron 1100, Intel Celeron 2.40 GHz, 845 Intel Graphics, 638 MB RAM, Ubuntu Gutsy 7.10

  6. #6
    Join Date
    Jul 2011
    Location
    Michigan
    Beans
    1

    Re: How to disable CTRL ALT F1

    I have found the file xorg.conf but it is read only. what do I do

  7. #7
    Join Date
    Jul 2011
    Beans
    1

    Smile Re: How to disable CTRL ALT F1

    hey

    The xorg.conf is not for regular user to edit and save.

    1. Copy that file to your home directory ( cp /etc/X11/xorg.conf /home/user1/.... )
    2. edit and save in your user directory
    3. copy it back to the /etc/x11 directory ( sudo cp /home/user/xorg.conf /etc/x11 )

    done.

    btw, thanks to the previous post about how to disable ctrl-alt-f1. I've been looking for it for weeks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •