Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: Canon iP2600....anyone?

  1. #11
    Join Date
    Jun 2008
    Beans
    8

    Re: Canon iP2600....anyone?

    Thank for your advice, naildeca. It was very helpful.

  2. #12
    Join Date
    Jun 2009
    Beans
    3

    Re: Canon iP2600....anyone?

    Hi - I am really new newbie. I installed the packages from the Asian site - both debs and they seemed to install properly in 9.04 - but when I go to add the printer I get the error that says "CUPS sever error - "client-error-not-possible" then it fails and I can do nothing... does anyone have an idea of what is wrong???

    BTW - I do have an AMD 64 processor - but what does this have to do with a printer???

    Thanks to any and all that can help.

  3. #13
    Join Date
    Apr 2008
    Beans
    15
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Canon iP2600....anyone?

    Just bought one of these printers and it did not have the right driver. All I had to do extra was the following from a terminal 'sudo apt-get install -f' and then both packages worked great!

    Just wanted to say thanks!!!

  4. #14
    Join Date
    Oct 2007
    Beans
    428

    Re: Canon iP2600....anyone?

    Did you have to do the steps in posts #6 and #9?

    I was considering buying this printer. It appears to be a relatively Linux-friendly printer that is cheap yet decent. I find that HP inkjet printers are way overrated. The functioning of them, not the Linux part.

    I was going to go by this guide before I came across this thread. I guess they are both more or less the same:

    http://www.openprinting.org/show_pri...n-PIXMA_iP2600

  5. #15
    Join Date
    Dec 2008
    Location
    Si Valley
    Beans
    66
    Distro
    Ubuntu 12.04 Precise Pangolin

    Canon IP2600 in Karmic

    For those who cannot install packages
    • cnijfilter-common_2.90-1_i386.deb
    • cnijfilter-ip2600series_2.90-1_i386.deb
    due to missing libcupsys2 in Karmic Koala (9.10), you can modify these packages as described in this tutorial.

    Alternatively, you can download the following packages that I have modified myself Of course, the order of installation remains the same: common -> IP2600.

    rebuilt_common.deb
    rebuilt_ip2600.deb

  6. #16
    Join Date
    Jul 2009
    Beans
    43
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Canon iP2600....anyone?

    @almikul

    Thank you, that was extremely helpful.

  7. #17
    Join Date
    Feb 2009
    Beans
    2

    Re: Canon iP2600....anyone?

    Thank god you modified those. I was looking at the source for the common library and could not make heads or tails of it.

  8. #18
    Join Date
    Dec 2008
    Location
    Si Valley
    Beans
    66
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Canon iP2600....anyone?

    Some minor update: when I installed IP2600 with my own modified packages, the file /usr/lib/cups/filter/pstocanonij was owned by me and not root. It is supposed to be owned by root, so if it is not, then you should manually set the ownership to root by doing

    Code:
    sudo chown root:root /usr/lib/cups/filter/pstocanonij
    Hope it helps.

  9. #19
    Join Date
    Jun 2008
    Beans
    4

    Re: Canon IP2600 in Karmic

    Thanks for the modified packages for Karmic. I was able to install them using --force-architecture but when I try to print, it gives a 'cups-insecure-filter' error and it won't print. Any idea how to overcome this?

    Also, one of the posts above says to 'Register printer to the spooler'. How do I do this?

  10. #20
    Join Date
    Jun 2008
    Beans
    4

    Re: Canon IP2600 in Karmic

    I solved this and my canon ip2600 is printing back again.

    Ran the following commands:

    sudo chown -hR root /usr/lib/cups/filter
    sudo chown -hR root /usr/lib/cups/backend
    sudo chgrp -hR root /usr/lib/cups/filter
    sudo chgrp -hR root /usr/lib/cups/backend

    Thanks all for your help

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •