Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: No Wireless on my Macbook

  1. #11
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: No Wireless on my Macbook

    Quote Originally Posted by KC_HYPE View Post
    Code:
    ndiswrapper -l 
    bcmwl5 : invalid driver!
    (i guess this means no to your first question blurg)
    Right on.

    remove that driver:
    Code:
    sudo ndiswrapper -r bcmwl5
    then get the driver from your OSX restore dvd as shown here:
    http://ubuntuforums.org/showthread.php?t=735846
    you can ignore step 5,6, and 7 as that bug was fixed in Hardy final.

  2. #12
    Join Date
    Apr 2008
    Beans
    13

    Re: No Wireless on my Macbook

    ok, so i put in the osx disc.
    in BootCamp/drivers i click on broadcominstaller.exe, and cant open it "No application suitable for automatic installation is available for hadling this kind of file"
    though i'm not sure i was supposed to try that anyways...

    unrar x broadcomxpinstaller.exe
    and
    unrar x broadcominstaller.exe (changed it to match the file name... not sure if you can do that or if its right)
    these both give:

    The program 'unrar' is currently not installed. You can install it by typing:
    sudo apt-get install unrar
    You will have to enable component called 'multiverse'
    bash: unrar: command not found

    so i do as directed (though not enabling 'multiverse', not sure what that means)
    and i get:
    kevin@kevin-laptop:~$ sudo apt-get install unrar
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package unrar is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    does any of this have to do with 64bit vs 32bit?
    is enabling 'multiverse' my problem?

    thanks again

  3. #13
    Join Date
    Apr 2008
    Beans
    13

    Re: No Wireless on my Macbook

    never mind the multiverse
    that was easy enough to find out
    unrar is now installed
    but...

    kevin@kevin-laptop:~$ unrar x broadcomxpinstaller.exe

    UNRAR 3.70 beta 3 freeware Copyright (c) 1993-2007 Alexander Roshal

    Cannot open broadcomxpinstaller.exe
    No such file or directory
    No files to extract

    tries it as well with broadcominstaller.exe (the actual file name on the disk)


    hope this isn't as simple as my mutiverse problem..

  4. #14
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: No Wireless on my Macbook

    Quote Originally Posted by KC_HYPE View Post
    never mind the multiverse
    that was easy enough to find out
    unrar is now installed
    but...

    kevin@kevin-laptop:~$ unrar x broadcomxpinstaller.exe

    UNRAR 3.70 beta 3 freeware Copyright (c) 1993-2007 Alexander Roshal

    Cannot open broadcomxpinstaller.exe
    No such file or directory
    No files to extract

    tries it as well with broadcominstaller.exe (the actual file name on the disk)


    hope this isn't as simple as my mutiverse problem..
    I don't really know why it uses unrar since it really is a zip archive, but whatever...

    there should be an xp driver package and a vista driver package, just make sure you are using the xp one. If you continue to have trouble, send me a PM and I can help you better.

  5. #15
    Join Date
    Apr 2006
    Beans
    38

    Re: No Wireless on my Macbook

    Looking in my system profiler I have the Macbook 2,1. I have installed wifi successfully in the past from here https://help.ubuntu.com/community/MacBook. This time when I try to follow those instructions, I get that it can't find package build-essential when trying both methods, including subversion. I am using 8.04 LTS. I had no problems with 8.04 Betas in the past.

    Any idea why it can't find it? I am connected right now via ethernet, so I have internet access...

    Cheers,
    Larrinski.

  6. #16
    Join Date
    Apr 2006
    Beans
    38

    Re: No Wireless on my Macbook

    Quote Originally Posted by larrinski View Post
    Looking in my system profiler I have the Macbook 2,1. I have installed wifi successfully in the past from here https://help.ubuntu.com/community/MacBook. This time when I try to follow those instructions, I get that it can't find package build-essential when trying both methods, including subversion. I am using 8.04 LTS. I had no problems with 8.04 Betas in the past.

    Any idea why it can't find it? I am connected right now via ethernet, so I have internet access...

    Cheers,
    Larrinski.
    Now it seems to download using subversion and I get as far as the last step and then I get
    jamie@jamie-desktop:~$ sudo iwpriv ath0 bgscan 0
    ath0 no private ioctls.
    Any idea why it is not taking? I am running Hardy under Parallels...

  7. #17
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: No Wireless on my Macbook

    Quote Originally Posted by larrinski View Post
    Any idea why it is not taking? I am running Hardy under Parallels...
    then why would you need to access wifi hardware directly? set the vm settings to share the host connection...

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •