Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Hosts file and networking

  1. #11
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Hosts file and networking

    It didn't make much sense to me that gksudo would work. I suggested it because it seemed to work for a few other people on the forums. Try Monicker's suggestion-- reboot, and from the grub menu choose recovery mode. This should give you a root prompt and allow you to do
    Code:
    nano /etc/hosts
    and fix the hosts file from the terminal.

    If that doesn't work, there's ShaunBrown's method, or failing all else, booting from a live cd and fixing the file from there.

  2. #12
    Join Date
    Sep 2006
    Beans
    52

    Re: Hosts file and networking

    Hello
    now unable to run this cmd!! the terminal just sits there not doing noyhing!! what am I doing wrong?

    futher if I use vi I get the following
    sudo vi /etc/hosts

    sudo: unable to resolve host geko80

  3. #13
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Hosts file and networking

    What happens when you reboot in recovery mode?

    For me, I get a text only sequence of boot messages and then a root prompt:
    root@myhost:~#
    You shouldn't need sudo from this point. You're root already.

  4. #14
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Hosts file and networking

    Anything here help - especially the link to bug?
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  5. #15
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Hosts file and networking

    I'm guessing a bit, but I'm thinking madsurfer is just not getting into recovery mode.

    When your computer starts up, there should be a short period when it says "grub loading stage 1.5." You need to press escape at this point to bring up the grub boot menu. You only have a few seconds by default.

    This should give you a boot options menu with options to boot into the standard kernel, the kernel in recovery mode, and memtest86+. You want the (recovery mode) option.

    Sorry; I've changed my default settings, and I forgot how hidden this usually is.
    Last edited by jetsam; May 5th, 2008 at 08:58 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •