Results 1 to 6 of 6

Thread: hardy upgrade: can't restart X server (Ctrl-Alt-Backspace)

  1. #1
    Join Date
    Dec 2006
    Beans
    44

    hardy upgrade: can't restart X server (Ctrl-Alt-Backspace)

    Hello,

    After upgrading from Gutsy to Hardy, i am experiencing the following problem with my X server: if i kill the X server (Ctrl-Alt-Backspace), or if it dies of "natural causes" (i.e. compiz crashes) i am left at a black screen with no possibility to get back to a graphical or command line interface. In Gutsy X would restart and i would be returned to the KDM login screen, or at least i could use Ctrl-Alt-F1-F6 to get a CL prompt. Now in Hardy: nothing - i am forced to hard reboot the machine.

    This is on an Asus W2 laptop with an ATI X1700 card running fglrx drivers. I am running my xorg.conf file from Gutsy, except that now AIGLX and Compositing are turned on.

    Regs,
    /t

  2. #2
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: hardy upgrade: can't restart X server (Ctrl-Alt-Backspace)

    I have exactly the same problem. I'm running Ubuntu (not kubuntu), on a laptop with an integrated intel graphics card. I have no desktop effects enabled, so its a fairly different setup to yours, but I still have the same issue.

    I went straight from Dapper (LTS only for me) which was faultless in every respect, and I'm slowly beginning to question why I upgraded.

  3. #3
    Join Date
    Jun 2006
    Beans
    8

    Re: hardy upgrade: can't restart X server (Ctrl-Alt-Backspace)

    Exact same problem. And that is when running with the vesa driver as I can't get the radeon driver to work at all. This hoses me being able to log out back into the login screen.

    I truly think they must have done hardly any testing prior to release.

  4. #4
    Join Date
    Jan 2008
    Beans
    211

    Re: hardy upgrade: can't restart X server (Ctrl-Alt-Backspace)

    bump

  5. #5
    Join Date
    Jan 2008
    Beans
    211

    Wink Re: hardy upgrade: can't restart X server (Ctrl-Alt-Backspace)

    you can re-enable the
    ctr-alt-backspace as it is disabled by default in Hardy

    Using GNOME

    * Get to the System->Preferences->Keyboard menu.

    * Select the “Layouts” tab and click on the “Layout Options” button.

    * Then select “Key sequence to kill the X server” and enable “Control + Alt + Backspace”.

    ------------------------------------
    Using KDE

    * Launch “systemsettings”

    * Select “Regional & Language”.

    * Select “Keyboard Layout”.

    * Click on “Enable keyboard layouts” (in the Layout tab).

    * Select the “Advanced” tab. Then select “Key sequence to kill the X server” and enable “Control + Alt + Backspace”.
    -------------------------------------===
    Using the command line

    You can type the following command to enable Zapping immediately.

    Code:
    setxkbmap -option terminate:ctrl_alt_bksp
    If you’re happy with the new behaviour you can add that command to your ~/.xinitrc in order to make the change permanent.
    ---------------------------------------------------
    Using HAL

    You can add the following line in /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi (inside the <match key=”info.capabilities” contains=”input.keys”> section):

    Code:
    <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
    Last edited by lordbux; April 28th, 2010 at 02:12 PM. Reason: error in typing

  6. #6
    Join Date
    Mar 2008
    Location
    Middle Tennessee
    Beans
    284
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: hardy upgrade: can't restart X server (Ctrl-Alt-Backspace)

    Quote Originally Posted by lordbux View Post
    ...
    You can type the following command to enable Zapping immediately.

    Code:
    setxkbmap -option terminate:ctrl_alt_bksp
    If you’re happy with the new behaviour you can add that command to your ~/.xinitrc in order to make the change permanent.
    ---------------------------------------------------
    Using HAL

    You can add the following line in /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi (inside the <match key=”info.capabilities” contains=”input.keys”> section):

    Code:
    <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
    I am using Fluxbox, so can't navigate the KDE or Gnome menus.

    The command "setxkbmap -option terminate:ctrl_alt_bksp" works fine. However, I have to enter it in a terminal every time to get it to work again. I created an .xinitrc file with "setxkbmap -option terminate:ctrl_alt_bksp", but that does nothing.

    I tried to follow your HAL instructions, but there is no "10-x11-input.fdi" file. There is a plain input file: 10-input-policy.fdi that has the indicated input.keys section. But, as you might guess, there is no restoring CTRL-ALT-Backspace function.

    Any additional insight? Running a 10.04 Xubuntu foundation with fluxbox as my WM.
    Linux Genuine Advantage: I am licensed!

    Spouting mindless hatred of all things Microsoft since... ummm... never.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •