Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Timidity works but no sound from Noteedit - Hardy

  1. #11
    Join Date
    Dec 2008
    Beans
    4

    Re: Timidity works but no sound from Noteedit - Hardy

    Quote Originally Posted by GoLinux View Post
    Hello all,

    in case you still need help, I was able to make it work on my Ubuntu 8.10 Intrepid Ibex.

    1. Launch Timidity++ as server with this command from Terminal:

    timidity -iA -B2,8 -Os -EFreverb=0 2>&1 &

    2. Open NoteEdit, go to Setting -> Configure -> Sound and select "Timidity port 0 128:0", "Apply" then "OK"

    Now pressing the play button it should work.

    Found this here:

    http://alsa.opensrc.org/index.php/Ti..._with_Noteedit

    Rock On!!!
    Ok, Thanks for the solution to this.
    Now, why do I have to reconfigure the sound every time I open up NoteEdit?
    Why doesn't the configure hold forever, until I change it?

  2. #12
    Join Date
    Jul 2008
    Beans
    61

    Re: Timidity works but no sound from Noteedit - Hardy

    [QUOTE=GoLinux;6334754]Hello all,

    in case you still need help, I was able to make it work on my Ubuntu 8.10 Intrepid Ibex.

    1. Launch Timidity++ as server with this command from Terminal:

    timidity -iA -B2,8 -Os -EFreverb=0 2>&1 &

    2. Open NoteEdit, go to Setting -> Configure -> Sound and select "Timidity port 0 128:0", "Apply" then "OK"

    Now pressing the play button it should work.

    Found this here:

    http://alsa.opensrc.org/index.php/Ti..._with_Noteedit
    ================================================== =====

    Thanks this worked for me but I have puzzles.

    When I tried Noteedit without timidity as server I had timidity port 128:0 to 3 showing in Noteedit which didn't work.

    With timidity as server I still had timidity port 128:0 to 3 which still didn't work but also port 130:0 to 3 which did

    Even more puzzling, my Roland piano, connected via USB, hadn't worked for MIDI playback before but does with timidity as server?!?

    (I'm using Jaunty/Kubuntu)

  3. #13
    Join Date
    Sep 2010
    Beans
    1

    Thumbs up Re: Timidity works but no sound from Noteedit - Hardy

    If Timidity plays midi files but nted does not, run

    CODE:

    timidity -iA -B2,8 -Os -EFreverb=0 2>&1 &

    in Terminal.

    Open nted. Edit>Preferences>Configure Midi Out>128:0 Timidity

    Leave echo midi checked.

    This works well, but must be done every time the system is booted. A nice work-around can be found using System>Preferences>Start Up Applications.

    Simply click "Add" and insert the above code in the command box. Add an appropriate title, eg, nted midi support, and you're good to go.

  4. #14
    Join Date
    Oct 2010
    Beans
    76

    Re: Timidity works but no sound from Noteedit - Hardy

    works!

    In lucid & nted (1.9.16 by Joerg Anders)

    1. install timidity (if not yet installed)
    2. Open terminal and run: timidity -iA -B2,8 -Os -EFreverb=0 2>&1 &

    terminal will display something like: Requested buffer size 2048, fragment size 1024
    ALSA pcm 'default' set buffer size 2048, period size 680 bytes
    TiMidity starting in ALSA server mode
    Opening sequencer port: 131:0 131:1 131:2 131:3

    and a flashing cursor

    3. go to nted menu: EDIT->Preferences > configure midi out
    - i think u can select any of the ports displayed on your terminal. i tried: 131:0 Timidity and 131:1 Timidity, both worked.

    now the next step would be to make it work the first time nted is run on the session (ideally not on startup: keeping it lean.)

    how do we do that?
    Last edited by Jack Brown; October 8th, 2010 at 06:10 PM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •