Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Hardy and Nexuiz do not play well

  1. #1
    Join Date
    Apr 2008
    Location
    /na/usa/ca
    Beans
    153

    Hardy and Nexuiz do not play well

    I upgraded to 8.04 yesterday and now Nexuiz doesn't work. It keeps jumping between fullscreen and a monitor-sized window. Before you ask, I have already uninstalled and reinstalled it. Here is the output of when I try to run Nexuiz from the terminal:
    Code:
    staylor@Mariner:~$ nexuiz
    Nexuiz Linux 09:18:31 Mar 23 2008
    Trying to load library... "libz.so.1" - loaded.
    Added packfile /usr/share/games/nexuiz/data/data20080229.pk3 (3982 files)
    Trying to load library... "libcurl.so.4" - loaded.
    Failed to init SDL joystick subsystem: 
    Trying to load library... "libvorbis.so.0" - loaded.
    Trying to load library... "libvorbisfile.so.3" - loaded.
    Trying to load library... "libmodplug.so.0" - loaded.
    Trying to load library... "libOffscreenGecko.so" "/usr/lib/games/nexuiz/libOffscreenGecko.so" - failed.
    execing quake.rc
    execing default.cfg
    execing physicsQBR.cfg
    execing newhook.cfg
    execing weapons.cfg
    execing normal.cfg
    execing config.cfg
    execing data/campaign.cfg
    couldn't exec autoexec.cfg
    Initializing Video Mode: fullscreen 1440x900x32x60hz
    Linked against SDL version 1.2.12
    Using SDL library version 1.2.12
    0 SDL joystick(s) found:
    Trying to load library... "libjpeg.so.62" - loaded.
    Trying to load library... "libpng12.so.0" - loaded.
    Draw_CachePic: failed to load gfx/complete
    Draw_CachePic: failed to load gfx/inter
    Shader 'textures/Reaptxt/sun' already defined
    S_Startup: initializing sound output format: 48000Hz, 16 bit, 2 channels...
    ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
    Wanted audio Specification:
    	Channels  : 2
    	Format    : 0x8010
    	Frequency : 48000
    	Samples   : 4096
    Failed to open the audio device! (No available audio device)
    S_Startup: sound output initialization FAILED
    S_Startup: initializing sound output format: 44100Hz, 16 bit, 2 channels...
    Wanted audio Specification:
    	Channels  : 2
    	Format    : 0x8010
    	Frequency : 44100
    	Samples   : 4096
    Failed to open the audio device! (No available audio device)
    S_Startup: sound output initialization FAILED
    S_Startup: initializing sound output format: 22050Hz, 16 bit, 2 channels...
    Wanted audio Specification:
    	Channels  : 2
    	Format    : 0x8010
    	Frequency : 22050
    	Samples   : 2048
    Failed to open the audio device! (No available audio device)
    S_Startup: sound output initialization FAILED
    S_Startup: initializing sound output format: 11025Hz, 16 bit, 2 channels...
    Wanted audio Specification:
    	Channels  : 2
    	Format    : 0x8010
    	Frequency : 11025
    	Samples   : 1024
    Failed to open the audio device! (No available audio device)
    S_Startup: sound output initialization FAILED
    S_Startup: initializing sound output format: 11025Hz, 8 bit, 2 channels...
    Wanted audio Specification:
    	Channels  : 2
    	Format    : 0x8
    	Frequency : 11025
    	Samples   : 1024
    Failed to open the audio device! (No available audio device)
    S_Startup: sound output initialization FAILED
    S_Startup: initializing sound output format: 11025Hz, 8 bit, 1 channels...
    Wanted audio Specification:
    	Channels  : 1
    	Format    : 0x8
    	Frequency : 11025
    	Samples   : 1024
    Failed to open the audio device! (No available audio device)
    S_Startup: sound output initialization FAILED
    S_Startup: initializing sound output format: 8000Hz, 8 bit, 1 channels...
    Wanted audio Specification:
    	Channels  : 1
    	Format    : 0x8
    	Frequency : 8000
    	Samples   : 512
    Failed to open the audio device! (No available audio device)
    S_Startup: sound output initialization FAILED
    S_Startup: SndSys_Init failed.
    Found 1 cdrom drives.
    The CD in drive 0 is not an audio cd.
    CDAudio_Init: No CD in player.
    Can't get initial CD volume
    CD Audio Initialized
    Client using an automatically assigned port
    Client opened a socket on address local:2
    Client opened a socket on address 0.0.0.0:53412
    No CD in player.
    Warning: released an already released button
    archlinux \\ amd+ati \\ subtle \\ website

  2. #2
    Join Date
    Apr 2008
    Location
    /na/usa/ca
    Beans
    153

    Re: Hardy and Nexuiz do not play well

    Please help, guys. I can't figure out how to get it working.
    archlinux \\ amd+ati \\ subtle \\ website

  3. #3
    Join Date
    Aug 2005
    Beans
    44

    Re: Hardy and Nexuiz do not play well

    I can confirm. I am having the same problem.

  4. #4
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Hardy and Nexuiz do not play well

    edit: Well, upon reading closer, I guess this isn't likely to solve your issue, so ignore me.
    Did you pick completely remove when uninstalling? Also called purge.
    Code:
    $ sudo apt-get autoremove --purge nexuiz*

    Before reinstalling, if you want to be extra super sure, do this.
    Code:
    $ sudo updatedb
    locate nexuiz
    Hunt down and remove the files that it lists. You can likely leave out stuff in your home folder, though.
    Last edited by Zorael; April 29th, 2008 at 02:54 AM.
    ...

  5. #5
    Join Date
    Oct 2007
    Beans
    264

    Re: Hardy and Nexuiz do not play well

    Please try starting nexuiz from the command line using the following command:

    padsp nexuiz

  6. #6
    Join Date
    Nov 2006
    Beans
    6

    Re: Hardy and Nexuiz do not play well

    I am having the same problem (SndSys_Init failed) with Nexuiz, and I tried the padsp command, but the result is the same: no sound.
    ...

  7. #7
    Join Date
    May 2006
    Beans
    911

    Re: Hardy and Nexuiz do not play well

    Why don't you just get the game directly from the Nexuiz guys? That's what I have and it plays flawlessly.

  8. #8
    Join Date
    Apr 2008
    Location
    Ohio
    Beans
    44
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Hardy and Nexuiz do not play well

    I pulled it down from nexuiz and it's not working on my AMD64 3200+ with Hardy 64. It starts, shows the intro screen, when you choose a player mode it drops out and the mouse no longer responds until you restart the desktop or reboot. Is the download from nexuiz working for everyone else?

    Thanks in advance!

  9. #9
    Join Date
    Jul 2006
    Location
    Newcastle, Australia
    Beans
    63
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hardy and Nexuiz do not play well

    After finding this link:
    http://paddydempster.wordpress.com/2...udio-on-hardy/
    I tried:
    Code:
    sudo apt-get install libsdl1.2debian-pulseaudio
    this fixed a lot of problems with SDL apps for me. Mupen64 now works properly, XMame almost does but sound is a bit shaky. Frets on fire still crashes though. I think SDL is going to be a problem for hardy for a little while until things get patched.

    Still try the above and see what happens, I haven't gotten around to reinstalling nexuiz, OpenArena or Quake 4 yet. ut2004 is my flavour of choice.
    respLect.com home of the stuff I do in my spare time. Some of it is kind of cool.
    Life is why I have to die today.

  10. #10
    Join Date
    Oct 2006
    Location
    Amsterdam
    Beans
    153
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: Hardy and Nexuiz do not play well

    having the same prob here, switch between fullscreen and not, sdl??
    i played today without prob after installation but now it messed up...
    running on ubuntu hardy, nvidia 8400m gt, please help


    edit:
    when i start nexuiz under fluxbox (not gnome-desktop), which runs without compiz and all, nexuiz goes just fine. so it seems to have something with gnome/compiz!?
    Last edited by hihihi; May 24th, 2008 at 11:05 AM.
    everything has an end, the sausage has two.
    <<<<<<<<<<<<<<<<<<<"linux worms"

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •