Results 1 to 9 of 9

Thread: Mythbuntu 8.04 install fails at 83%

  1. #1
    Join Date
    Apr 2008
    Beans
    6

    [SOLVED] Mythbuntu 8.04 install fails at 83%

    I'm trying to install Mythbuntu 8.04 on my computer but it somehow fails to complete the installation. Regardless of the way I start the installation (from the Live CD or directly from the option "Install Mythbuntu" in the boot menu), when it reaches 83% - "Configuring MythTV", the window disappear without any error message.

    I already know about a similar problem caused by spaces or certain special characters in the mysql password: http://ubuntuforums.org/showthread.php?t=671186 but my mysql password doesn't have any weird character; it only consists of numbers, lowercase and upercase letters.

    Any ideas about what could be the culprit? I had to leave home before doing more testing and looking for log files, but any help would be appreciated so that once I'm back home I'll be prepared to either give you more information about my bug or simply fix my problem! What log file should I look into?
    Last edited by Grodesh; April 28th, 2008 at 03:31 AM.

  2. #2
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,388
    Distro
    Ubuntu Development Release

    Re: Mythbuntu 8.04 install fails at 83%

    Is this a standard install or advanced install? FE, BE, FE/BE? What options did you pick during install?
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  3. #3
    Join Date
    Apr 2008
    Beans
    6

    Re: Mythbuntu 8.04 install fails at 83%

    Quote Originally Posted by tgm4883 View Post
    Is this a standard install or advanced install? FE, BE, FE/BE? What options did you pick during install?

    It's an advanced installation for a Primary Backend with Frontend with the following options (I suppose most will be irrelevant but I'll just throw them all in case):

    Plugins:
    Myth Web
    Myth Archive
    Myth Controls
    Myth Game
    Myth Video

    Themes:
    Since I don't have a widescreen TV, I deselected all the wide themes

    Additional Services:
    VNC
    SSH
    Samba
    NFS

    MythTV Related Passwords:
    I set up a password for both Mythweb and MySQL. As said before, the MySQL password consist of only number and letters (lower and uppercase) for a length of 12 characters.

    Remote control:
    Windows Media Center USB (Philips)

    Transmiter:
    Windows Media Center for Scientific Atlanta

    Frontend drivers:
    Nvidia drivers for Geforce4 MX 440, with composite out enabled (NTSC-M)

    Backend drivers:
    XMLTV Guide Data

  4. #4
    Join Date
    Apr 2008
    Beans
    6

    Re: Mythbuntu 8.04 install fails at 83%

    I've got the debug file from the installer and I attached it to this post. There seems to be a problem with my locale (fr_CA) as there are a lot of warnings about it.

    Also, the installer tries to write files in the /root/ directory but it lacks the permissions.

    I'll try to setup an en_US installation to see if it makes any difference.
    Attached Files Attached Files
    Last edited by Grodesh; April 27th, 2008 at 01:37 PM.

  5. #5
    Join Date
    Mar 2008
    Location
    Israel
    Beans
    86
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mythbuntu 8.04 install fails at 83%

    when you install from the live cd during the installation unplug the internet cable!!!

  6. #6
    Join Date
    Apr 2008
    Beans
    6

    Re: Mythbuntu 8.04 install fails at 83%

    Neither using en_US or unpluging the network cable changed anything... I'm running out of ideas...

  7. #7
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: Mythbuntu 8.04 install fails at 83%

    Hi Grodesh,

    Can you please post an entire /var/log/syslog after it fails? This log contains a more informative traceback where things are failing.

  8. #8
    Join Date
    Apr 2008
    Beans
    6

    Re: Mythbuntu 8.04 install fails at 83%

    Here's my syslog. Thanks for looking at it.

    I scanned it rapidly and saw new information: For my /home, I'm mounting a partition I was using on my old installation, Since I'm using the same account name (and there already is a home dir for a user called mythtv from my old installation). I suppose there might be a problem with either the uid or the gid which may cause some permission problems. I'll experiment once more by renaming the old home directory names and check what happens when the home directory are recreated from scratch.
    Attached Files Attached Files

  9. #9
    Join Date
    Apr 2008
    Beans
    6

    Re: Mythbuntu 8.04 install fails at 83%

    That was it. Now that the directories didn't exist on the /home partition, the installation has passed the 83% mark and is about to finish.

    THanks a lot superm1, you indirectly showed me the path to a successful installation!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •