How do you apply the following patch?

https://bugs.launchpad.net/ubuntu/+s...072/comments/7

I am trying to apply this patch in response to this bug which seems to be in the works for hardy updates.

http://bugzilla.gnome.org/show_bug.cgi?id=524485

Thanks!