Results 1 to 7 of 7

Thread: package manager SLOW

  1. #1
    Join Date
    Mar 2008
    Beans
    1

    package manager SLOW

    Lately, esp. after the upgrade, package manager has been slow. Like 1 kb per second slow. Is this a problem with ubuntu, the developers of the packages, or my computer settings?
    Last edited by atonalpanic; April 25th, 2008 at 04:36 PM.

  2. #2
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: package manager SLOW

    I think the servers are just getting over-worked by the Hardy release. It's slow here too.

    Took me two minutes just to install beep (22k):
    sudo time apt-get install beep
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    libgd2-noxpm
    Use 'apt-get autoremove' to remove them.
    The following NEW packages will be installed:
    beep
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 22.0kB of archives.
    After unpacking 111kB of additional disk space will be used.
    Get:1 http://us.archive.ubuntu.com gutsy/universe beep 1.2.2-19 [22.0kB]
    Fetched 22.0kB in 1m49s (200B/s)
    Preconfiguring packages ...
    Selecting previously deselected package beep.
    (Reading database ... 155315 files and directories currently installed.)
    Unpacking beep (from .../beep_1.2.2-19_i386.deb) ...
    Setting up beep (1.2.2-19) ...

    2.02user 0.28system 1:53.82elapsed 2%CPU

  3. #3
    Join Date
    Apr 2007
    Location
    Cullman, AL
    Beans
    652
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: package manager SLOW

    Try a different download server in software sources.
    Guide to forum text formatting code. Please use them | Use descriptive thread titles.

  4. #4
    Join Date
    Sep 2007
    Location
    Decatur, IL
    Beans
    444

    Re: package manager SLOW

    Quote Originally Posted by Tim Sharitt View Post
    Try a different download server in software sources.
    Yup. I normally use the US Main Server but had to switch to the gatech server yesterday.
    Microsoft Vista | Ubuntu 8.10
    HP | DV6910US
    Ubuntu Registered User # 20970
    Linux Registered User # 449097

  5. #5
    Join Date
    Jan 2008
    Location
    /dev/null
    Beans
    2,793
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: package manager SLOW

    Quote Originally Posted by Tim Sharitt View Post
    Try a different download server in software sources.
    another option is to select other... from the list in software sources an then click the select best server button from the ensuing dialog box. Its really hard to tell which download server is best right now since its the day after a release and most of the servers are being hammered pretty hard.

  6. #6
    Join Date
    Apr 2007
    Location
    Cullman, AL
    Beans
    652
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: package manager SLOW

    Quote Originally Posted by Oldsoldier2003 View Post
    another option is to select other... from the list in software sources an then click the select best server button from the ensuing dialog box. Its really hard to tell which download server is best right now since its the day after a release and most of the servers are being hammered pretty hard.
    That seems to work best because a closer server isn't a sure thing if it's swamped.
    Guide to forum text formatting code. Please use them | Use descriptive thread titles.

  7. #7
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: package manager SLOW

    Much better. Thanks!

    New test after changing server and doing apt-get clean:
    sudo time apt-get install beep
    ...
    Fetched 22.0kB in 1s (18.0kB/s)
    ...
    Setting up beep (1.2.2-19) ...

    2.02user 0.29system 0:04.82elapsed 47%CPU

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •