Results 1 to 4 of 4

Thread: WPA connection fails after suspend/resume

  1. #1
    Join Date
    Oct 2005
    Location
    Philadelphia, PA
    Beans
    32
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    WPA connection fails after suspend/resume

    Hi all,

    Running 8.04 on an Inspiron 1420 laptop here. My wireless at home is WPA encrypted and I have no issues connecting to it..at first. The problem occurs when I suspend and resume my computer. I can occasionally reconnect, but more often than not I fail to make a connection. I've had this problem using both gnome-network-manager and WICD. I don't think it's driver related, because 'iwconfig' shows the network, but attempting to reissue a DHCP fails. My best guess would be a conflict in issuing a new encyption key? Any ideas on how to troubleshoot or fix this? Thanks.

  2. #2
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

  3. #3
    Join Date
    Oct 2005
    Location
    Philadelphia, PA
    Beans
    32
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: WPA connection fails after suspend/resume

    Thanks for the quick reply. I've tried 'sudo dhclient wlan0' and I hang when trying to acquire a DHCP lease. It eventually times out an gives me a 'DHCP client sleeping error'.

  4. #4
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: WPA connection fails after suspend/resume

    Did you type the entire sequence with the wpa_supplicant.conf file?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •