Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: 8.04 connection troubles

  1. #21
    Join Date
    Jun 2006
    Beans
    21

    Re: 8.04 connection troubles

    I am having this problem too.

    I've tried booting with acpi=noirq on a recommendation with no luck (made the system run really slowly too.)

    I've tried with a Via Rhine VT6107 and another generic Ethernet card. Exactly the same results.

    On roaming and DHCP, it gets a private ip address: 169.x.x.x
    On static, I use 192.168.1.2, it can ping itself but not the router or internet.

    Worked fine in Dapper, Edgy, Feisty, and Gutsy.

  2. #22
    Join Date
    Oct 2006
    Location
    New York
    Beans
    1,118
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: 8.04 connection troubles

    I can get a connection if at the prompt I call

    sudo modprobe -r forcedeth
    sudo modprobe forcedeth msi=0 msix=0
    sudo /etc/init.d/networking restart

    Right now I am unable to get this to work at startup. So I am still looking for a way to do that.

  3. #23
    Join Date
    Jun 2006
    Beans
    21

    Re: 8.04 connection troubles

    Add those commands to bootup.

  4. #24
    Join Date
    Oct 2006
    Location
    New York
    Beans
    1,118
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: 8.04 connection troubles

    Can you please elaborate?

  5. #25
    Join Date
    Apr 2008
    Location
    Houston, Texas
    Beans
    16
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: 8.04 connection troubles

    Adding to boot up is not working... But in case you want to try, see post #57 by sam_delta
    http://ubuntuforums.org/showthread.php?t=766800&page=6
    Last edited by al-fil; May 1st, 2008 at 05:49 AM. Reason: incorrect procedure prior to edit

  6. #26
    Join Date
    May 2007
    Location
    PDX
    Beans
    45

    Re: 8.04 connection troubles

    For those with Broadcom cards, this worked for me:

    http://ubuntuforums.org/showthread.php?t=766560

  7. #27
    Join Date
    Apr 2008
    Beans
    4

    Re: 8.04 connection troubles

    I don't know if anyone else has this problem, but anyway, here it goes:

    When I leave the network setting at roaming, it recognizes a connection, but I get no IP address. Then, when I change it to DHCP, it doesn't recognize a connection, at all.

    I've already blacklisted IPv6, by the way.

  8. #28
    Join Date
    Feb 2007
    Beans
    18

    Re: 8.04 connection troubles

    All these attempts to solve this require a Ph.D in command line ... . Repeatedly they're not working. It's obviously a major showkiller bug for a user. I suggest the team prioritize coming up with a more automated fix if you're ever going to hope to attract Windows users.

    I'll just wait for Linux Mint Elyssa - they'll fix it.

    This does not happen in other distros - not even one - of the scores of distros I've tried.

  9. #29
    Join Date
    Oct 2006
    Beans
    234
    Distro
    Ubuntu Gnome

    Re: 8.04 connection troubles

    edited 24052008
    found my solution!

    Using a belkin Wirless G usb network adapter:

    1. no problem with the right driver.
    2. able to get wireless by entering commands in the terminal
    3. I have my essid hidden
    4. I use WEP 128 bit encryption
    5. I followed the instructions in this thread, helpful, but no connection.

    http://ubuntuforums.org/showthread.php?t=571188

    I tried for hours using the instructions on that thread. It was helpful towards my final
    solution. Using the Network manager just kept getting me into dead ends.

    Code:
    $ sudo gedit /etc/rc.local
    showed this:

    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    exit 0
    I added this to the rc.local:
    Code:
    ifconfig eth0 down
     ifconfig eth1 down
     dhclient -r eth1
     ifconfig eth1 up
     iwconfig eth1 essid "linksys"
     iwconfig eth1 encryption on
     iwconfig eth1 key 1a2b3c4d5e ASCII
     dhclient eth1
    rebooted and still nothing. I wondered why that would not get my a connection on boot. I got desperate. I remembered my simple bin bash command. I commented out #!/bin/sh -e, added #!/bin/bash. saved rc.local and rebooted. And I had an internet connection on boot. #!/bin/sh -e should have worked, but not for me.

    Make sure you don't have any driver conflicts. I Installed rt73 rt 2500 with ndiswrapper, and it did nothing. I finally deleted rt73,rt2500, and ndiswrapper. It seems that 8.04 and 7.10 have the drivers native that are compatible with this Belkin.

    Try entering first from the command line to see if you can get a connection:
    Code:
    ifconfig eth1 down
     sudo dhclient -r eth1
     sudo ifconfig eth1 up
     sudo iwconfig eth1 essid "your routername"
    sudo  iwconfig eth1 encryption on        #I don't know if you need this
    sudo iwconfig eth1 key 1a2b3c4d5e ASCII
     sudo dhclient eth1
    ************************************************** *****************

    Quote Originally Posted by Dutchmaster View Post
    All these attempts to solve this require a Ph.D in command line ... . Repeatedly they're not working. It's obviously a major showkiller bug for a user. I suggest the team prioritize coming up with a more automated fix if you're ever going to hope to attract Windows users.
    Yes, it should be easier than this!
    Last edited by ubume2; May 25th, 2008 at 03:00 AM. Reason: for me problem solved

  10. #30
    Join Date
    Oct 2006
    Location
    New York
    Beans
    1,118
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: 8.04 connection troubles

    I know I'm awful for not sharing earlier, but I found (and now refound a solution to this).

    Add the following line to /etc/modprobe.d/options
    Code:
    options forcedeth msi=0 msix=0
    Then rebuild initramfs like this
    Code:
    sudo update-initramfs -u
    If you read down further I see msi=1, which may work for some, but I have not tested it.

    source1
    source2
    Last edited by hwttdz; September 9th, 2008 at 08:16 PM.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •