Results 1 to 2 of 2

Thread: MX5000 Keyboard Issues

  1. #1
    Join Date
    Apr 2008
    Beans
    1

    MX5000 Keyboard Issues

    Alright, so I recently purchased a Logitech MX5000 keyboard and an MX1000 mouse. After many how-to's and X crashes, I finally configured them correctly to work with bluetooth and not USB emulation. My extra buttons worked (for the most part) and i used xbindkeys to map the mouse. However, after I came back to the computer this morning my mouse and keyboard had dropped. I reset X and it crashed, so i reverted all changes i had made to xorg.conf and started over. Only thing is, this time after i got it all working (with some tweaks to the mouse) a window popped up saying the following:

    The X system keyboard settings differ from your current GNOME keyboard settings.

    Expected was model "evdev", layout "us" and no options, but the the following settings were found: model "pc105", layout "us" and no options.


    Then it asks if you would like to keep the X keyboard settings or the gnome keyboard settings. Regardless of which one i picked (i did it twice), my keyboard layout has a seizure and drops function for the arrow keys, delete, home, page up/down, etc. Now, pressing up arrow brings up the "save screenshot" window, for example.

    The weirdest thing of all is that the changes i made worked the first time, yesterday. I haven't updated Xorg or anything since then, and i didn't configure the keyboard any differently the second time. Also, i've had a PS/2 keyboard connected the entire time just in case, and that keyboard works perfectly. I'm getting the impression that it's evdev's doing, but i don't know how to correct it.

    Help?

  2. #2
    Join Date
    Jul 2005
    Location
    Birmingham, UK
    Beans
    257
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: MX5000 Keyboard Issues

    This started happening to me today. A quick search found this thread:
    http://ubuntuforums.org/showthread.p...reenshot+arrow

    With this solution:
    System -> Preferences -> Keyboard Shortcuts

    Then either disable the two "Take a screenshot" items, or set them to something else. I have mine at Shift F3 & Shift F4
    No man earns punishment, no man earns reward. Free your mind of the idea of deserving, the idea of earning, and you will begin to be able to think.
    Ursula LeGuin, The Dispossessed.
    Member of BOINC Team Ubuntu, spare cpu cycles benefitting humanity.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •