Results 1 to 5 of 5

Thread: local server URL problem

  1. #1
    Join Date
    Feb 2007
    Beans
    135

    local server URL problem

    I am having some problems with Firefox accessing a local servers xampp stack.

    The server name is Jewel and the network id for the system is also jewel.

    In XP I can type in http://jewel and will be pointed to the active server but in ubuntu 8.04 I get the damn thing redirecting to www.jewel.com.
    http://jewel/ is never accepted.

    The only way I can access the server is by IP number (192.168.0.120:80)

    ATM I am developing a website, building a POS system and eventually a mail hub so I really need the correct URL to work with folder names.

    [Edit]I fixed the autocomplete URL feature in Firefox http://support.mozilla.com/en-US/kb/Location+bar+search
    but Ubuntu seems to blocking the server. Once again the ip number works (http://192.168...but it cannot resolve the the server name (http://jewel/) correctly.
    Last edited by pcjunkie; April 23rd, 2008 at 02:50 AM.

  2. #2
    Join Date
    Aug 2005
    Beans
    Hidden!

    Re: local server URL problem

    I don't know about the web server but on a Linux network you typically access other machines on the network with the notation hostname.local. So if the host name is jewel then you should be able to ping jewel.local

  3. #3
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: local server URL problem

    A quick fix would be to add:
    Code:
    192.168.0.120  Jewel
    to your hosts file /etc/hosts. Put it after the last ip4 address in the file and before the ip6 stuff that's there.

    There are more complicated and network wide ways of handling name resolution, but the above will work, and it's easy.

  4. #4
    Join Date
    Feb 2007
    Beans
    135

    Re: local server URL problem

    Quote Originally Posted by jetsam View Post
    A quick fix would be to add:
    Code:
    192.168.0.120  Jewel
    to your hosts file /etc/hosts. Put it after the last ip4 address in the file and before the ip6 stuff that's there.

    There are more complicated and network wide ways of handling name resolution, but the above will work, and it's easy.
    Yes, Worked like treat. While I was there I looked at other files, I really like Ubuntu/Linux...This is much easier than a registry.

    Browsed to etc using sudo nautilus.
    etc/hosts

    127.0.0.1 localhost
    127.0.1.1 noob-desktop
    192.168.0.120 Jasper

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    I was able to use http://jewel/

    Thank you.

  5. #5
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: local server URL problem

    Glad it worked.

    All the configuration files in Linux can be confusing sometimes to new users, but I agree with you-- the openness of the system is a big plus over Windows.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •