Results 1 to 3 of 3

Thread: Avimerge: Video and sound not matching up after merging

  1. #1
    Join Date
    Jan 2008
    Location
    Boston Area, MA, US
    Beans
    12
    Distro
    Xubuntu 8.04 Hardy Heron

    Unhappy [SOLVED]: Avimerge: Video and sound not matching up after merging

    Here's the deal. I'm using avimerge to piece together about 17 AVI videos. However, once I view the output file, the sound is off later on in the video. Is there any way around this? I tried using the "-c" switch which, if I'm reading the man page correctly, should fix the problem, however it did not.

    -c
    Drop video frames in case audio is missing [off]
    Only when merging multiple AVI files. Some AVI
    files run a little bit (usually for one or two
    video frames) short on audio. This means avimerge
    cannot keep up sync when concatinating them. The
    files play fine when played individually but not
    when merged because audio from the new file gets
    played back with video from the old file. avimerge
    will print a message like
    Any ideas guys? Whether it be using avimerge or not, I'd appreciate it.

    Thanks all.
    Last edited by fredmv; April 22nd, 2008 at 07:09 PM.

  2. #2
    Join Date
    Sep 2006
    Location
    USA
    Beans
    56

    Re: Avimerge: Video and sound not matching up after merging

    Have you tried mencoder? Below is a sample of how to combine 3 videos. Just edit it and add all 17 of yours and see what happens.

    mencoder -oac copy -ovc copy vid1.avi vid2.avi vid3.avi -o final.avi
    ...couldn't leave well enough alone.

  3. #3
    Join Date
    Jan 2008
    Location
    Boston Area, MA, US
    Beans
    12
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: Avimerge: Video and sound not matching up after merging

    Quote Originally Posted by heathenx View Post
    Have you tried mencoder? Below is a sample of how to combine 3 videos. Just edit it and add all 17 of yours and see what happens.

    mencoder -oac copy -ovc copy vid1.avi vid2.avi vid3.avi -o final.avi
    Thanks a lot heathenx. Worked perfectly.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •