Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Broadcom 4328 and WPA?

  1. #11
    Join Date
    Mar 2008
    Location
    Los Angeles, CA
    Beans
    146
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Broadcom 4328 and WPA?

    Quote Originally Posted by marlier View Post
    Kutjara --

    I certainly won't say that I've fixed anything, but invoking wpa_supplicant from the command line I was able to get a stable connection when I changed

    ap_scan=1

    to

    ap_scan=0

    in the wpa_supplicant config file. Now if I could just figure out how to get NetworkManager to use that stupid parameter...
    Thanks for that, Marlier. I'll give that a try if I get up the courage to attack the problem again. For now, I'm just going to use my new Belkin dongle and work on the other stuff I need to get working on this machine.

    I'll definitely keep your tip in mind for when I (inevitably) try again.

  2. #12
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broadcom 4328 and WPA?

    I don't know how network manager and wpa_supplicant interact together. However you have a few options to get around this. It seems like you want to use Network Manager in roaming mode. You either need to manually add your changes to the /etc/network/interfaces file (something like this thread: http://ubuntuforums.org/showthread.php?t=318539) -- if that doesn't work you can also call wpa_supplicant directly from the interfaces file with use of the preup statements (more on this later if you want to go this route).

    Also WICD, an alternative to network manager, works much in the same way as the command line, and you can manually alter the parameters it uses to call wpa_supplicant. You could try this in leiu of network manager.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •