Results 1 to 6 of 6

Thread: Desktop Thinks its the Home Directory

  1. #1
    Join Date
    Feb 2008
    Location
    Jamaica
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Unhappy Desktop Thinks its the Home Directory

    couple days back i got some updates from ubutu an as usual i installed them an evry things ok . . tonight wen i turn on my pc all of my folders that was in my home folder eg. Music Document, an program files are all spead out over my desktop . . my destop is full of folders like music, gpass,rkhunter and so much more other files that was in my home folder.
    when i got to places --> Home folder i see desktop filesystem music an all them other folder yet still they r on my desk top ...
    i didnt copy any of them to my desktop and if i delete any of the folders on my desktop they completely move off the system...
    another thing if i try to create a file in my home directory it goes straight to my desktop
    why is that so? does anyone kno wat caused this or wat happen can it be fixed...i'm kinda new to ubuntu can i get som simplified steps to fix this problem

  2. #2
    Join Date
    May 2007
    Location
    Toronto, Canada
    Beans
    4,508
    Distro
    Ubuntu

    Re: Desktop Thinks its the Home Directory

    I don't know what caused that, but I know Ubuntu Tweak has an option to enable that. So getting it and disabling that option could do the trick:

    http://ubuntu-tweak.googlecode.com/f...7Eppa1_all.deb

    Then go to applications - system tools - ubuntu tweak, desktop, desktop icons, and disable "use home folder as desktop".

  3. #3
    Join Date
    Feb 2008
    Location
    Jamaica
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Desktop Thinks its the Home Directory

    i hav ubuntu tweak already installed . .
    jus tried wat u said but the box is already UNCHECKED
    got anymore ideas
    UBUNTU TO DI FLIPPIN WORLD

  4. #4
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,480
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Desktop Thinks its the Home Directory

    Have you maybe been playing around with gconf-editor?

    Press Alt-F2 and type in "gconf-editor". Press Ok. In the left panel, go to apps > nautilus > preferences.

    In the right-pane, you'll see an option called "desktop_is_home_dir". This should have a tick in a box next to it. Click that little box and everything should go back to normal.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  5. #5
    Join Date
    Feb 2008
    Location
    Jamaica
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Desktop Thinks its the Home Directory

    thnx man but that dont seem to work either
    take a look at this thread here (below): http://ubuntuforums.org/showthread.p...op+thinks+home
    see if u can simplify it a bit so i can understand and try it
    UBUNTU TO DI FLIPPIN WORLD

  6. #6
    Join Date
    Dec 2007
    Location
    Adelaide, Australia
    Beans
    678
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Desktop Thinks its the Home Directory

    Alright, to translate that other post into easy chunks:

    - open a terminal (Alt+F2)

    go to /home/[username]
    Code:
    cd /home/[username]
    enter
    Code:
    mkdir Desktop
    go to /home/[username]/.config
    Code:
    cd /home/[username]/.config
    edit user-dirs.dirs
    Code:
    sudo gedit user-dirs.dirs
    find the line that starts with
    XDG_DESKTOP_DIR

    make sure it says
    XDG_DESKTOP_DIR="$HOME/Desktop"

    Save the file

    Reboot

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •