Page 4 of 18 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 174

Thread: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

  1. #31
    Join Date
    Oct 2007
    Beans
    130

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    Quote Originally Posted by AcuraCoupe View Post
    I installed the standard Festvox diphone voices.

    When I tested the voices, I can only hear the noise. Do I need to install any additional sound software?

    This is my testing result:
    Code:
    Festival Speech Synthesis System 1.4.3:release Jan 2003
    Copyright (C) University of Edinburgh, 1996-2003. All rights reserved.
    For details type `(festival_warranty)'
    festival> (voice.list)
    (rab_diphone ked_diphone don_diphone kal_diphone)
    festival> (voice_kal_diphone)
    kal_diphone
    festival> (SayText "Hello from Ubuntu")
    #<Utterance 0xb7195b38>
    festival> (SayText "Hello from Ubuntu")
    #<Utterance 0xb73e45b8>
    festival> (SayText "Hello")            
    #<Utterance 0xb740f8c8>
    I'm not quite sure what to make of this, since it appears to work (the utterance appears to be synthesized properly). Maybe try this:

    Code:
    sudo apt-get install alsa-oss
    ...then try:

    Code:
    echo '(SayText "Hello from Ubuntu")' | aoss festival
    [People] are usually satisfied with bad argument only when their convictions rest on other grounds. (John Oman, Grace and Personality [New York: Macmillan, 1925], p. 38).

  2. #32
    Join Date
    Apr 2008
    Beans
    11

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    I installed the alsa-oss.

    I the command
    Code:
    echo '(SayText "Hello from Ubuntu")' | aoss festival
    but I couldn't hear anything
    Code:
    Segmentation fault (core dumped)
    I use the Virtual Machine VMware to install and run the festival. Is it cause any problems?

    Please help! Thanks.

  3. #33
    Join Date
    Oct 2007
    Beans
    130

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    Quote Originally Posted by AcuraCoupe View Post
    I installed the alsa-oss.

    I the command
    Code:
    echo '(SayText "Hello from Ubuntu")' | aoss festival
    but I couldn't hear anything
    Code:
    Segmentation fault (core dumped)
    What voice were you using? I get segfaults with the Festvox voices. What about the us1 MBROLA voice?

    Code:
    echo '(voice_us1_mbrola) (SayText "Hello from Ubuntu")' | aoss festival
    Next few days I'll try installing the Festvox voices from sources, and if they work that way, I'll add a section for building them from source in the HOWTO.


    Quote Originally Posted by AcuraCoupe View Post
    I use the Virtual Machine VMware to install and run the festival. Is it cause any problems?
    No. Well, it shouldn't at least. I tested it with Dapper (6.10) on a VMware Virtual Machine, and I had no problem ( -- other than the Festvox voices don't work that is; but they also don't work on my real desktop which is Hardy (8.04) -- so that's probably nothing to do with VMware).


    HTH
    [People] are usually satisfied with bad argument only when their convictions rest on other grounds. (John Oman, Grace and Personality [New York: Macmillan, 1925], p. 38).

  4. #34
    Join Date
    Oct 2007
    Beans
    130

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    Actually, I just checked, and with festival-1.96~beta-7ubuntu1 (current version in Hardy, and version built from source in HOWTO), the don_diphone voice does work for me. However, kal / ked / rab_diphone voices still segfault festival. I'll look into building them from source in a day or two. I the mean time, you can try using the MBROLA or Nitech voices (which sound better anyhow, imo).
    [People] are usually satisfied with bad argument only when their convictions rest on other grounds. (John Oman, Grace and Personality [New York: Macmillan, 1925], p. 38).

  5. #35
    Join Date
    Apr 2008
    Beans
    11

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    It works now. The MBROLA voices work with the alsa-oss wrapper.
    Thank You for your patient. I appreciate your help.


    Quote Originally Posted by MonkeeSage View Post
    What voice were you using? I get segfaults with the Festvox voices. What about the us1 MBROLA voice?

    Code:
    echo '(voice_us1_mbrola) (SayText "Hello from Ubuntu")' | aoss festival
    Next few days I'll try installing the Festvox voices from sources, and if they work that way, I'll add a section for building them from source in the HOWTO.




    No. Well, it shouldn't at least. I tested it with Dapper (6.10) on a VMware Virtual Machine, and I had no problem ( -- other than the Festvox voices don't work that is; but they also don't work on my real desktop which is Hardy (8.04) -- so that's probably nothing to do with VMware).


    HTH

  6. #36
    Join Date
    Mar 2008
    Beans
    227

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    Thanks for the howto.

    Edit: Never mind the quality is probably the same as the CMU ones

    They have also multi-syn voices, the quality is similar or maybe just a little better then the CMU ones They are only in the Scottish and Canadian male voices though.

    http://www.cstr.ed.ac.uk/downloads/f...syn-1.0.tar.gz
    http://www.cstr.ed.ac.uk/downloads/f...syn-1.0.tar.gz

    You have to create a directory: /usr/share/festival/voices-multisyn/english
    and move the cstr_us_awb_arctic_multisyn and cstr_us_jmk_arctic_multisyn directories from the tarballs over there.

    Also the festival that comes with Hardy was missing some multysn *.scm files. I downloaded this tarball:

    http://www.cstr.ed.ac.uk/downloads/f...95-beta.tar.gz

    and extracted the *.scm files from the multisyn directory to: /usr/share/festival
    Last edited by monraaf; April 24th, 2008 at 12:33 PM. Reason: Not much difference after all.

  7. #37
    Join Date
    Oct 2007
    Beans
    130

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    Quote Originally Posted by AcuraCoupe View Post
    It works now. The MBROLA voices work with the alsa-oss wrapper.
    Thank You for your patient. I appreciate your help.
    Great! Glad you got it working! You should try the Nitech HTS voices, I personally think they sound the best and they are fairly small to download (see the section in the HOWTO).


    Quote Originally Posted by monraaf View Post
    . . .
    They have also multi-syn voices, the quality is similar or maybe just a little better then the CMU ones They are only in the Scottish and Canadian male voices though.
    . . .
    Ah, I totally forgot about those! Thanks for the reminder. Even if they are of similar quality with the CMU voices, it doesn't hurt to have more options. And given Murphy's Law, somebody, somewhere will want to know how to install them if it's not in the HOWTO. I'll add a section incorporating your instructions later tonight or tomorrow.
    [People] are usually satisfied with bad argument only when their convictions rest on other grounds. (John Oman, Grace and Personality [New York: Macmillan, 1925], p. 38).

  8. #38
    Join Date
    Oct 2007
    Beans
    130

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    Been busy. I'll update the HOWTO this weekend.
    [People] are usually satisfied with bad argument only when their convictions rest on other grounds. (John Oman, Grace and Personality [New York: Macmillan, 1925], p. 38).

  9. #39
    Join Date
    Apr 2006
    Beans
    1

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    I thought I would post this here because I haven't found this anywhere else. In order to get festival to work with pulseaudio in Ubuntu 8.04, add the following three lines to your .festivalrc

    (Parameter.set 'Audio_Command "paplay $FILE")
    (Parameter.set 'Audio_Method 'Audio_Command)
    (Parameter.set 'Audio_Required_Format 'snd)

    This is similar for making it work with alsa, except you use "paplay" instead of "aplay" in the first line.

  10. #40
    Join Date
    Oct 2007
    Beans
    130

    Re: HOWTO: Make festival TTS use better voices (MBROLA / CMU / HTS)

    Quote Originally Posted by jahala View Post
    I thought I would post this here because I haven't found this anywhere else. In order to get festival to work with pulseaudio in Ubuntu 8.04, add the following three lines to your .festivalrc

    (Parameter.set 'Audio_Command "paplay $FILE")
    (Parameter.set 'Audio_Method 'Audio_Command)
    (Parameter.set 'Audio_Required_Format 'snd)

    This is similar for making it work with alsa, except you use "paplay" instead of "aplay" in the first line.
    Nice.

    I understand that you can also use Pulse Audio's wrapper, padsp, in place of esddsp or aoss.
    Last edited by MonkeeSage; May 5th, 2008 at 06:55 AM.
    [People] are usually satisfied with bad argument only when their convictions rest on other grounds. (John Oman, Grace and Personality [New York: Macmillan, 1925], p. 38).

Page 4 of 18 FirstFirst ... 2345614 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •